aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tiff2png
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
commit530706893f31269bbfa303e069f2e76cbbe2fce7 (patch)
treea8077a0d6e20d70b39e6a7fe3e57a6dafe7c7f33 /graphics/tiff2png
parent9d262811a145d3e715edefd1d5d64ceac41de547 (diff)
downloadfreebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.gz
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.zst
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.zip
- update png to 1.5.10
Diffstat (limited to 'graphics/tiff2png')
-rw-r--r--graphics/tiff2png/Makefile4
-rw-r--r--graphics/tiff2png/files/patch-tiff2png.c10
2 files changed, 12 insertions, 2 deletions
diff --git a/graphics/tiff2png/Makefile b/graphics/tiff2png/Makefile
index 56913aec679b..1a7d1099b4fc 100644
--- a/graphics/tiff2png/Makefile
+++ b/graphics/tiff2png/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tiff2png
PORTVERSION= 0.91
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= SF/png-mng/${PORTNAME}/${PORTVERSION}
@@ -17,7 +17,7 @@ COMMENT= Converts TIFF images to PNG format
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
MAKEFILE= Makefile.unx
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/graphics/tiff2png/files/patch-tiff2png.c b/graphics/tiff2png/files/patch-tiff2png.c
new file mode 100644
index 000000000000..ba385e7a7f01
--- /dev/null
+++ b/graphics/tiff2png/files/patch-tiff2png.c
@@ -0,0 +1,10 @@
+--- tiff2png.c.orig 2002-09-13 01:00:00.000000000 +0200
++++ tiff2png.c 2012-04-27 07:10:32.000000000 +0200
+@@ -87,6 +87,7 @@
+ # include "tiffcomp.h" /* not installed by default */
+ #endif
+ #include "png.h"
++#include "zlib.h"
+
+ #ifdef _MSC_VER /* works for MSVC 5.0; need finer tuning? */
+ # define strcasecmp _stricmp