aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tiff
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-12-05 03:40:23 +0800
committerdinoex <dinoex@FreeBSD.org>2003-12-05 03:40:23 +0800
commit45044aca3da0c35f8ea69af747a54586441a1f8f (patch)
treedc343a96f8cbdda1536b08a7dc16cf7235a72155 /graphics/tiff
parent001752b2f1e1e90c314940929911477750b9f8b7 (diff)
downloadfreebsd-ports-gnome-45044aca3da0c35f8ea69af747a54586441a1f8f.tar.gz
freebsd-ports-gnome-45044aca3da0c35f8ea69af747a54586441a1f8f.tar.zst
freebsd-ports-gnome-45044aca3da0c35f8ea69af747a54586441a1f8f.zip
- Fix coredumps with bad tiff-files
http://bugzilla.remotesensing.org/show_bug.cgi?id=440
Diffstat (limited to 'graphics/tiff')
-rw-r--r--graphics/tiff/Makefile1
-rw-r--r--graphics/tiff/files/patch-libtiff-tif_dir.c27
2 files changed, 28 insertions, 0 deletions
diff --git a/graphics/tiff/Makefile b/graphics/tiff/Makefile
index 904b9542d4d9..3a976b39a657 100644
--- a/graphics/tiff/Makefile
+++ b/graphics/tiff/Makefile
@@ -9,6 +9,7 @@
PORTNAME= tiff
PORTVERSION= 3.6.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.remotesensing.org/pub/libtiff/ \
http://libtiff.maptools.org/dl/
diff --git a/graphics/tiff/files/patch-libtiff-tif_dir.c b/graphics/tiff/files/patch-libtiff-tif_dir.c
new file mode 100644
index 000000000000..914100d8e2c8
--- /dev/null
+++ b/graphics/tiff/files/patch-libtiff-tif_dir.c
@@ -0,0 +1,27 @@
+--- libtiff/tif_dir.c.orig Tue Sep 30 08:13:07 2003
++++ libtiff/tif_dir.c Mon Dec 1 15:36:11 2003
+@@ -607,18 +607,18 @@
+ va_end(ap);
+ return (status);
+ badvalue:
+- TIFFError(module, "%.1000s: Bad value %d for \"%s\"", v,
+- tif->tif_name, _TIFFFieldWithTag(tif, tag)->field_name);
++ TIFFError(module, "%.1000s: Bad value %d for \"%s\"",
++ tif->tif_name, v, _TIFFFieldWithTag(tif, tag)->field_name);
+ va_end(ap);
+ return (0);
+ badvalue32:
+- TIFFError(module, "%.1000s: Bad value %ld for \"%s\"", v32,
+- tif->tif_name, _TIFFFieldWithTag(tif, tag)->field_name);
++ TIFFError(module, "%.1000s: Bad value %ld for \"%s\"",
++ tif->tif_name, v32, _TIFFFieldWithTag(tif, tag)->field_name);
+ va_end(ap);
+ return (0);
+ badvaluedbl:
+- TIFFError(module, "%.1000s: Bad value %f for \"%s\"", d,
+- tif->tif_name, _TIFFFieldWithTag(tif, tag)->field_name);
++ TIFFError(module, "%.1000s: Bad value %f for \"%s\"",
++ tif->tif_name, d, _TIFFFieldWithTag(tif, tag)->field_name);
+ va_end(ap);
+ return (0);
+ }