aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tulip
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2012-02-28 17:39:10 +0800
committergahr <gahr@FreeBSD.org>2012-02-28 17:39:10 +0800
commit13567f2f6f69d81bf6f5f338ebf200240cfacb56 (patch)
treef92e2003f77cf3f0dab84f82fcc9c224c4ef9218 /graphics/tulip
parent369c993549a5b1d1de732a687eb63c0f4dd8a00a (diff)
downloadfreebsd-ports-gnome-13567f2f6f69d81bf6f5f338ebf200240cfacb56.tar.gz
freebsd-ports-gnome-13567f2f6f69d81bf6f5f338ebf200240cfacb56.tar.zst
freebsd-ports-gnome-13567f2f6f69d81bf6f5f338ebf200240cfacb56.zip
- Update to 3.7.0
Release notes: http://tulip.labri.fr/TulipDrupal/?q=node/1822
Diffstat (limited to 'graphics/tulip')
-rw-r--r--graphics/tulip/Makefile6
-rw-r--r--graphics/tulip/distinfo8
-rw-r--r--graphics/tulip/files/patch-CMakeLists.txt19
-rw-r--r--graphics/tulip/files/patch-library-tulip-include-tulip_ConsoleUtils.h11
-rw-r--r--graphics/tulip/files/patch-library-tulip-src_CMakeLists.txt11
-rw-r--r--graphics/tulip/files/patch-opengl25
-rw-r--r--graphics/tulip/files/patch-software-crash_handling_CMakeLists.txt13
-rw-r--r--graphics/tulip/files/patch-software-crash_handling_CrashHandling.cpp43
-rw-r--r--graphics/tulip/files/patch-software-crash_handling_StackWalker.cpp15
-rw-r--r--graphics/tulip/files/patch-software-crash_handling_StackWalker.h11
-rw-r--r--graphics/tulip/pkg-plist15
11 files changed, 147 insertions, 30 deletions
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index 9a9807d2e464..d3278ecc340e 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= tulip
-PORTVERSION= 3.6.1
+PORTVERSION= 3.7.0
CATEGORIES= graphics
MASTER_SITES= SF/auber/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX}
@@ -49,10 +49,6 @@ CFLAGS+= -fPIC
BROKEN= does not compile on FreeBSD 7.X
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|<qtimer.h>|<QtCore/qtimer.h>|;s|<qlocale.h>|<QtCore/qlocale.h>|' \
- ${WRKSRC}/software/tulip/src/main.cpp
-
.if !defined(NOPORTDOCS)
DISTFILES+= ${PORTNAME}-${PORTVERSION}-html.tar.bz2
PORTDOCS= *
diff --git a/graphics/tulip/distinfo b/graphics/tulip/distinfo
index dd02dae217d2..9cb3fc77045f 100644
--- a/graphics/tulip/distinfo
+++ b/graphics/tulip/distinfo
@@ -1,4 +1,4 @@
-SHA256 (tulip-3.6.1-src.tar.gz) = 38744be827d98841c055103beeb6518ff69fc9d5e6ff9018252dd6776efde634
-SIZE (tulip-3.6.1-src.tar.gz) = 26654339
-SHA256 (tulip-3.6.1-html.tar.bz2) = 30ef3cefcdc60fa79a6bfd2f09fa1a5c99c2cb5c83be7d8ea4b062f1cc0cf540
-SIZE (tulip-3.6.1-html.tar.bz2) = 53416051
+SHA256 (tulip-3.7.0-src.tar.gz) = 5892ef464329d81f7bc17b4c493d8226a384a7582c18bf74a19baede6e920e94
+SIZE (tulip-3.7.0-src.tar.gz) = 21469118
+SHA256 (tulip-3.7.0-html.tar.bz2) = 0e4d44c5289f4229dcd6bd0867aadd1881b5d2cd2d3cbc9c6e5438677e52a73f
+SIZE (tulip-3.7.0-html.tar.bz2) = 54061118
diff --git a/graphics/tulip/files/patch-CMakeLists.txt b/graphics/tulip/files/patch-CMakeLists.txt
index 144f3bd7862a..afa864cc4bb0 100644
--- a/graphics/tulip/files/patch-CMakeLists.txt
+++ b/graphics/tulip/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2011-08-03 09:12:07.000000000 +0200
-+++ CMakeLists.txt 2011-08-03 09:14:33.000000000 +0200
-@@ -230,8 +230,8 @@
+--- CMakeLists.txt.orig 2012-02-21 12:23:29.000000000 +0100
++++ CMakeLists.txt 2012-02-24 14:05:03.000000000 +0100
+@@ -266,8 +266,8 @@
SET(TulipBitmapInstallDir ${TulipShareInstallDir}/bitmaps/)
SET(TulipAppleResourcesDir ${TulipAppleContentsDir}Resources/)
ELSE()
@@ -11,3 +11,16 @@
SET(TulipBinInstallDir bin/)
SET(TulipIncludeInstallDir include/)
SET(TulipShareInstallDir share/tulip)
+@@ -395,6 +395,12 @@
+ STRING(COMPARE EQUAL "${UNAME_OUT}" "ia64" I64)
+ ENDIF(NOT I64)
+ IF(NOT I64)
++ STRING(COMPARE EQUAL "${UNAME_OUT}" "amd64" I64)
++ENDIF(NOT I64)
++IF(NOT I64)
++ STRING(COMPARE EQUAL "${UNAME_OUT}" "sparc64" I64)
++ENDIF(NOT I64)
++IF(NOT I64)
+ STRING(COMPARE EQUAL "${UNAME_OUT}" "Power Macintosh" MACPPC)
+ ENDIF(NOT I64)
+ IF(I64)
diff --git a/graphics/tulip/files/patch-library-tulip-include-tulip_ConsoleUtils.h b/graphics/tulip/files/patch-library-tulip-include-tulip_ConsoleUtils.h
new file mode 100644
index 000000000000..7cfad6b8b119
--- /dev/null
+++ b/graphics/tulip/files/patch-library-tulip-include-tulip_ConsoleUtils.h
@@ -0,0 +1,11 @@
+--- library/tulip/include/tulip/ConsoleUtils.h.orig 2012-02-24 08:48:00.000000000 +0100
++++ library/tulip/include/tulip/ConsoleUtils.h 2012-02-24 11:18:11.000000000 +0100
+@@ -31,7 +31,7 @@
+ #include <io.h>
+ #endif
+
+-#if defined(__linux) || defined(__APPLE__)
++#if defined(__linux) || defined(__APPLE__) || defined(__FreeBSD__)
+
+ #include <termios.h>
+ #include <sys/ioctl.h>
diff --git a/graphics/tulip/files/patch-library-tulip-src_CMakeLists.txt b/graphics/tulip/files/patch-library-tulip-src_CMakeLists.txt
new file mode 100644
index 000000000000..18dd1ce4801b
--- /dev/null
+++ b/graphics/tulip/files/patch-library-tulip-src_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- library/tulip/src/CMakeLists.txt.orig 2012-02-23 14:11:43.000000000 +0100
++++ library/tulip/src/CMakeLists.txt 2012-02-23 14:11:49.000000000 +0100
+@@ -86,8 +86,6 @@
+ SET_TARGET_PROPERTIES(${LibTulipName} PROPERTIES LINK_FLAGS " /NODEFAULTLIB:LIBCMT.lib ")
+ ENDIF()
+ ENDIF()
+-ELSE(WIN32)
+- TARGET_LINK_LIBRARIES(${LibTulipName} dl)
+ ENDIF(WIN32)
+
+ INSTALL(TARGETS ${LibTulipName}
diff --git a/graphics/tulip/files/patch-opengl b/graphics/tulip/files/patch-opengl
index c40455dc2750..a2166af8e13f 100644
--- a/graphics/tulip/files/patch-opengl
+++ b/graphics/tulip/files/patch-opengl
@@ -9,18 +9,17 @@
ADD_LIBRARY(${LibTulipQtName} SHARED ${tulip-qt_UI_SRCS} ${tulip-qt_MOC_SRCS} ${tulip-qt_RCC_SRCS} ${tulip-qt_LIB_SRCS})
TARGET_LINK_LIBRARIES(${LibTulipQtName} ${GLEW_LIBRARY})
TARGET_LINK_LIBRARIES(${LibTulipQtName} ${OPENGL_glu_LIBRARY})
---- software/tulip/src/CMakeLists.txt.orig 2011-08-04 11:05:06.000000000 +0200
-+++ software/tulip/src/CMakeLists.txt 2011-08-04 11:05:19.000000000 +0200
-@@ -33,7 +33,8 @@
+--- software/tulip/src/CMakeLists.txt.orig 2012-02-22 16:57:38.000000000 +0100
++++ software/tulip/src/CMakeLists.txt 2012-02-22 16:58:06.000000000 +0100
+@@ -33,7 +33,7 @@
TULIP_QT4_WRAP_CPP(tulip_MOC_SRCS ${tulip_MOC} OPTIONS "-DQT_MINOR_REL=${QT_VERSION_MINOR}")
QT4_ADD_RESOURCES(tulip_RCC_SRCS ${tulip_RCC})
-INCLUDE_DIRECTORIES(../include/ ${TulipBuildInclude} ${TulipQtBuildInclude} ${PROJECT_BINARY_DIR}/library/tulip-qt/include/tulip ${PROJECT_BINARY_DIR}/software/tulip/include ${TulipInclude} ${TulipQtInclude} ${TulipOGLInclude} ${TulipPluginsManagerInclude})
-+INCLUDE_DIRECTORIES(../include/ ${TulipBuildInclude} ${TulipQtBuildInclude} ${PROJECT_BINARY_DIR}/library/tulip-qt/include/tulip ${PROJECT_BINARY_DIR}/software/tulip/include ${TulipInclude} ${TulipQtInclude} ${TulipOGLInclude} ${TulipPluginsManagerInclude}
-+ ${OPENGL_INCLUDE_DIR})
++INCLUDE_DIRECTORIES(../include/ ${TulipBuildInclude} ${TulipQtBuildInclude} ${PROJECT_BINARY_DIR}/library/tulip-qt/include/tulip ${PROJECT_BINARY_DIR}/software/tulip/include ${TulipInclude} ${TulipQtInclude} ${TulipOGLInclude} ${TulipPluginsManagerInclude} ${OPENGL_INCLUDE_DIR})
+ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/software/crash_handling)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DQT_MINOR_REL=${QT_VERSION_MINOR}")
-
--- plugins/colors/CMakeLists.txt.orig 2011-08-04 11:14:55.000000000 +0200
+++ plugins/colors/CMakeLists.txt 2011-08-04 11:15:05.000000000 +0200
@@ -1,4 +1,4 @@
@@ -39,17 +38,17 @@
SET(spreadsheet_LIB_SRCS
SpreadView.cpp
---- plugins/view/pythonscriptview/CMakeLists.txt.orig 2011-08-04 12:08:47.000000000 +0200
-+++ plugins/view/pythonscriptview/CMakeLists.txt 2011-08-04 12:09:00.000000000 +0200
+--- plugins/view/pythonscriptview/CMakeLists.txt.orig 2012-02-22 16:59:26.000000000 +0100
++++ plugins/view/pythonscriptview/CMakeLists.txt 2012-02-22 16:59:54.000000000 +0100
@@ -6,7 +6,7 @@
- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DQSCINTILLA_DLL")
+ INCLUDE("${PROJECT_SOURCE_DIR}/${TulipUseFile}")
- # Force to use SIP and QScintilla headers located in thirdparty and not those installed in the system
--INCLUDE_DIRECTORIES(BEFORE ${qscintilla2Include} ${SIP_INCLUDE_DIR})
-+INCLUDE_DIRECTORIES(BEFORE ${qscintilla2Include} ${SIP_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
+ # Force to use SIP headers located in thirdparty and not those installed in the system
+-INCLUDE_DIRECTORIES(BEFORE ${SIP_INCLUDE_DIR})
++INCLUDE_DIRECTORIES(BEFORE ${SIP_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR})
INCLUDE_DIRECTORIES(${TulipInclude} ${TulipBuildInclude} ${TulipOGLInclude} ${TulipQtInclude} ${QT_INCLUDE_DIR} ${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR} ${PYTHON_INCLUDE_DIR} ${PYTHON_INCLUDE_PATH})
- SET(QT_USE_QTWEBKIT true)
+ SET(pythonscriptview_LIB_SRCS
--- plugins/interactor/CMakeLists.txt.orig 2011-08-04 12:22:38.000000000 +0200
+++ plugins/interactor/CMakeLists.txt 2011-08-04 12:22:48.000000000 +0200
@@ -1,4 +1,4 @@
diff --git a/graphics/tulip/files/patch-software-crash_handling_CMakeLists.txt b/graphics/tulip/files/patch-software-crash_handling_CMakeLists.txt
new file mode 100644
index 000000000000..dbef230d0e7d
--- /dev/null
+++ b/graphics/tulip/files/patch-software-crash_handling_CMakeLists.txt
@@ -0,0 +1,13 @@
+--- software/crash_handling/CMakeLists.txt.orig 2012-02-23 12:13:29.000000000 +0100
++++ software/crash_handling/CMakeLists.txt 2012-02-23 12:13:58.000000000 +0100
+@@ -27,10 +27,6 @@
+
+ ADD_LIBRARY(crash_handling STATIC ${LIB_SRCS})
+
+-IF(UNIX)
+- TARGET_LINK_LIBRARIES(crash_handling dl)
+-ENDIF(UNIX)
+-
+ IF(HAVE_BFD)
+ TARGET_LINK_LIBRARIES(crash_handling bfd)
+ ENDIF(HAVE_BFD)
diff --git a/graphics/tulip/files/patch-software-crash_handling_CrashHandling.cpp b/graphics/tulip/files/patch-software-crash_handling_CrashHandling.cpp
new file mode 100644
index 000000000000..5e390354869c
--- /dev/null
+++ b/graphics/tulip/files/patch-software-crash_handling_CrashHandling.cpp
@@ -0,0 +1,43 @@
+--- ./software/crash_handling/CrashHandling.cpp.orig 2012-02-24 13:54:53.000000000 +0100
++++ ./software/crash_handling/CrashHandling.cpp 2012-02-24 15:15:51.000000000 +0100
+@@ -31,11 +31,11 @@
+ /*
+ Linux/MacOS-specific handling
+ */
+-#if defined(__linux) || defined(__APPLE__)
++#if defined(__linux) || defined(__APPLE__) || defined(__FreeBSD__)
+
+ #include "UnixSignalInterposer.h"
+
+-#if defined(__APPLE__)
++#if defined(__APPLE__) || defined(__FreeBSD__)
+ #include <sys/ucontext.h>
+ #else
+
+@@ -54,7 +54,17 @@
+
+ // Get the address at the time the signal was raised from the EIP (x86) or RIP (x86_64)
+
+-#ifndef __APPLE__
++#ifdef __FreeBSD__
++
++ ucontext_t * uc = reinterpret_cast<ucontext_t *>(ucontext);
++#ifndef I64
++ void *callerAddress = reinterpret_cast<void *>(uc->uc_mcontext.mc_eip);
++#else
++ void *callerAddress = reinterpret_cast<void *>(uc->uc_mcontext.mc_rip);
++#endif
++
++#else
++#ifndef (__APPLE__)
+
+ sig_ucontext_t * uc = reinterpret_cast<sig_ucontext_t *>(ucontext);
+ #ifdef I64
+@@ -73,6 +83,7 @@
+ #endif
+
+ #endif
++#endif
+
+ std::cerr << TLP_PLATEFORM_HEADER << " " << OS_PLATFORM << std::endl
+ << TLP_ARCH_HEADER << " " << OS_ARCHITECTURE << std::endl
diff --git a/graphics/tulip/files/patch-software-crash_handling_StackWalker.cpp b/graphics/tulip/files/patch-software-crash_handling_StackWalker.cpp
new file mode 100644
index 000000000000..ff68635bbab5
--- /dev/null
+++ b/graphics/tulip/files/patch-software-crash_handling_StackWalker.cpp
@@ -0,0 +1,15 @@
+--- software/crash_handling/StackWalker.cpp.orig 2012-02-24 15:18:04.000000000 +0100
++++ software/crash_handling/StackWalker.cpp 2012-02-24 15:23:54.000000000 +0100
+@@ -29,10 +29,10 @@
+ printCallStack(std::cerr, maxDepth);
+ }
+
+-#if defined(__linux) || defined(__APPLE__)
++#if defined(__linux) || defined(__APPLE__) || defined(__FreeBSD__)
+
+ #include <cxxabi.h>
+-#ifndef __APPLE__
++#if !defined(__APPLE__) && !defined(__FreeBSD__)
+ #include <execinfo.h>
+ #else
+ #include <dlfcn.h>
diff --git a/graphics/tulip/files/patch-software-crash_handling_StackWalker.h b/graphics/tulip/files/patch-software-crash_handling_StackWalker.h
new file mode 100644
index 000000000000..380cc1c282ac
--- /dev/null
+++ b/graphics/tulip/files/patch-software-crash_handling_StackWalker.h
@@ -0,0 +1,11 @@
+--- software/crash_handling/StackWalker.h.orig 2012-02-24 15:16:55.000000000 +0100
++++ software/crash_handling/StackWalker.h 2012-02-24 15:17:07.000000000 +0100
+@@ -83,7 +83,7 @@
+
+ };
+
+-#if defined(__linux) || defined(__APPLE__)
++#if defined(__linux) || defined(__APPLE__) || defined(__FreeBSD__)
+
+ #include <map>
+
diff --git a/graphics/tulip/pkg-plist b/graphics/tulip/pkg-plist
index 9f03cb02dcea..e4a6ab533233 100644
--- a/graphics/tulip/pkg-plist
+++ b/graphics/tulip/pkg-plist
@@ -41,6 +41,7 @@ include/tulip/ColorScaleConfigDialogData.h
include/tulip/ColorScaleWidget.h
include/tulip/ConcatIterator.h
include/tulip/ConnectedTest.h
+include/tulip/ConsoleUtils.h
include/tulip/Controller.h
include/tulip/ControllerAlgorithmTools.h
include/tulip/ControllerPluginsManager.h
@@ -97,6 +98,7 @@ include/tulip/GlConvexGraphHull.h
include/tulip/GlConvexHull.h
include/tulip/GlCubicBSplineInterpolation.h
include/tulip/GlCurve.h
+include/tulip/GlCylinder.h
include/tulip/GlDisplayListManager.h
include/tulip/GlEdge.h
include/tulip/GlEntity.h
@@ -214,7 +216,6 @@ include/tulip/PluginProgress.h
include/tulip/PluginProgressWidget.h
include/tulip/PluginProgressWidgetData.h
include/tulip/PreferenceManager.h
-include/tulip/PropertyAlgorithm.h
include/tulip/PropertyCreationDialog.h
include/tulip/PropertyCreationDialogData.h
include/tulip/PropertyDialog.h
@@ -271,6 +272,7 @@ include/tulip/TlpQtTools.h
include/tulip/TlpTools.h
include/tulip/TreeTest.h
include/tulip/TriconnectedTest.h
+include/tulip/TulipException.h
include/tulip/TulipPlugin.h
include/tulip/TulipRelease.h
include/tulip/TulipSettings.h
@@ -307,6 +309,7 @@ lib/tlp/glyphs/libCube-%%TULIP_VERSION%%.so
lib/tlp/glyphs/libCubeOutlinedTransparent-%%TULIP_VERSION%%.so
lib/tlp/glyphs/libCylinder-%%TULIP_VERSION%%.so
lib/tlp/glyphs/libDiamond-%%TULIP_VERSION%%.so
+lib/tlp/glyphs/libGlowSphere-%%TULIP_VERSION%%.so
lib/tlp/glyphs/libHalfCylinder-%%TULIP_VERSION%%.so
lib/tlp/glyphs/libHexagone-%%TULIP_VERSION%%.so
lib/tlp/glyphs/libPentagone-%%TULIP_VERSION%%.so
@@ -356,6 +359,8 @@ lib/tlp/libGrid-%%TULIP_VERSION%%.so
lib/tlp/libHierarchicalClustering-%%TULIP_VERSION%%.so
lib/tlp/libHierarchicalGraph-%%TULIP_VERSION%%.so
lib/tlp/libIdMetric-%%TULIP_VERSION%%.so
+lib/tlp/libImportPajek-%%TULIP_VERSION%%.so
+lib/tlp/libImportUCINET-%%TULIP_VERSION%%.so
lib/tlp/libImprovedWalker-%%TULIP_VERSION%%.so
lib/tlp/libInducedSubGraphSelection-%%TULIP_VERSION%%.so
lib/tlp/libKruskal-%%TULIP_VERSION%%.so
@@ -389,6 +394,7 @@ lib/tlp/libTreeRadial-%%TULIP_VERSION%%.so
lib/tlp/libTreeReingoldAndTilforExtended-%%TULIP_VERSION%%.so
lib/tlp/libTutte-%%TULIP_VERSION%%.so
lib/tlp/libWebImport-%%TULIP_VERSION%%.so
+lib/tlp/libdelaunay-%%TULIP_VERSION%%.so
lib/tlp/libftgl.so
lib/tlp/libgzstream.so
lib/tlp/libogdfballoon-%%TULIP_VERSION%%.so
@@ -410,7 +416,6 @@ lib/tlp/libogdfsugiyama-%%TULIP_VERSION%%.so
lib/tlp/libogdftree-%%TULIP_VERSION%%.so
lib/tlp/libogdfupwardplanarization-%%TULIP_VERSION%%.so
lib/tlp/libogdfvisibility-%%TULIP_VERSION%%.so
-lib/tlp/libqscintilla2.so
lib/tlp/libtulip-%%TULIP_VERS%%.so
lib/tlp/libtulip-ogdf-%%TULIP_VERS%%.so
lib/tlp/libtulip-ogl-%%TULIP_VERS%%.so
@@ -461,13 +466,13 @@ lib/tlp/view/libpythonscriptview-%%TULIP_VERSION%%.so
%%DATADIR%%/bitmaps/logo32x32.ico
%%DATADIR%%/bitmaps/logolabri.jpg
%%DATADIR%%/bitmaps/logotulip.jpg
+%%DATADIR%%/bitmaps/radialGradientTexture.png
%%DATADIR%%/bitmaps/roundTexture.png
-%%DATADIR%%/bitmaps/startup.gif
%%DATADIR%%/bitmaps/tex_back.png
%%DATADIR%%/bitmaps/titlebarGradient.png
%%DATADIR%%/bitmaps/welcomelogo.bmp
-%%DATADIR%%/tulip361.qch
-%%DATADIR%%/tulip361.qhc
+%%DATADIR%%/tulip370.qch
+%%DATADIR%%/tulip370.qhc
@dirrm %%DATADIR%%/bitmaps/colorscales
@dirrm %%DATADIR%%/bitmaps
@dirrm %%DATADIR%%/apiFiles