aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xpm
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1998-10-05 04:45:48 +0800
committerJordan K. Hubbard <jkh@FreeBSD.org>1998-10-05 04:45:48 +0800
commit72c0c2273e108129f04c84b0bc5efb37f3dcf87c (patch)
treeaa5780c551ce87651651c72c3d7223b4706c4be5 /graphics/xpm
parent671f995626b4273b9b51b6e97b83f8c5bb69992b (diff)
downloadfreebsd-ports-gnome-72c0c2273e108129f04c84b0bc5efb37f3dcf87c.tar.gz
freebsd-ports-gnome-72c0c2273e108129f04c84b0bc5efb37f3dcf87c.tar.zst
freebsd-ports-gnome-72c0c2273e108129f04c84b0bc5efb37f3dcf87c.zip
Make this actually work on ELF machines. I'm not sure what the
proper canonical thing to do with shared libs that install using minor release numbers these days, but this will work a lot better than what's there in the meantime until I figure it out.
Diffstat (limited to 'graphics/xpm')
-rw-r--r--graphics/xpm/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/xpm/Makefile b/graphics/xpm/Makefile
index 0dcdd6e9193f..9c02914e638b 100644
--- a/graphics/xpm/Makefile
+++ b/graphics/xpm/Makefile
@@ -3,7 +3,7 @@
# Date created: 14 September 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.17 1998/09/16 01:36:13 steve Exp $
+# $Id: Makefile,v 1.18 1998/09/21 21:28:17 steve Exp $
#
DISTNAME= xpm-3.4k
@@ -17,8 +17,8 @@ USE_IMAKE= yes
MAN1= cxpm.1 sxpm.1
post-install:
- if [ "${PORTOBJFORMAT}" = "aout" ]; then \
- ${LN} -sf libXpm.so.4.11 ${PREFIX}/lib/libXpm.so; \
+ if [ "${PORTOBJFORMAT}" = "elf" ]; then \
+ ${LN} -sf libXpm.so.4.11 ${PREFIX}/lib/libXpm.so.4; \
fi
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib