aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/zint/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-03-26 15:21:07 +0800
committerwen <wen@FreeBSD.org>2010-03-26 15:21:07 +0800
commite2e19ff2fc49d5bdf4ab80551ca158092f0c2efd (patch)
tree649c0fb0bbd7613af9043bdbe0775ba61424119e /graphics/zint/Makefile
parentb43578bbe8950d67d8731bdb5cd234b45d0e1aa2 (diff)
downloadfreebsd-ports-gnome-e2e19ff2fc49d5bdf4ab80551ca158092f0c2efd.tar.gz
freebsd-ports-gnome-e2e19ff2fc49d5bdf4ab80551ca158092f0c2efd.tar.zst
freebsd-ports-gnome-e2e19ff2fc49d5bdf4ab80551ca158092f0c2efd.zip
A barcode encoding library supporting over 50 symbologies including Code 128,
Data Matrix, USPS OneCode, EAN-128, UPC/EAN, ITF, QR Code, Code 16k, PDF417, MicroPDF417, LOGMARS, Maxicode, GS1 DataBar, Aztec, Composite Symbols and more. WWW: http://www.zint.org.uk/ PR: ports/144958 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
Diffstat (limited to 'graphics/zint/Makefile')
-rw-r--r--graphics/zint/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/zint/Makefile b/graphics/zint/Makefile
new file mode 100644
index 000000000000..6e5a19633c78
--- /dev/null
+++ b/graphics/zint/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: zint
+# Date created: 2010-03-13
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zint
+PORTVERSION= 2.3.1
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Zint Barcode Generator
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_CMAKE= yes
+CMAKE_USE_PTHREAD= yes
+USE_LDCONFIG= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build designer
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.mk>