aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/zint/files
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-03-26 15:21:07 +0800
committerwen <wen@FreeBSD.org>2010-03-26 15:21:07 +0800
commite2e19ff2fc49d5bdf4ab80551ca158092f0c2efd (patch)
tree649c0fb0bbd7613af9043bdbe0775ba61424119e /graphics/zint/files
parentb43578bbe8950d67d8731bdb5cd234b45d0e1aa2 (diff)
downloadfreebsd-ports-gnome-e2e19ff2fc49d5bdf4ab80551ca158092f0c2efd.tar.gz
freebsd-ports-gnome-e2e19ff2fc49d5bdf4ab80551ca158092f0c2efd.tar.zst
freebsd-ports-gnome-e2e19ff2fc49d5bdf4ab80551ca158092f0c2efd.zip
A barcode encoding library supporting over 50 symbologies including Code 128,
Data Matrix, USPS OneCode, EAN-128, UPC/EAN, ITF, QR Code, Code 16k, PDF417, MicroPDF417, LOGMARS, Maxicode, GS1 DataBar, Aztec, Composite Symbols and more. WWW: http://www.zint.org.uk/ PR: ports/144958 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
Diffstat (limited to 'graphics/zint/files')
-rw-r--r--graphics/zint/files/patch-backend_CMakeLists.txt24
-rw-r--r--graphics/zint/files/patch-backend_code1.c13
-rw-r--r--graphics/zint/files/patch-backend_maxicode.c13
3 files changed, 50 insertions, 0 deletions
diff --git a/graphics/zint/files/patch-backend_CMakeLists.txt b/graphics/zint/files/patch-backend_CMakeLists.txt
new file mode 100644
index 000000000000..e8d354cddcb8
--- /dev/null
+++ b/graphics/zint/files/patch-backend_CMakeLists.txt
@@ -0,0 +1,24 @@
+
+$FreeBSD$
+
+--- backend/CMakeLists.txt.orig
++++ backend/CMakeLists.txt
+@@ -2,7 +2,8 @@
+
+ project(zint)
+
+-find_package(PNG)
++find_package(PNG REQUIRED)
++include_directories(${PNG_INCLUDE_DIR})
+
+ set(zint_COMMON_SRCS common.c library.c ps.c large.c reedsol.c gs1.c svg.c png.c)
+ set(zint_ONEDIM_SRCS code.c code128.c 2of5.c upcean.c telepen.c medical.c plessey.c rss.c)
+@@ -21,7 +22,7 @@
+ set_target_properties(zint PROPERTIES SOVERSION "${ZINT_VERSION_MAJOR}.${ZINT_VERSION_MINOR}"
+ VERSION ${ZINT_VERSION})
+
+-target_link_libraries(zint ${PNG_LIBRARIES} )
++target_link_libraries(zint ${PNG_LIBRARY} )
+
+ install(TARGETS zint ${INSTALL_TARGETS_DEFAULT_ARGS} )
+ install(FILES zint.h DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT Devel)
diff --git a/graphics/zint/files/patch-backend_code1.c b/graphics/zint/files/patch-backend_code1.c
new file mode 100644
index 000000000000..f6a225480d6d
--- /dev/null
+++ b/graphics/zint/files/patch-backend_code1.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- backend/code1.c.orig
++++ backend/code1.c
+@@ -28,7 +28,6 @@
+ #ifdef __APPLE__
+ #include <sys/malloc.h>
+ #else
+-#include <malloc.h>
+ #endif
+
+ void horiz(struct zint_symbol *symbol, int row_no, int full)
diff --git a/graphics/zint/files/patch-backend_maxicode.c b/graphics/zint/files/patch-backend_maxicode.c
new file mode 100644
index 000000000000..f6b242d32e50
--- /dev/null
+++ b/graphics/zint/files/patch-backend_maxicode.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- backend/maxicode.c.orig
++++ backend/maxicode.c
+@@ -29,7 +29,6 @@
+ #ifdef __APPLE__
+ #include <sys/malloc.h>
+ #else
+-#include <malloc.h>
+ #endif
+
+ int maxi_codeword[144];