aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-03 16:49:46 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-03 16:49:46 +0800
commit019f2422aaa071ea4b35d1bc3b69068878ea93d5 (patch)
treee9e009fc092528bdc298f66c506930624e74cb2c /graphics
parent4dfe867ac40f1b052a2f64bf10a0f33f79b55dbe (diff)
downloadfreebsd-ports-gnome-019f2422aaa071ea4b35d1bc3b69068878ea93d5.tar.gz
freebsd-ports-gnome-019f2422aaa071ea4b35d1bc3b69068878ea93d5.tar.zst
freebsd-ports-gnome-019f2422aaa071ea4b35d1bc3b69068878ea93d5.zip
Add an explicit dependency on pkgconf
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aeskulap/Makefile2
-rw-r--r--graphics/geeqie/Makefile2
-rw-r--r--graphics/gx/Makefile8
-rw-r--r--graphics/libgnomecanvasmm/Makefile8
-rw-r--r--graphics/libgnomecanvasmm26/Makefile8
-rw-r--r--graphics/pinta/Makefile9
-rw-r--r--graphics/py-goocanvas/Makefile7
-rw-r--r--graphics/sharpconstruct/Makefile2
-rw-r--r--graphics/xournal/Makefile1
9 files changed, 14 insertions, 33 deletions
diff --git a/graphics/aeskulap/Makefile b/graphics/aeskulap/Makefile
index aba1c3fa371d..f9d719766e8a 100644
--- a/graphics/aeskulap/Makefile
+++ b/graphics/aeskulap/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
glademm-2.4:${PORTSDIR}/devel/libglademm24 \
gconfmm-2.6:${PORTSDIR}/devel/gconfmm26
-USES= gettext
+USES= gettext pkgconfig
USE_GNOME= gconf2
GCONF_SCHEMAS= aeskulap.schemas
USE_LDCONFIG= ${PREFIX}/lib/aeskulap
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index 0efcb1c4a75d..d73c0687cc23 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -13,7 +13,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_GNOME= gtk20 desktopfileutils
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
CONFIGURE_ARGS= --docdir="${DOCSDIR}" \
--htmldir="${DOCSDIR}/html" \
--with-htmldir="${DOCSDIR}/html" \
diff --git a/graphics/gx/Makefile b/graphics/gx/Makefile
index d0d63651ca96..f93dbb6d3875 100644
--- a/graphics/gx/Makefile
+++ b/graphics/gx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gx
-# Date created: 11 June 2007
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gx
PORTVERSION= 0.4.0
@@ -18,7 +14,7 @@ LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
gnomevfsmm-2.6.1:${PORTSDIR}/devel/gnome-vfsmm \
gconfmm-2.6.1:${PORTSDIR}/devel/gconfmm26
-USES= gettext
+USES= gettext pkgconfig
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/graphics/libgnomecanvasmm/Makefile b/graphics/libgnomecanvasmm/Makefile
index ca69343793f7..b1d552ecf851 100644
--- a/graphics/libgnomecanvasmm/Makefile
+++ b/graphics/libgnomecanvasmm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libgnomecanvasmm
-# Date created: 22 May 2003
-# Whom: Alexander Nedotsukov <bland@mail.ru>
-#
+# Created by: Alexander Nedotsukov <bland@mail.ru>
# $FreeBSD$
-#
PORTNAME= libgnomecanvasmm
PORTVERSION= 2.0.1
@@ -18,7 +14,7 @@ COMMENT= C++ wrapper for libgnomecanvas library
LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtkmm20
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomehack libgnomecanvas
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/graphics/libgnomecanvasmm26/Makefile b/graphics/libgnomecanvasmm26/Makefile
index cf01f1720974..febbc70599f2 100644
--- a/graphics/libgnomecanvasmm26/Makefile
+++ b/graphics/libgnomecanvasmm26/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: libgnomecanvasmm
-# Date created: 22 May 2003
-# Whom: Alexander Nedotsukov <bland@mail.ru>
-#
+# Created by: Alexander Nedotsukov <bland@mail.ru>
# $FreeBSD$
# $MCom: ports/graphics/libgnomecanvasmm26/Makefile,v 1.22 2009/03/17 15:05:06 kwm Exp $
-#
PORTNAME= libgnomecanvasmm
PORTVERSION= 2.26.0
@@ -21,8 +17,8 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
LATEST_LINK= libgnomecanvasmm26
+USES= gmake pkgconfig
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= gnomehack libgnomecanvas
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/graphics/pinta/Makefile b/graphics/pinta/Makefile
index 9370499cdec4..fd6544fe0a06 100644
--- a/graphics/pinta/Makefile
+++ b/graphics/pinta/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pinta
-# Date created: 2011-02-14
-# Whom: Alexander Kojevnikov <alexander@kojevnikov.com>
-#
+# Created by: Alexander Kojevnikov <alexander@kojevnikov.com>
# $FreeBSD$
-#
PORTNAME= pinta
PORTVERSION= 1.4
@@ -18,11 +14,10 @@ LICENSE= MIT
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/mono-addins.pc:${PORTSDIR}/devel/mono-addins
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack gtksharp20 desktopfileutils
INSTALLS_ICONS= yes
-USES= gettext
+USES= gettext gmake pkgconfig
MAN1= pinta.1
MANCOMPRESSED= yes
diff --git a/graphics/py-goocanvas/Makefile b/graphics/py-goocanvas/Makefile
index 6c35468be66e..20a2baf1cbe8 100644
--- a/graphics/py-goocanvas/Makefile
+++ b/graphics/py-goocanvas/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: py-goocanvas
-# Date created: 2006-09-20
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/graphics/py-goocanvas/Makefile,v 1.6 2008/09/22 09:14:41 kwm Exp $
@@ -27,7 +24,7 @@ USE_BZIP2= yes
USE_GNOME= gnomehack pygtk2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-docs
-USE_GMAKE= yes
+USES= gmake pkgconfig
post-patch:
@${REINPLACE_CMD} -e 's|$$(PYGOBJECT_PYGDOCS)/style.css||; \
diff --git a/graphics/sharpconstruct/Makefile b/graphics/sharpconstruct/Makefile
index b6822a61b1b2..2f2a3d7c90cb 100644
--- a/graphics/sharpconstruct/Makefile
+++ b/graphics/sharpconstruct/Makefile
@@ -13,9 +13,9 @@ COMMENT= 3D modeller for organic shapes
LIB_DEPENDS= gtkglextmm-x11-1.2:${PORTSDIR}/x11-toolkits/gtkglextmm \
glademm-2.4:${PORTSDIR}/devel/libglademm24
+USES= gmake pkgconfig
USE_BZIP2= yes
USE_GL= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/graphics/xournal/Makefile b/graphics/xournal/Makefile
index 54d57c0a6d29..db328560dde2 100644
--- a/graphics/xournal/Makefile
+++ b/graphics/xournal/Makefile
@@ -14,6 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= poppler-glib:${PORTSDIR}/graphics/poppler-glib
+USES= pkgconfig
USE_GNOME= desktopfileutils libgnomecanvas
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --docdir="${DOCSDIR}"