aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbillf <billf@FreeBSD.org>1999-04-08 05:50:31 +0800
committerbillf <billf@FreeBSD.org>1999-04-08 05:50:31 +0800
commit03b84835c23fd2c06a9543d2407a5daf9c266573 (patch)
tree29b0f600f2618101af9171fecc8487299e5d010d /graphics
parentc02d72040d0d522e3e11a026530d8c25e72ddf97 (diff)
downloadfreebsd-ports-gnome-03b84835c23fd2c06a9543d2407a5daf9c266573.tar.gz
freebsd-ports-gnome-03b84835c23fd2c06a9543d2407a5daf9c266573.tar.zst
freebsd-ports-gnome-03b84835c23fd2c06a9543d2407a5daf9c266573.zip
Upgrade to v0.40, associated changes.
portlint: don't patch a file and then run it through sed(1). I'm sickened that I did that in this port. Prompted By: Fenner's Distfile-O-Matic
Diffstat (limited to 'graphics')
-rw-r--r--graphics/g2/Makefile13
-rw-r--r--graphics/g2/distinfo2
-rw-r--r--graphics/g2/files/patch-aa15
3 files changed, 16 insertions, 14 deletions
diff --git a/graphics/g2/Makefile b/graphics/g2/Makefile
index 5b6400960aae..7905c385125c 100644
--- a/graphics/g2/Makefile
+++ b/graphics/g2/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: g2
-# Version required: 0.30
+# Version required: 0.40
# Date created: 16 July 1998
# Whom: Bill Fumerola <billf@chc-chimes.com>
#
-# $Id: Makefile,v 1.3 1998/11/29 12:43:05 asami Exp $
+# $Id: Makefile,v 1.4 1998/12/29 18:22:57 billf Exp $
#
-DISTNAME= g2-0.30
+DISTNAME= g2-0.40
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= libs/graphics
@@ -19,13 +19,6 @@ USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${PREFIX}/include/gd"
-post-patch:
-
- ${MV} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.pre_sed
- ${CAT} ${WRKSRC}/Makefile.in.pre_sed | \
- ${SED} -e 's#DIR = /usr#DIR = ${PREFIX}#g' \
- >> ${WRKSRC}/Makefile.in
-
do-build:
cd ${WRKSRC} ; make depend ; make
diff --git a/graphics/g2/distinfo b/graphics/g2/distinfo
index e0596d4e38b1..69f9007b8c26 100644
--- a/graphics/g2/distinfo
+++ b/graphics/g2/distinfo
@@ -1 +1 @@
-MD5 (g2-0.30.tar.gz) = 8de31533b8eb5a4bb61005d631d99b55
+MD5 (g2-0.40.tar.gz) = 5f6f4a426ba9e111ab23dce657afe7cd
diff --git a/graphics/g2/files/patch-aa b/graphics/g2/files/patch-aa
index 4a2928453f5e..0a4746df0f3a 100644
--- a/graphics/g2/files/patch-aa
+++ b/graphics/g2/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.in.old Mon Jul 27 13:12:08 1998
-+++ Makefile.in Mon Jul 27 13:15:39 1998
+--- Makefile.in.orig Wed Apr 7 17:41:01 1999
++++ Makefile.in Wed Apr 7 17:42:04 1999
@@ -25,7 +25,7 @@
FIND = @FIND@
MAKEDEPEND = @MAKEDEPEND@
@@ -8,4 +8,13 @@
+ARFLAGS = -r
BASE_DIR = ./src
- BASE_SRC = $(BASE_DIR)/g2_device.c $(BASE_DIR)/g2_ui_control.c \
+ BASE_SRC = $(BASE_DIR)/g2_device.c $(BASE_DIR)/g2_ui_control.c \
+@@ -70,7 +70,7 @@
+
+ libg2.a: $(OBJ)
+ $(AR) $(ARFLAGS) libg2.a $(OBJ)
+- ln -s libg2.a libg2.0.40.a
++ ln -fs libg2.a libg2.0.40.a
+
+ libg2.so: $(OBJ)
+ $(CC) -shared -o libg2.so $(OBJ) -lc -lm