aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-11-24 02:35:59 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-11-24 02:35:59 +0800
commit05cd33832c59be6d4bf59ddd485d74e169d7c131 (patch)
tree434fcd756f638aa2c8010f9261258512af1e9d32 /graphics
parent03333aa6df401d0b0235bc0f1d9c2c114742e007 (diff)
downloadfreebsd-ports-gnome-05cd33832c59be6d4bf59ddd485d74e169d7c131.tar.gz
freebsd-ports-gnome-05cd33832c59be6d4bf59ddd485d74e169d7c131.tar.zst
freebsd-ports-gnome-05cd33832c59be6d4bf59ddd485d74e169d7c131.zip
- Add missing USES=localbase
- Fix build for dependent ports if OPENMP enabled - Bump PORTREVISION for package change
Diffstat (limited to 'graphics')
-rw-r--r--graphics/GraphicsMagick/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/graphics/GraphicsMagick/Makefile b/graphics/GraphicsMagick/Makefile
index 8780377b675e..aa38a8ffcf4b 100644
--- a/graphics/GraphicsMagick/Makefile
+++ b/graphics/GraphicsMagick/Makefile
@@ -3,7 +3,7 @@
PORTNAME= GraphicsMagick
PORTVERSION= 1.3.23
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= SF \
@@ -32,15 +32,11 @@ CONFIGURE_ENV= PTHREAD_LIBS=-lpthread
INSTALL_TARGET= install-strip
TEST_TARGET= check
USE_LDCONFIG= yes
-USES= jpeg libtool tar:bzip2
+USES= jpeg libtool localbase tar:bzip2
PORTDATA= *
PORTDOCS= *
-# The OPENMP option may select gcc as compiler but on architectures
-# that have switched to libc++ clang should be used for C++ code.
-#CXX= c++
-
# Use fonts installed by x11-fonts/webfonts by default
WINDOWS_FONT_DIR?= ${LOCALBASE}/share/fonts/webfonts
@@ -96,3 +92,7 @@ post-install-Q8BIT-on:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/GraphicsMagick/modules-Q8/coders ${STAGEDIR}${PREFIX}/lib/GraphicsMagick/modules-Q8/filters
.include <bsd.port.mk>
+
+# The OPENMP option may select gcc as compiler but on architectures
+# that have switched to libc++ clang should be used for C++ code.
+CXX= c++