aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-07-11 12:02:06 +0800
committerdinoex <dinoex@FreeBSD.org>2013-07-11 12:02:06 +0800
commit09370355b27bb4602b9a30e868114b65dc43316f (patch)
tree20a1db292c1cbeeef43526b95544716fa2aff310 /graphics
parent3dbef4749a268208ce46ff8e360d7447a8977531 (diff)
downloadfreebsd-ports-gnome-09370355b27bb4602b9a30e868114b65dc43316f.tar.gz
freebsd-ports-gnome-09370355b27bb4602b9a30e868114b65dc43316f.tar.zst
freebsd-ports-gnome-09370355b27bb4602b9a30e868114b65dc43316f.zip
- fix build when DEBUG is set
PR: 180361 Submitted by: Raphael Kubo da Costa
Diffstat (limited to 'graphics')
-rw-r--r--graphics/png/Makefile4
-rw-r--r--graphics/png/files/patch-CMakeLists.txt12
-rw-r--r--graphics/png/pkg-plist2
3 files changed, 13 insertions, 5 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index f8b10dc063e7..9d380f965864 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -31,10 +31,6 @@ APNG_DESC=Enable Animated PNG support
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
-BROKEN= Please remove WITH_DEBUG for this port
-.endif
-
.if ${PORT_OPTIONS:MAPNG} || make(makesum) || defined(FETCH_ALL)
MASTER_SITES+= SF/apng/libpng/libpng15/:apng
DISTFILES+= ${DISTNAME}-apng.patch.gz:apng
diff --git a/graphics/png/files/patch-CMakeLists.txt b/graphics/png/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1c2eac4c7a5d
--- /dev/null
+++ b/graphics/png/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt~ 2013-07-07 13:31:51.000000000 +0300
++++ CMakeLists.txt 2013-07-07 13:32:01.000000000 +0300
+@@ -59,9 +59,6 @@
+ # SET LIBNAME
+ set(PNG_LIB_NAME png${PNGLIB_MAJOR}${PNGLIB_MINOR})
+
+-# to distinguish between debug and release lib
+-set(CMAKE_DEBUG_POSTFIX "d")
+-
+ # Use the prebuilt pnglibconf.h file from the scripts folder
+ # TODO: fix this by building with awk; without this no cmake build can be
+ # configured directly (to do so indirectly use your local awk to build a
diff --git a/graphics/png/pkg-plist b/graphics/png/pkg-plist
index 9bc30bd4dc93..35ffc43d6ba8 100644
--- a/graphics/png/pkg-plist
+++ b/graphics/png/pkg-plist
@@ -14,7 +14,7 @@ lib/libpng.a
lib/libpng.so
libdata/pkgconfig/libpng15.pc
libdata/pkgconfig/libpng.pc
-lib/libpng/libpng15-release.cmake
+lib/libpng/libpng15-%%CMAKE_BUILD_TYPE%%.cmake
lib/libpng/libpng15.cmake
lib/libpng15.a
lib/libpng15.so