aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-23 06:07:20 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-23 06:07:20 +0800
commit09f2465460db8ce911234591475e7f575e365cc5 (patch)
treeee19c80cf8ca55a9ca35c8b7bb51171640330e47 /graphics
parentc01efe497229825080fdd9fbeb7f4d4adc8fe32a (diff)
downloadfreebsd-ports-gnome-09f2465460db8ce911234591475e7f575e365cc5.tar.gz
freebsd-ports-gnome-09f2465460db8ce911234591475e7f575e365cc5.tar.zst
freebsd-ports-gnome-09f2465460db8ce911234591475e7f575e365cc5.zip
Stage support
Diffstat (limited to 'graphics')
-rw-r--r--graphics/imagesort/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/graphics/imagesort/Makefile b/graphics/imagesort/Makefile
index c29792b8f9ec..85658f89bdbb 100644
--- a/graphics/imagesort/Makefile
+++ b/graphics/imagesort/Makefile
@@ -12,9 +12,9 @@ COMMENT= A flexible X utility for managing many image files
LICENSE= GPLv2
-LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib \
- jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png
OPTIONS_DEFINE= DOCS
@@ -24,9 +24,6 @@ USE_GNOME= imlib
PORTDOCS= README imagesortrc.sample
PLIST_FILES= bin/imagesort
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e \
'/^CC/s| =| ?=| ; \
@@ -37,12 +34,8 @@ post-patch:
s|^#endif.*|#endif|' ${WRKSRC}/imagesort.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/imagesort ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/imagesort ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>