aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-09-02 05:34:14 +0800
committershaun <shaun@FreeBSD.org>2006-09-02 05:34:14 +0800
commit0d036cb7c3190f317cd302f419f7cd80a0464cbc (patch)
tree355beb0145e8dd5c732235fa1264ca9ccc60a0b4 /graphics
parenta7951193551cefc62c77c5bbe19d20279d0392a9 (diff)
downloadfreebsd-ports-gnome-0d036cb7c3190f317cd302f419f7cd80a0464cbc.tar.gz
freebsd-ports-gnome-0d036cb7c3190f317cd302f419f7cd80a0464cbc.tar.zst
freebsd-ports-gnome-0d036cb7c3190f317cd302f419f7cd80a0464cbc.zip
- Take over maintainership of the abandoned SDL ports.
- Add an additional mirror for a few of them. - Fix a few minor portlint(1) complaints.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sdl_gfx/Makefile7
-rw-r--r--graphics/sdl_image/Makefile4
-rw-r--r--graphics/sdl_ttf/Makefile4
3 files changed, 8 insertions, 7 deletions
diff --git a/graphics/sdl_gfx/Makefile b/graphics/sdl_gfx/Makefile
index 403cd5e0c172..9f037eaed623 100644
--- a/graphics/sdl_gfx/Makefile
+++ b/graphics/sdl_gfx/Makefile
@@ -10,11 +10,12 @@ PORTNAME= sdl_gfx
PORTVERSION= 2.0.13
PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= http://www.ferzkopp.net/Software/%SUBDIR%/
+MASTER_SITES= http://www.ferzkopp.net/Software/%SUBDIR%/ \
+ http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
MASTER_SITE_SUBDIR= SDL_gfx-${PORTVERSION:R}
DISTNAME= SDL_gfx-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@FreeBSD.org
COMMENT= SDL graphics drawing primitives and other support functions
USE_SDL= sdl
@@ -25,7 +26,7 @@ CONFIGURE_ARGS= --includedir=${PREFIX}/include/SDL11 \
--disable-mmx
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index 1e4b95c129a2..2cddb43cb7ed 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
DISTNAME= SDL_image-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@FreeBSD.org
COMMENT= A simple library to load images of various formats as SDL surfaces
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -27,7 +27,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
CONFIGURE_ARGS= --enable-tif --enable-xcf
MAKE_ARGS= LT_CURRENT=10 LT_REVISION=0 LT_AGE=0
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/.libs/showimage ${PREFIX}/bin
diff --git a/graphics/sdl_ttf/Makefile b/graphics/sdl_ttf/Makefile
index eca56d1cdfcd..ae116d263136 100644
--- a/graphics/sdl_ttf/Makefile
+++ b/graphics/sdl_ttf/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_ttf/release/
DISTNAME= SDL_ttf-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@FreeBSD.org
COMMENT= A library to use TrueType fonts to render text in SDL applications
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
@@ -25,7 +25,7 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ARGS= LT_CURRENT=3 LT_REVISION=0 LT_AGE=0
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/.libs/glfont ${PREFIX}/bin