aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2016-07-06 02:46:45 +0800
committerrene <rene@FreeBSD.org>2016-07-06 02:46:45 +0800
commit117cba92b3c0bf1ddad410aec5e57ff36a960131 (patch)
tree4ddc681753ecb37ad1c303b82beb140f4fc19dcd /graphics
parentc322a7290210afce4813aa5591258b822169086a (diff)
downloadfreebsd-ports-gnome-117cba92b3c0bf1ddad410aec5e57ff36a960131.tar.gz
freebsd-ports-gnome-117cba92b3c0bf1ddad410aec5e57ff36a960131.tar.zst
freebsd-ports-gnome-117cba92b3c0bf1ddad410aec5e57ff36a960131.zip
Remove expired ports:
games/freetennis: depends on expired graphics/ocaml-images 2016-07-04 graphics/ocaml-images: Depends on expiring devel/omake 2016-07-04 devel/omake: Broken for more than 6 months
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/ocaml-images/Makefile90
-rw-r--r--graphics/ocaml-images/distinfo2
-rw-r--r--graphics/ocaml-images/files/patch-OMakefile20
-rw-r--r--graphics/ocaml-images/files/patch-src_OMakefile15
-rw-r--r--graphics/ocaml-images/files/patch-src_gifread.c34
-rw-r--r--graphics/ocaml-images/files/patch-src_gifwrite.c55
-rw-r--r--graphics/ocaml-images/files/patch-src_jpegread.c11
-rw-r--r--graphics/ocaml-images/files/patch-src_pngread.c38
-rw-r--r--graphics/ocaml-images/files/patch-src_pngwrite.c20
-rw-r--r--graphics/ocaml-images/files/patch-src_tiffread.c36
-rw-r--r--graphics/ocaml-images/files/patch-src_tiffwrite.c28
-rw-r--r--graphics/ocaml-images/pkg-descr7
-rw-r--r--graphics/ocaml-images/pkg-plist146
14 files changed, 0 insertions, 503 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4b42f6636b89..0583a6be11e9 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -601,7 +601,6 @@
SUBDIR += npretty
SUBDIR += nurbs++
SUBDIR += nvidia-texture-tools
- SUBDIR += ocaml-images
SUBDIR += ocaml-lablgl
SUBDIR += ocrad
SUBDIR += ocre
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
deleted file mode 100644
index eaa6bcfff43d..000000000000
--- a/graphics/ocaml-images/Makefile
+++ /dev/null
@@ -1,90 +0,0 @@
-# Created by: ijliao
-# $FreeBSD$
-
-PORTNAME= images
-PORTVERSION= 4.0.1
-PORTREVISION= 7
-PORTEPOCH= 2
-CATEGORIES= graphics
-MASTER_SITES= https://bitbucket.org/camlspotter/camlimages/get/
-PKGNAMEPREFIX= ocaml-
-DISTNAME= v${PORTVERSION}
-DIST_SUBDIR= ocaml-images
-
-MAINTAINER= michael.grunewald@laposte.net
-COMMENT= Objective Caml image processing library
-
-DEPRECATED= Depends on expiring devel/omake
-EXPIRATION_DATE= 2016-07-04
-
-BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ocaml.m4:lang/ocaml-autoconf
-BUILD_DEPENDS+= omake:devel/omake
-
-USE_OCAML= yes
-USE_OCAML_FINDLIB= yes
-OCAMLFIND_DESTDIR= ${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}
-
-OCAML_PKGDIRS= camlimages
-OCAML_LDLIBS= ${OCAML_SITELIBDIR}/camlimages
-
-OMAKESUBS+= -e s@%%INCLUDESPORTS%%@${LOCALBASE}/include@
-OMAKESUBS+= -e s@%%INCLUDESX11%%@${LOCALBASE}/include/X11@
-OMAKESUBS+= -e s@%%INCLUDESPNG%%@${LOCALBASE}/include/libpng15@
-OMAKESUBS+= -e s@%%LDFLAGSPORTS%%@-L${LOCALBASE}/lib@
-
-OMAKE= omake 'PREFIX=${STAGEDIR}${PREFIX}'
-OMARGS= --dotomake .omake --force-dotomake
-WRKSRC= ${WRKDIR}/camlspotter-camlimages-c803efa9d5d3
-
-MAKE_JOBS_UNSAFE= yes
-
-OPTIONS_DEFINE= PNG JPEG TIFF XPM GIF FREETYPE GHOSTSCRIPT GTK2 DOCS
-OPTIONS_DEFAULT=PNG JPEG TIFF XPM GIF FREETYPE GHOSTSCRIPT
-OPTIONS_SUB= yes
-
-PNG_CONFIGURE_WITH= png
-PNG_LIB_DEPENDS= libpng.so:graphics/png
-
-JPEG_CONFIGURE_WITH= jpeg
-JPEG_USES= jpeg
-
-TIFF_CONFIGURE_WITH= tiff
-TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
-
-XPM_CONFIGURE_WITH= xpm
-
-GIF_CONFIGURE_WITH= gif
-GIF_LIB_DEPENDS= libgif.so:graphics/giflib
-
-FREETYPE_CONFIGURE_WITH=freetype
-FREETYPE_LIB_DEPENDS= libttf.so:print/freetype
-
-GHOSTSCRIPT_CONFIGURE_WITH= gs
-GHOSTSCRIPT_USES= ghostscript
-
-GTK2_CONFIGURE_WITH= liblgtk2
-GTK2_BUILD_DEPENDS= lablgtk2:x11-toolkits/ocaml-lablgtk2
-GTK2_RUN_DEPENDS= lablgtk2:x11-toolkits/ocaml-lablgtk2
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MXPM}
-USE_XORG= xpm
-.endif
-
-do-configure:
- @(cd ${WRKSRC} && ${REINPLACE_CMD} ${OMAKESUBS} OMakefile)
- (cd ${WRKSRC} && ${OMAKE} ${OMARGS} configure)
-
-do-build:
- (cd ${WRKSRC} && ${OMAKE} ${OMARGS})
-
-ocaml-findlib:
- # Overriding ocaml-findlib target which does not support stage
- # The consequence is that pkg-plist must be manually supported
-
-do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/${OCAML_LDLIBS}
- (cd ${WRKSRC} && ${OMAKE} ${OMARGS} install)
-
-.include <bsd.port.mk>
diff --git a/graphics/ocaml-images/distinfo b/graphics/ocaml-images/distinfo
deleted file mode 100644
index 292653df98ca..000000000000
--- a/graphics/ocaml-images/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ocaml-images/v4.0.1.tar.gz) = b40237c1505487049799a7af296eb3996b3fa08eab94415546f46d61355747c4
-SIZE (ocaml-images/v4.0.1.tar.gz) = 2190274
diff --git a/graphics/ocaml-images/files/patch-OMakefile b/graphics/ocaml-images/files/patch-OMakefile
deleted file mode 100644
index 469d16c417d5..000000000000
--- a/graphics/ocaml-images/files/patch-OMakefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- OMakefile.orig 2012-11-07 22:03:19.000000000 +0100
-+++ OMakefile 2012-11-07 22:04:26.000000000 +0100
-@@ -22,13 +22,13 @@
-
- # Specify non standard include directories
- INCLUDES[]=
-- /usr/include/X11
-- /usr/local/include
-+ %%INCLUDESPORTS%%
-+ %%INCLUDESX11%%
-+ %%INCLUDESPNG%%
-
- # Specify non standard library directories
- LDFLAGS[]+=
--# for example,
--# LDFLAGS[]+= -L/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/
-+ %%LDFLAGSPORTS%%
-
- # Specify directories where X's rgb.txt can be found
- PATH_RGB_TXT[]=
diff --git a/graphics/ocaml-images/files/patch-src_OMakefile b/graphics/ocaml-images/files/patch-src_OMakefile
deleted file mode 100644
index c6d85cfd4037..000000000000
--- a/graphics/ocaml-images/files/patch-src_OMakefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/OMakefile.orig 2012-11-07 22:43:27.000000000 +0100
-+++ src/OMakefile 2012-11-07 22:44:22.000000000 +0100
-@@ -262,10 +262,10 @@
- $(glob i, *.so)
-
- INSTALL()=
-- value $(OCAMLFIND) install $(LIBRARY_PREFIX) $(INSTALL_TARGETS)
-+ value $(OCAMLFIND) install -ldconf ignore -destdir $(PREFIX)/lib/ocaml/site-lib $(LIBRARY_PREFIX) $(INSTALL_TARGETS)
-
- UNINSTALL()=
-- value $(OCAMLFIND) remove $(LIBRARY_PREFIX)
-+ value $(OCAMLFIND) remove -ldconf ignore -destdir $(PREFIX)/lib/ocaml/site-lib $(LIBRARY_PREFIX)
-
- install: all
- $(INSTALL)
diff --git a/graphics/ocaml-images/files/patch-src_gifread.c b/graphics/ocaml-images/files/patch-src_gifread.c
deleted file mode 100644
index c2b49558342c..000000000000
--- a/graphics/ocaml-images/files/patch-src_gifread.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/gifread.c.orig 2011-06-22 18:04:32 UTC
-+++ src/gifread.c
-@@ -140,7 +140,11 @@ value dGifOpenFileName( value name )
- GifFileType *GifFile;
- int i;
-
-+#if GIFLIB_MAJOR >= 5
-+ if((GifFile = DGifOpenFileName( String_val(name), NULL )) == NULL){
-+#else
- if((GifFile = DGifOpenFileName( String_val(name) )) == NULL){
-+#endif
- failwith("DGifOpenFileName");
- }
-
-@@ -161,7 +165,11 @@ value dGifCloseFile( value hdl )
- segmentation faults */
- ((GifFileType *)hdl)->Image.ColorMap = NULL;
-
-+#if GIFLIB_MAJOR == 5 && GIFLIB_MINOR >= 1 || GIFLIB_MAJOR > 5
-+ DGifCloseFile( (GifFileType *) hdl, NULL );
-+#else
- DGifCloseFile( (GifFileType *) hdl );
-+#endif
- CAMLreturn(Val_unit);
- }
-
-@@ -200,7 +208,6 @@ value dGifGetLine( value hdl )
-
- if( DGifGetLine(GifFile, String_val(buf), GifFile->Image.Width )
- == GIF_ERROR ){
-- PrintGifError ();
- failwith("DGifGetLine");
- }
- CAMLreturn(buf);
diff --git a/graphics/ocaml-images/files/patch-src_gifwrite.c b/graphics/ocaml-images/files/patch-src_gifwrite.c
deleted file mode 100644
index 0fbcede2549c..000000000000
--- a/graphics/ocaml-images/files/patch-src_gifwrite.c
+++ /dev/null
@@ -1,55 +0,0 @@
---- src/gifwrite.c.orig 2011-06-22 18:04:32 UTC
-+++ src/gifwrite.c
-@@ -25,7 +25,7 @@
-
- #include <gif_lib.h>
-
--int list_length( value list )
-+static int list_length( value list )
- {
- CAMLparam1(list);
- CAMLlocal1(l);
-@@ -52,7 +52,11 @@ ColorMapObject *ColorMapObject_val( valu
- fprintf(stderr, "Creating map with length = %d ...\n", len);
- fflush(stderr);
- */
-+#if GIFLIB_MAJOR >= 5
-+ cmapobj = GifMakeMapObject( len, NULL );
-+#else
- cmapobj = MakeMapObject( len, NULL );
-+#endif
- for(i=0; i< len; i++){
- cmapobj->Colors[i].Red = Int_val(Field(Field(cmap,i),0));
- cmapobj->Colors[i].Green = Int_val(Field(Field(cmap,i),1));
-@@ -68,7 +72,11 @@ value eGifOpenFileName( name )
-
- GifFileType *GifFileOut;
-
-+#if GIFLIB_MAJOR >= 5
-+ if ((GifFileOut = EGifOpenFileName( String_val( name ), 0, NULL) )== NULL) {
-+#else
- if ((GifFileOut = EGifOpenFileName( String_val( name ), 0) )== NULL) {
-+#endif
- failwith("EGifOpenFileName");
- }
- /* gcc -fwritable-strings is required to compile libungif */
-@@ -88,7 +96,11 @@ value eGifCloseFile( value hdl )
- segmentation faults */
- ((GifFileType *)hdl)->Image.ColorMap = NULL;
-
-+#if GIFLIB_MAJOR == 5 && GIFLIB_MINOR >= 1 || GIFLIB_MAJOR > 5
-+ EGifCloseFile( (GifFileType *) hdl, NULL );
-+#else
- EGifCloseFile( (GifFileType *) hdl );
-+#endif
- CAMLreturn(Val_unit);
- }
-
-@@ -133,7 +145,6 @@ value eGifPutLine( value oc, value buf )
-
- if ( EGifPutLine(GifFileOut, String_val(buf), GifFileOut->Image.Width)
- == GIF_ERROR ){
-- PrintGifError ();
- failwith("EGifPutLine");
- }
- CAMLreturn(Val_unit);
diff --git a/graphics/ocaml-images/files/patch-src_jpegread.c b/graphics/ocaml-images/files/patch-src_jpegread.c
deleted file mode 100644
index 4369ab05fd9d..000000000000
--- a/graphics/ocaml-images/files/patch-src_jpegread.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/jpegread.c.orig 2011-06-22 20:04:32.000000000 +0200
-+++ src/jpegread.c
-@@ -417,7 +417,7 @@
- jpeg_read_scanlines( cinfop, row, 1 );
- row[0] += scanline_bytes;
- }
-- CAMLreturn0;
-+ CAMLreturn(0);
- }
-
- value close_jpeg_file_for_read( jpegh )
diff --git a/graphics/ocaml-images/files/patch-src_pngread.c b/graphics/ocaml-images/files/patch-src_pngread.c
deleted file mode 100644
index 2e5a49bf9c4f..000000000000
--- a/graphics/ocaml-images/files/patch-src_pngread.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/pngread.c.orig 2009-10-26 13:42:03.000000000 +0100
-+++ src/pngread.c 2012-05-05 07:08:53.000000000 +0200
-@@ -69,7 +69,7 @@
- }
-
- /* error handling */
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- /* Free all of the memory associated with the png_ptr and info_ptr */
- png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
- fclose(fp);
-@@ -134,7 +134,7 @@
- png_set_rows(png_ptr, info_ptr, row_pointers);
-
- /* Later, we can return something */
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- /* Free all of the memory associated with the png_ptr and info_ptr */
- png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
- fclose(fp);
-@@ -243,7 +243,7 @@
- }
-
- /* error handling */
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- /* Free all of the memory associated with the png_ptr and info_ptr */
- png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
- fclose(fp);
-@@ -302,7 +302,7 @@
- png_set_rows(png_ptr, info_ptr, row_pointers);
-
- /* Later, we can return something */
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- /* Free all of the memory associated with the png_ptr and info_ptr */
- png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
- fclose(fp);
diff --git a/graphics/ocaml-images/files/patch-src_pngwrite.c b/graphics/ocaml-images/files/patch-src_pngwrite.c
deleted file mode 100644
index dc6872e299d7..000000000000
--- a/graphics/ocaml-images/files/patch-src_pngwrite.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/pngwrite.c.orig 2009-10-26 13:42:03.000000000 +0100
-+++ src/pngwrite.c 2012-05-06 13:01:28.000000000 +0200
-@@ -62,7 +62,7 @@
- }
-
- /* error handling */
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- /* Free all of the memory associated with the png_ptr and info_ptr */
- png_destroy_write_struct(&png_ptr, &info_ptr);
- fclose(fp);
-@@ -171,7 +171,7 @@
- }
-
- /* error handling */
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- /* Free all of the memory associated with the png_ptr and info_ptr */
- png_destroy_write_struct(&png_ptr, &info_ptr);
- fclose(fp);
diff --git a/graphics/ocaml-images/files/patch-src_tiffread.c b/graphics/ocaml-images/files/patch-src_tiffread.c
deleted file mode 100644
index 73b684a3408e..000000000000
--- a/graphics/ocaml-images/files/patch-src_tiffread.c
+++ /dev/null
@@ -1,36 +0,0 @@
---- src/tiffread.c.orig 2011-06-22 20:04:32.000000000 +0200
-+++ src/tiffread.c
-@@ -23,14 +23,22 @@
-
- #include "oversized.h"
-
-+/* Avoid redefinitions */
-+#undef int16
-+#undef uint16
- /* These are defined in caml/config.h */
- #define int16 int16tiff
- #define uint16 uint16tiff
- #define int32 int32tiff
- #define uint32 uint32tiff
-+#define int64 int64tiff
-+#define uint64 uint64tiff
-
- #include <tiffio.h>
-
-+#undef int64
-+#undef uint64
-+
- extern value *imglib_error;
-
- value open_tiff_file_for_read( name )
-@@ -70,6 +78,10 @@
- failwith_oversized("tiff");
- }
-
-+ if (oversized (imagewidth, imagelength)) {
-+ failwith_oversized("tiff");
-+ }
-+
- if( imagesample == 3 && photometric == PHOTOMETRIC_RGB ){
- if( imagebits != 8 ){
- failwith("Sorry, tiff rgb file must be 24bit-color");
diff --git a/graphics/ocaml-images/files/patch-src_tiffwrite.c b/graphics/ocaml-images/files/patch-src_tiffwrite.c
deleted file mode 100644
index 2e50b0b217b6..000000000000
--- a/graphics/ocaml-images/files/patch-src_tiffwrite.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/tiffwrite.c.orig 2011-06-22 20:04:32.000000000 +0200
-+++ src/tiffwrite.c
-@@ -20,11 +20,16 @@
- #include <caml/memory.h>
- #include <caml/fail.h>
-
-+/* Avoid redefinitions */
-+#undef int16
-+#undef uint16
- /* These are defined in caml/config.h */
- #define int16 int16tiff
- #define uint16 uint16tiff
- #define int32 int32tiff
- #define uint32 uint32tiff
-+#define int64 int64tiff
-+#define uint64 uint64tiff
-
- #include <tiffio.h>
-
-@@ -32,6 +37,8 @@
- #undef uint16
- #undef int32
- #undef uint32
-+#undef int64
-+#undef uint64
-
- extern value *imglib_error;
-
diff --git a/graphics/ocaml-images/pkg-descr b/graphics/ocaml-images/pkg-descr
deleted file mode 100644
index 26acfb0be000..000000000000
--- a/graphics/ocaml-images/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-This is an image processing library, which provides some basic functions of
-image processing and loading/saving various image file formats. In addition
-the library can handle huge images that cannot be (or can hardly be) stored
-into the memory (the library automatically creates swap files and escapes
-them to reduce the memory usage).
-
-WWW: http://pauillac.inria.fr/camlimages/
diff --git a/graphics/ocaml-images/pkg-plist b/graphics/ocaml-images/pkg-plist
deleted file mode 100644
index 7efe825a7f46..000000000000
--- a/graphics/ocaml-images/pkg-plist
+++ /dev/null
@@ -1,146 +0,0 @@
-lib/ocaml/site-lib/camlimages/META
-lib/ocaml/site-lib/camlimages/bitmap.cmi
-lib/ocaml/site-lib/camlimages/bitmap.mli
-lib/ocaml/site-lib/camlimages/blend.cmi
-lib/ocaml/site-lib/camlimages/blend.mli
-lib/ocaml/site-lib/camlimages/bmp.cmi
-lib/ocaml/site-lib/camlimages/bmp.mli
-lib/ocaml/site-lib/camlimages/camlimages.cmi
-lib/ocaml/site-lib/camlimages/camlimages_all.a
-lib/ocaml/site-lib/camlimages/camlimages_all.cma
-lib/ocaml/site-lib/camlimages/camlimages_all.cmxa
-lib/ocaml/site-lib/camlimages/camlimages_core.a
-lib/ocaml/site-lib/camlimages/camlimages_core.cma
-lib/ocaml/site-lib/camlimages/camlimages_core.cmxa
-lib/ocaml/site-lib/camlimages/camlimages_freetype.a
-lib/ocaml/site-lib/camlimages/camlimages_freetype.cma
-lib/ocaml/site-lib/camlimages/camlimages_freetype.cmxa
-%%GIF%%lib/ocaml/site-lib/camlimages/camlimages_gif.a
-%%GIF%%lib/ocaml/site-lib/camlimages/camlimages_gif.cma
-%%GIF%%lib/ocaml/site-lib/camlimages/camlimages_gif.cmxa
-lib/ocaml/site-lib/camlimages/camlimages_graphics.a
-lib/ocaml/site-lib/camlimages/camlimages_graphics.cma
-lib/ocaml/site-lib/camlimages/camlimages_graphics.cmxa
-lib/ocaml/site-lib/camlimages/camlimages_jpeg.a
-lib/ocaml/site-lib/camlimages/camlimages_jpeg.cma
-lib/ocaml/site-lib/camlimages/camlimages_jpeg.cmxa
-%%GTK2%%lib/ocaml/site-lib/camlimages/camlimages_lablgtk2.a
-%%GTK2%%lib/ocaml/site-lib/camlimages/camlimages_lablgtk2.cma
-%%GTK2%%lib/ocaml/site-lib/camlimages/camlimages_lablgtk2.cmxa
-lib/ocaml/site-lib/camlimages/camlimages_png.a
-lib/ocaml/site-lib/camlimages/camlimages_png.cma
-lib/ocaml/site-lib/camlimages/camlimages_png.cmxa
-lib/ocaml/site-lib/camlimages/camlimages_ps.a
-lib/ocaml/site-lib/camlimages/camlimages_ps.cma
-lib/ocaml/site-lib/camlimages/camlimages_ps.cmxa
-lib/ocaml/site-lib/camlimages/camlimages_supported.a
-lib/ocaml/site-lib/camlimages/camlimages_supported.cma
-lib/ocaml/site-lib/camlimages/camlimages_supported.cmxa
-lib/ocaml/site-lib/camlimages/camlimages_tiff.a
-lib/ocaml/site-lib/camlimages/camlimages_tiff.cma
-lib/ocaml/site-lib/camlimages/camlimages_tiff.cmxa
-lib/ocaml/site-lib/camlimages/camlimages_xpm.a
-lib/ocaml/site-lib/camlimages/camlimages_xpm.cma
-lib/ocaml/site-lib/camlimages/camlimages_xpm.cmxa
-lib/ocaml/site-lib/camlimages/cmyk32.cmi
-lib/ocaml/site-lib/camlimages/cmyk32.mli
-lib/ocaml/site-lib/camlimages/color.cmi
-lib/ocaml/site-lib/camlimages/color.mli
-lib/ocaml/site-lib/camlimages/colorhist.cmi
-lib/ocaml/site-lib/camlimages/colorhist.mli
-lib/ocaml/site-lib/camlimages/dllcamlimages_all.so
-lib/ocaml/site-lib/camlimages/dllcamlimages_freetype.so
-lib/ocaml/site-lib/camlimages/dllcamlimages_gif.so
-lib/ocaml/site-lib/camlimages/dllcamlimages_jpeg.so
-lib/ocaml/site-lib/camlimages/dllcamlimages_png.so
-lib/ocaml/site-lib/camlimages/dllcamlimages_supported.so
-lib/ocaml/site-lib/camlimages/dllcamlimages_tiff.so
-lib/ocaml/site-lib/camlimages/dllcamlimages_xpm.so
-lib/ocaml/site-lib/camlimages/freetype.cmi
-lib/ocaml/site-lib/camlimages/freetype.mli
-lib/ocaml/site-lib/camlimages/ftlow.cmi
-lib/ocaml/site-lib/camlimages/ftlow.mli
-lib/ocaml/site-lib/camlimages/fttext.cmi
-lib/ocaml/site-lib/camlimages/fttext.mli
-lib/ocaml/site-lib/camlimages/genimage.cmi
-lib/ocaml/site-lib/camlimages/genimage.mli
-lib/ocaml/site-lib/camlimages/geometry.cmi
-lib/ocaml/site-lib/camlimages/geometry.mli
-lib/ocaml/site-lib/camlimages/gif.cmi
-lib/ocaml/site-lib/camlimages/gif.mli
-lib/ocaml/site-lib/camlimages/graphic_image.cmi
-lib/ocaml/site-lib/camlimages/graphic_image.mli
-lib/ocaml/site-lib/camlimages/image_intf.cmi
-lib/ocaml/site-lib/camlimages/image_intf.mli
-%%GTK2%%lib/ocaml/site-lib/camlimages/imagegdk.cmi
-lib/ocaml/site-lib/camlimages/imagegdk.mli
-lib/ocaml/site-lib/camlimages/images.cmi
-lib/ocaml/site-lib/camlimages/images.mli
-lib/ocaml/site-lib/camlimages/index16.cmi
-lib/ocaml/site-lib/camlimages/index16.mli
-lib/ocaml/site-lib/camlimages/index8.cmi
-lib/ocaml/site-lib/camlimages/index8.mli
-lib/ocaml/site-lib/camlimages/info.cmi
-lib/ocaml/site-lib/camlimages/info.mli
-lib/ocaml/site-lib/camlimages/jis_table.cmi
-lib/ocaml/site-lib/camlimages/jis_unicode.cmi
-lib/ocaml/site-lib/camlimages/jis_unicode.mli
-lib/ocaml/site-lib/camlimages/jpeg.cmi
-lib/ocaml/site-lib/camlimages/jpeg.mli
-lib/ocaml/site-lib/camlimages/libcamlimages_all.a
-lib/ocaml/site-lib/camlimages/libcamlimages_freetype.a
-lib/ocaml/site-lib/camlimages/libcamlimages_gif.a
-lib/ocaml/site-lib/camlimages/libcamlimages_jpeg.a
-lib/ocaml/site-lib/camlimages/libcamlimages_png.a
-lib/ocaml/site-lib/camlimages/libcamlimages_supported.a
-lib/ocaml/site-lib/camlimages/libcamlimages_tiff.a
-lib/ocaml/site-lib/camlimages/libcamlimages_xpm.a
-lib/ocaml/site-lib/camlimages/mstring.cmi
-lib/ocaml/site-lib/camlimages/mstring.mli
-lib/ocaml/site-lib/camlimages/oBmp.cmi
-lib/ocaml/site-lib/camlimages/oColor.cmi
-lib/ocaml/site-lib/camlimages/oColor.mli
-lib/ocaml/site-lib/camlimages/oFreetype.cmi
-lib/ocaml/site-lib/camlimages/oGif.cmi
-lib/ocaml/site-lib/camlimages/oGraphic.cmi
-lib/ocaml/site-lib/camlimages/oImages.cmi
-lib/ocaml/site-lib/camlimages/oImages.mli
-lib/ocaml/site-lib/camlimages/oJpeg.cmi
-lib/ocaml/site-lib/camlimages/oJpeg.mli
-lib/ocaml/site-lib/camlimages/oPng.cmi
-lib/ocaml/site-lib/camlimages/oPng.mli
-lib/ocaml/site-lib/camlimages/oPpm.cmi
-lib/ocaml/site-lib/camlimages/oPs.cmi
-lib/ocaml/site-lib/camlimages/oTiff.cmi
-%%GTK2%%lib/ocaml/site-lib/camlimages/oXimage.cmi
-lib/ocaml/site-lib/camlimages/oXimage.mli
-%%GTK2%%lib/ocaml/site-lib/camlimages/oXimage2.cmi
-lib/ocaml/site-lib/camlimages/oXpm.cmi
-lib/ocaml/site-lib/camlimages/oXvthumb.cmi
-lib/ocaml/site-lib/camlimages/oXvthumb.mli
-lib/ocaml/site-lib/camlimages/png.cmi
-lib/ocaml/site-lib/camlimages/png.mli
-lib/ocaml/site-lib/camlimages/ppm.cmi
-lib/ocaml/site-lib/camlimages/ppm.mli
-lib/ocaml/site-lib/camlimages/ps.cmi
-lib/ocaml/site-lib/camlimages/ps.mli
-lib/ocaml/site-lib/camlimages/reduce.cmi
-lib/ocaml/site-lib/camlimages/reduce.mli
-lib/ocaml/site-lib/camlimages/region.cmi
-lib/ocaml/site-lib/camlimages/region.mli
-lib/ocaml/site-lib/camlimages/rgb24.cmi
-lib/ocaml/site-lib/camlimages/rgb24.mli
-lib/ocaml/site-lib/camlimages/rgba32.cmi
-lib/ocaml/site-lib/camlimages/rgba32.mli
-lib/ocaml/site-lib/camlimages/tiff.cmi
-lib/ocaml/site-lib/camlimages/tiff.mli
-lib/ocaml/site-lib/camlimages/tmpfile.cmi
-lib/ocaml/site-lib/camlimages/tmpfile.mli
-lib/ocaml/site-lib/camlimages/units.cmi
-%%GTK2%%lib/ocaml/site-lib/camlimages/ximage.cmi
-lib/ocaml/site-lib/camlimages/ximage.mli
-%%GTK2%%lib/ocaml/site-lib/camlimages/ximage2.cmi
-lib/ocaml/site-lib/camlimages/xpm.cmi
-lib/ocaml/site-lib/camlimages/xpm.mli
-lib/ocaml/site-lib/camlimages/xvthumb.cmi
-lib/ocaml/site-lib/camlimages/xvthumb.mli