aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2006-07-30 01:48:51 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2006-07-30 01:48:51 +0800
commit11b5b4523593f0f92185096df088a92c45404e05 (patch)
tree47e429eb9af516cb6f4623d969508675e60048b2 /graphics
parent824121b8df5079d63f96d99e531c7f08d8727cff (diff)
downloadfreebsd-ports-gnome-11b5b4523593f0f92185096df088a92c45404e05.tar.gz
freebsd-ports-gnome-11b5b4523593f0f92185096df088a92c45404e05.tar.zst
freebsd-ports-gnome-11b5b4523593f0f92185096df088a92c45404e05.zip
- Add autopano-sift:
Autopano analyses two or more images and automatically generates control points - coordinates in the images where the views overlap. This can be fed to hugin which then stitches the files together and enblend which combines the colors to remove seam lines. WWW: http://user.cs.tu-berlin.de/~nowozin/autopano-sift/ - Add entry to LEGAL: The use of this software is restricted by certain conditions. See the "LICENSE" file distributed with the program for details. The University of British Columbia has applied for a patent on the SIFT algorithm in the United States. Commercial applications of this software may require a license from the University of British Columbia. PR: 95746 Submitted by: J.R. Oldroyd <fbsd@opal.com> Maintained by: Carlos E. G. Carvalho <cartola@openit.com.br>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/autopano-sift/Makefile69
-rw-r--r--graphics/autopano-sift/distinfo3
-rw-r--r--graphics/autopano-sift/files/autopano.in13
-rw-r--r--graphics/autopano-sift/files/patch-Makefile21
-rw-r--r--graphics/autopano-sift/files/patch-bin-autopano-complete.sh15
-rw-r--r--graphics/autopano-sift/files/patch-util-Makefile31
-rw-r--r--graphics/autopano-sift/pkg-descr17
-rw-r--r--graphics/autopano-sift/pkg-plist19
9 files changed, 189 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4f7df9468234..564dcce6631b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -21,6 +21,7 @@
SUBDIR += allegrogl
SUBDIR += aoi
SUBDIR += aqsis
+ SUBDIR += autopano-sift
SUBDIR += autotrace
SUBDIR += aview
SUBDIR += ayam
diff --git a/graphics/autopano-sift/Makefile b/graphics/autopano-sift/Makefile
new file mode 100644
index 000000000000..3d93dc680f3e
--- /dev/null
+++ b/graphics/autopano-sift/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: autopano-sift
+# Date created: 11 April 2006
+# Whom: J.R. Oldroyd <fbsd@opal.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autopano-sift
+PORTVERSION= 2.4
+CATEGORIES= graphics
+MASTER_SITES= http://user.cs.tu-berlin.de/~nowozin/autopano-sift/
+
+MAINTAINER= cartola@openit.com.br
+COMMENT= Automatic panorama control point generation tool
+
+RESTRICTED= May be covered by patents
+NO_PACKAGE= ${RESTRICTED}
+
+LIB_DEPENDS+= gdiplus:${PORTSDIR}/x11-toolkits/libgdiplus
+BUILD_DEPENDS+= mono:${PORTSDIR}/lang/mono \
+ ${X11BASE}/libdata/pkgconfig/gtk-sharp.pc:${PORTSDIR}/x11-toolkits/gtk-sharp10
+RUN_DEPENDS+= mono:${PORTSDIR}/lang/mono \
+ ${X11BASE}/lib/mono/gtk-sharp/gtk-sharp.dll:${PORTSDIR}/x11-toolkits/gtk-sharp10
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+SUB_FILES= autopano
+
+USE_GMAKE= yes
+
+MAN1= autopano-complete.1 \
+ autopano-complete.old.1 \
+ autopano.1 \
+ autopanog.1 \
+ generatekeys.1 \
+ showone.1 \
+ showtwo.1
+MAN7= autopano-sift.7
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL} ${WRKSRC}/bin/ICSharpCode.SharpZipLib.dll ${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/autopano-complete.sh ${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/autopano-complete.old.sh ${DATADIR}/
+ ${INSTALL} ${WRKSRC}/bin/autopano.exe ${DATADIR}/
+ ${INSTALL} ${WRKSRC}/bin/autopanog.exe ${DATADIR}/
+ ${INSTALL} ${WRKSRC}/bin/generatekeys-sd.exe ${DATADIR}/
+ ${INSTALL} ${WRKSRC}/bin/generatekeys.exe ${DATADIR}/
+ ${INSTALL} ${WRKSRC}/bin/libsift.dll ${DATADIR}/
+ ${INSTALL} ${WRKSRC}/bin/showone.exe ${DATADIR}/
+ ${INSTALL} ${WRKSRC}/bin/showtwo.exe ${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/autopano ${PREFIX}/bin/autopano
+ ${LN} ${PREFIX}/bin/autopano ${PREFIX}/bin/autopanog
+ ${LN} ${PREFIX}/bin/autopano ${PREFIX}/bin/generatekeys-sd
+ ${LN} ${PREFIX}/bin/autopano ${PREFIX}/bin/generatekeys
+ ${LN} ${PREFIX}/bin/autopano ${PREFIX}/bin/showone
+ ${LN} ${PREFIX}/bin/autopano ${PREFIX}/bin/showtwo
+ ${LN} -s ${DATADIR}/autopano-complete.sh ${PREFIX}/bin/autopano-complete
+ ${LN} -s ${DATADIR}/autopano-complete.old.sh ${PREFIX}/bin/autopano-complete.old
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/doc/autopano-complete.1 ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/doc/autopano-complete.old.1 ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/doc/autopano.1 ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/doc/autopanog.1 ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/doc/generatekeys.1 ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/doc/showone.1 ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/doc/showtwo.1 ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/doc/autopano-sift.7 ${PREFIX}/man/man7/
+
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+.include <bsd.port.mk>
diff --git a/graphics/autopano-sift/distinfo b/graphics/autopano-sift/distinfo
new file mode 100644
index 000000000000..ffa61024970f
--- /dev/null
+++ b/graphics/autopano-sift/distinfo
@@ -0,0 +1,3 @@
+MD5 (autopano-sift-2.4.tar.gz) = e497074d0cb5586cdc66506d782ccbd7
+SHA256 (autopano-sift-2.4.tar.gz) = 0f2ee8887550f77ca77be9ba7ff1888099c316de03362cb324ed32fd6ffeea35
+SIZE (autopano-sift-2.4.tar.gz) = 640117
diff --git a/graphics/autopano-sift/files/autopano.in b/graphics/autopano-sift/files/autopano.in
new file mode 100644
index 000000000000..34ba6a83e2c5
--- /dev/null
+++ b/graphics/autopano-sift/files/autopano.in
@@ -0,0 +1,13 @@
+#!/bin/sh
+#
+# wrapper script to invoke mono
+#
+# this same script is used for:
+# autopano
+# autopanog
+# generatekeys-sd
+# generatekeys
+# showone
+# showtwo
+
+exec mono %%DATADIR%%/`basename $0`.exe ${@+"$@"}
diff --git a/graphics/autopano-sift/files/patch-Makefile b/graphics/autopano-sift/files/patch-Makefile
new file mode 100644
index 000000000000..658f2e0d9fdf
--- /dev/null
+++ b/graphics/autopano-sift/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig Mon Oct 31 07:45:20 2005
++++ Makefile Tue Apr 11 14:12:32 2006
+@@ -72,15 +72,15 @@
+
+ distclean:
+ rm -f libsift.dll
+- make $(MAKE_OPTIONS) -C util clean
++ $(MAKE) $(MAKE_OPTIONS) -C util clean
+
+ utils:
+- make $(MAKE_OPTIONS) -C util all
++ $(MAKE) $(MAKE_OPTIONS) -C util all
+
+ release: clean releasetempclean releasetempsetup all bin_install
+ # autopano-sift
+ svn export . /tmp/$(APSVER)/src
+- make -C util/man/
++ $(MAKE) -C util/man/
+ mkdir /tmp/$(APSVER)/doc
+ cp util/man/*.[17] util/man/*.pdf util/man/*.txt /tmp/$(APSVER)/doc
+ mkdir /tmp/$(APSVER)/bin
diff --git a/graphics/autopano-sift/files/patch-bin-autopano-complete.sh b/graphics/autopano-sift/files/patch-bin-autopano-complete.sh
new file mode 100644
index 000000000000..383756b3a077
--- /dev/null
+++ b/graphics/autopano-sift/files/patch-bin-autopano-complete.sh
@@ -0,0 +1,15 @@
+--- bin/autopano-complete.sh.orig Sat Apr 9 05:40:12 2005
++++ bin/autopano-complete.sh Wed Apr 12 12:14:10 2006
+@@ -7,10 +7,10 @@
+ MONO=$(which mono)
+
+ # Set this to the directory you installed autopano-sift into, for example
+-#AUTOPANO_PATH=/usr/local/autopano-sift/bin
++AUTOPANO_PATH=/usr/local/share/autopano-sift
+ # Do not use a trailing backslash. If the executeables are within your path
+ # (recommended, you can leave the line below).
+-AUTOPANO_PATH=$(dirname $(which generatekeys.exe))
++#AUTOPANO_PATH=$(dirname $(which generatekeys.exe))
+
+ usage()
+ {
diff --git a/graphics/autopano-sift/files/patch-util-Makefile b/graphics/autopano-sift/files/patch-util-Makefile
new file mode 100644
index 000000000000..ad0d9b219e22
--- /dev/null
+++ b/graphics/autopano-sift/files/patch-util-Makefile
@@ -0,0 +1,31 @@
+--- util/Makefile.orig Sat Jan 15 11:33:38 2005
++++ util/Makefile Tue Apr 11 14:14:54 2006
+@@ -36,8 +36,8 @@
+ #SOURCES=GUIImage.cs DrawingPrimitives.cs BasicImagingInterface.cs
+
+ all: autopano.exe showone.exe showtwo.exe generatekeys.exe generatekeys-sd.exe
+- make $(MAKE_OPTIONS) -C autopanog all
+- make $(MAKE_OPTIONS) -C autopano-win32 all
++ $(MAKE) $(MAKE_OPTIONS) -C autopanog all
++ $(MAKE) $(MAKE_OPTIONS) -C autopano-win32 all
+
+ autopano.exe: Autopano.cs DrawingPrimitives.cs BasicImagingInterface.cs GUIImage-Drawing.cs
+ $(CSC) $(CSCFLAGS) /out:autopano.exe Autopano.cs \
+@@ -50,7 +50,7 @@
+
+ generatekeys-sd.exe:
+ mv generatekeys.exe generatekeys-gtk.exe
+- make -C . systemdrawing=yes generatekeys.exe
++ $(MAKE) -C . systemdrawing=yes generatekeys.exe
+ mv generatekeys.exe generatekeys-sd.exe
+ mv generatekeys-gtk.exe generatekeys.exe
+
+@@ -65,6 +65,6 @@
+
+ clean:
+ rm -f *.exe
+- make $(MAKE_OPTIONS) -C autopanog/ clean
+- make $(MAKE_OPTIONS) -C autopano-win32/ clean
++ $(MAKE) $(MAKE_OPTIONS) -C autopanog/ clean
++ $(MAKE) $(MAKE_OPTIONS) -C autopano-win32/ clean
+
diff --git a/graphics/autopano-sift/pkg-descr b/graphics/autopano-sift/pkg-descr
new file mode 100644
index 000000000000..33db2c4cc899
--- /dev/null
+++ b/graphics/autopano-sift/pkg-descr
@@ -0,0 +1,17 @@
+Automatic panorama control point generation tool for use with hugin.
+
+Autopano analyses two or more images and automatically generates
+control points - coordinates in the images where the views overlap.
+This can be fed to hugin which then stitches the files together and
+enblend which combines the colors to remove seam lines.
+
+===============================================================================
+The use of this software is restricted by certain conditions.
+See the "LICENSE" file distributed with the program for details.
+
+The University of British Columbia has applied for a patent on the SIFT
+algorithm in the United States. Commercial applications of this software may
+require a license from the University of British Columbia.
+===============================================================================
+
+WWW: http://user.cs.tu-berlin.de/~nowozin/autopano-sift/
diff --git a/graphics/autopano-sift/pkg-plist b/graphics/autopano-sift/pkg-plist
new file mode 100644
index 000000000000..5cf29bf3e1fa
--- /dev/null
+++ b/graphics/autopano-sift/pkg-plist
@@ -0,0 +1,19 @@
+bin/autopano
+bin/autopano-complete
+bin/autopano-complete.old
+bin/autopanog
+bin/generatekeys
+bin/generatekeys-sd
+bin/showone
+bin/showtwo
+%%DATADIR%%/ICSharpCode.SharpZipLib.dll
+%%DATADIR%%/autopano-complete.sh
+%%DATADIR%%/autopano-complete.old.sh
+%%DATADIR%%/autopano.exe
+%%DATADIR%%/autopanog.exe
+%%DATADIR%%/generatekeys-sd.exe
+%%DATADIR%%/generatekeys.exe
+%%DATADIR%%/libsift.dll
+%%DATADIR%%/showone.exe
+%%DATADIR%%/showtwo.exe
+@dirrm share/autopano-sift