aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2012-05-20 08:17:16 +0800
committermakc <makc@FreeBSD.org>2012-05-20 08:17:16 +0800
commit18dbcb0a52d3a7a86305b52bad5415e898fa2fae (patch)
treede68d04cbf9bee0291002e20692ed167d61fe80b /graphics
parentc9d1d50d2e5fa3bd82e3765cbf17790cd088090d (diff)
downloadfreebsd-ports-gnome-18dbcb0a52d3a7a86305b52bad5415e898fa2fae.tar.gz
freebsd-ports-gnome-18dbcb0a52d3a7a86305b52bad5415e898fa2fae.tar.zst
freebsd-ports-gnome-18dbcb0a52d3a7a86305b52bad5415e898fa2fae.zip
Add explicit dependency on libGLU and patches to fix build with upcoming Qt 4.8
Mark MAKE_JOBS_SAFE
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fraqtive/Makefile2
-rw-r--r--graphics/fraqtive/files/patch-src__meshview.cpp11
-rw-r--r--graphics/fraqtive/files/patch-src__src.pro13
3 files changed, 26 insertions, 0 deletions
diff --git a/graphics/fraqtive/Makefile b/graphics/fraqtive/Makefile
index 95861a7b9726..37610e028831 100644
--- a/graphics/fraqtive/Makefile
+++ b/graphics/fraqtive/Makefile
@@ -18,10 +18,12 @@ USE_BZIP2= yes
USE_QT_VER= 4
QT_COMPONENTS= gui opengl qmake_build uic_build moc_build rcc_build
QT_NONSTANDARD= yes
+USE_GL= glu
HAS_CONFIGURE= yes
CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}" \
QMAKE_CFLAGS="${CFLAGS}"
CONFIGURE_ARGS= -prefix ${PREFIX} -qmake ${QMAKE}
+MAKE_JOBS_SAFE= yes
OPTIONS= SSE2 "Enable SSE2 optimization" off
diff --git a/graphics/fraqtive/files/patch-src__meshview.cpp b/graphics/fraqtive/files/patch-src__meshview.cpp
new file mode 100644
index 000000000000..a2d571bd41b1
--- /dev/null
+++ b/graphics/fraqtive/files/patch-src__meshview.cpp
@@ -0,0 +1,11 @@
+--- src/meshview.cpp 2009/12/17 19:54:48 66
++++ src/meshview.cpp 2012/04/03 22:32:00 74
+@@ -16,6 +16,8 @@
+ # define M_PI 3.14159265358979323846
+ #endif
+
++#include <GL/glu.h>
++
+ #include <QMouseEvent>
+ #include <QWheelEvent>
+ #include <QKeyEvent>
diff --git a/graphics/fraqtive/files/patch-src__src.pro b/graphics/fraqtive/files/patch-src__src.pro
new file mode 100644
index 000000000000..f3012fba95e0
--- /dev/null
+++ b/graphics/fraqtive/files/patch-src__src.pro
@@ -0,0 +1,13 @@
+--- src/src.pro 2009/12/15 17:10:52 64
++++ src/src.pro 2012/04/03 22:32:00 74
+@@ -154,6 +154,10 @@
+ LIBS += -lshell32
+ }
+
++unix {
++ LIBS += -lGLU
++}
++
+ MOC_DIR = ../tmp
+ RCC_DIR = ../tmp
+ UI_DIR = ../tmp