aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2005-03-08 19:26:56 +0800
committervanilla <vanilla@FreeBSD.org>2005-03-08 19:26:56 +0800
commit227439e97f891e45a8a8b2022fa3995bf3e9bf42 (patch)
treee8acc245c97f5e4c1c5bd045e1bc52c01a92e58d /graphics
parentfe165fa46ff4eaf8b14376939abbe8626720a5c5 (diff)
downloadfreebsd-ports-gnome-227439e97f891e45a8a8b2022fa3995bf3e9bf42.tar.gz
freebsd-ports-gnome-227439e97f891e45a8a8b2022fa3995bf3e9bf42.tar.zst
freebsd-ports-gnome-227439e97f891e45a8a8b2022fa3995bf3e9bf42.zip
Fix lround() on RELENG_4.
Obtained from: ports/biology/xdrawchem/Makefile
Diffstat (limited to 'graphics')
-rw-r--r--graphics/imlib2/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index cdfa05bce49c..9b15ec57ca86 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imlib2
PORTVERSION= 1.2.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= enlightenment
@@ -38,4 +38,8 @@ INSTALLS_SHLIB= yes
CONFIGURE_ARGS+= --enable-mmx
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|lround|(long int)rint|g' ${WRKSRC}/src/lib/color_helpers.c
+
.include <bsd.port.post.mk>