aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2008-07-03 21:04:08 +0800
committerehaupt <ehaupt@FreeBSD.org>2008-07-03 21:04:08 +0800
commit233fed7ff9e562d6a3a56ccf7137bd1d1b97f010 (patch)
treedac68c6052d827443757596528deacd552fecdd8 /graphics
parent1e7419b1e69778a32732e94049626a5b4318f34e (diff)
downloadfreebsd-ports-gnome-233fed7ff9e562d6a3a56ccf7137bd1d1b97f010.tar.gz
freebsd-ports-gnome-233fed7ff9e562d6a3a56ccf7137bd1d1b97f010.tar.zst
freebsd-ports-gnome-233fed7ff9e562d6a3a56ccf7137bd1d1b97f010.zip
Add iec16022 0.2.2, create 2D barcodes, also known as DataMatrix.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/iec16022/Makefile32
-rw-r--r--graphics/iec16022/distinfo3
-rw-r--r--graphics/iec16022/pkg-descr4
4 files changed, 40 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 1ce1b57ee16a..bf6399e1f85e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -293,6 +293,7 @@
SUBDIR += icontact
SUBDIR += icoutils
SUBDIR += ida
+ SUBDIR += iec16022
SUBDIR += iiview
SUBDIR += ilmbase
SUBDIR += imageindex
diff --git a/graphics/iec16022/Makefile b/graphics/iec16022/Makefile
new file mode 100644
index 000000000000..4aea12a8953d
--- /dev/null
+++ b/graphics/iec16022/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: iec16022
+# Date created: Thu Jul 3 14:13:08 CEST 2008
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iec16022
+PORTVERSION= 0.2.2
+CATEGORIES= graphics
+MASTER_SITES= http://datenfreihafen.org/~stefan/iec16022/ \
+ CRITICAL
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Create 2D barcodes, also known as DataMatrix
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+
+GNU_CONFIGURE= yes
+
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/iec16022
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/iec16022.c \
+ ${WRKSRC}/iec16022ecc200.c ${WRKSRC}/reedsol.c ${WRKSRC}/image.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/iec16022/distinfo b/graphics/iec16022/distinfo
new file mode 100644
index 000000000000..c370cb79ebbf
--- /dev/null
+++ b/graphics/iec16022/distinfo
@@ -0,0 +1,3 @@
+MD5 (iec16022-0.2.2.tar.gz) = 84ca2bcd351ecaba84bd123cf0ba078b
+SHA256 (iec16022-0.2.2.tar.gz) = 0c569e22cdc3ff73defba27ba11e430b454c7cfede31d0371331d48ed23d3c6b
+SIZE (iec16022-0.2.2.tar.gz) = 328369
diff --git a/graphics/iec16022/pkg-descr b/graphics/iec16022/pkg-descr
new file mode 100644
index 000000000000..5434d7ddbb99
--- /dev/null
+++ b/graphics/iec16022/pkg-descr
@@ -0,0 +1,4 @@
+Create 2D barcodes, also known as Data Matrix. These barcodes are defined in
+ISO/IEC 16022.
+
+WWW: http://datenfreihafen.org/projects/iec16022.html