aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-05-29 21:38:49 +0800
committerbapt <bapt@FreeBSD.org>2012-05-29 21:38:49 +0800
commit2a7dd8db0005fe0a91e88985230b3b4569b93dd7 (patch)
tree5dab87326d6c36ccc76146d4a7028becdce15790 /graphics
parentc2af3d7b69e10f40b05b3d142d198731f91ec298 (diff)
downloadfreebsd-ports-gnome-2a7dd8db0005fe0a91e88985230b3b4569b93dd7.tar.gz
freebsd-ports-gnome-2a7dd8db0005fe0a91e88985230b3b4569b93dd7.tar.zst
freebsd-ports-gnome-2a7dd8db0005fe0a91e88985230b3b4569b93dd7.zip
Convert to new option framework
Add PNG to shared options descriptions
Diffstat (limited to 'graphics')
-rw-r--r--graphics/jbig2dec/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/jbig2dec/Makefile b/graphics/jbig2dec/Makefile
index ccdfcef54ec1..e21364edbebc 100644
--- a/graphics/jbig2dec/Makefile
+++ b/graphics/jbig2dec/Makefile
@@ -20,8 +20,10 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-OPTIONS= PNG "Enable png support" On \
- TESTS "Download and use test-images for post-build testing" Off
+OPTIONS_DEFINE= PNG TESTS
+OPTIONS_DEFAULT= PNG
+
+TESTS_DESC= Download and use test-images for post-build testing
MAN1= jbig2dec.1
@@ -33,12 +35,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
.include <bsd.port.options.mk>
-.if defined(WITH_PNG)
+.if ${PORT_OPTIONS:MPNG}
LIB_DEPENDS+= png:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+=--with-libpng=${LOCALBASE}
.endif
-.if defined(WITH_TESTS)
+.if ${PORT_OPTIONS:MTESTS}
MASTER_SITES+= http://jbig2dec.sourceforge.net/ubc/:tests
DISTFILES+= jb2streams.zip:tests
EXTRACT_ONLY= ${DISTFILES:M*xz}