aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-02-09 20:41:43 +0800
committerkwm <kwm@FreeBSD.org>2015-02-09 20:41:43 +0800
commit2d62ad41c1e83069713499f2f5ac576045f29806 (patch)
treeb37a3eb7bca31b50a0313043d65cfc0f6931d062 /graphics
parent01af96fef40afdcb31724867bdf8a8720bb0efdd (diff)
downloadfreebsd-ports-gnome-2d62ad41c1e83069713499f2f5ac576045f29806.tar.gz
freebsd-ports-gnome-2d62ad41c1e83069713499f2f5ac576045f29806.tar.zst
freebsd-ports-gnome-2d62ad41c1e83069713499f2f5ac576045f29806.zip
Fix the build on 9.x and 8.x.
The build problem exhibits itself as a internal compiler error on 9 and code issues on 8.x. Solve this by making sure inkscape uses a newer compiler via the USES=compiler framework. Reported by: Robert Backhaus (via IRC)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/inkscape/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 8b5f208bbae7..c7df56abeae1 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt \
#RUN_DEPENDS= p5-XML-XQL>=0:${PORTSDIR}/textproc/p5-XML-XQL
USE_GNOME= gtkmm24 intlhack libxslt
-USES= desktop-file-utils gettext gmake iconv libtool pathfix \
- perl5 pkgconfig shebangfix tar:bzip2
+USES= compiler:c++0x desktop-file-utils gettext gmake iconv \
+ libtool pathfix perl5 pkgconfig shebangfix tar:bzip2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include