aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-09-02 19:42:21 +0800
committertobik <tobik@FreeBSD.org>2018-09-02 19:42:21 +0800
commit2e13b4124c406764ac8601b76512a401df262087 (patch)
tree29edd9f5a9965c7b3cf117942d4815508ed2593c /graphics
parent6de125f8949a6b2976a80ad3c83005117303be13 (diff)
downloadfreebsd-ports-gnome-2e13b4124c406764ac8601b76512a401df262087.tar.gz
freebsd-ports-gnome-2e13b4124c406764ac8601b76512a401df262087.tar.zst
freebsd-ports-gnome-2e13b4124c406764ac8601b76512a401df262087.zip
graphis/reallyslick: Fix build with Clang 6
hyperspace.cpp:387:19: error: non-constant-expression cannot be narrowed from type 'double' to 'float' in initializer list [-Wc++11-narrowing] float diff[3] = {flarepos[0] - camPos[0], flarepos[1] - camPos[1], flarepos[2] - camPos[2]}; ^~~~~~~~~~~~~~~~~~~~~~~ http://beefy11.nyi.freebsd.org/data/head-i386-default/p478276_s338342/logs/errors/reallyslick-0.9.1_20.log - Attempt build on arm* again; the error message is the same as on amd64/i386 - Mark as LLD_UNSAFE when compiled with FREEALUT=on because of OpenAL [1] PR: 226980 [1]
Diffstat (limited to 'graphics')
-rw-r--r--graphics/reallyslick/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 37450d5e42a3..54e416e0bc7b 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -11,16 +11,15 @@ DISTNAME= rss-glx_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL screensaver collection
-BROKEN_armv6= fails to compile: hyperspace.cpp:387:19: non-constant-expression cannot be narrowed from type 'double' to 'float' in initializer list
-BROKEN_armv7= fails to compile: hyperspace.cpp:387:19: non-constant-expression cannot be narrowed from type 'double' to 'float' in initializer list
-
LIB_DEPENDS= libMagickWand-6.so:graphics/ImageMagick \
libGLC.so:graphics/quesoglc
-USES= gmake pathfix pkgconfig tar:bzip2 libtool
+USES= compiler gmake pathfix pkgconfig tar:bzip2 libtool
USE_GL= glut
GNU_CONFIGURE= yes
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lXext
@@ -29,6 +28,7 @@ OPTIONS_DEFINE= FREEALUT GLEW
FREEALUT_DESC= Enable freealut support
FREEALUT_CONFIGURE_ENABLE= sound
FREEALUT_USES= openal:alut
+FREEALUT_VARS= LLD_UNSAFE=yes # cf. PR 226980
GLEW_DESC= Enable GLEW support
GLEW_USE= GL=glew