aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-10 03:42:46 +0800
commit30a00f2227a3e53b607331247c81c2911c1e98ef (patch)
treeb3bdcd25b598432ef78aefb0f72e9412f429eee4 /graphics
parentfc3bdd2b5bc1f418653dc07e3f7734890f957654 (diff)
downloadfreebsd-ports-gnome-30a00f2227a3e53b607331247c81c2911c1e98ef.tar.gz
freebsd-ports-gnome-30a00f2227a3e53b607331247c81c2911c1e98ef.tar.zst
freebsd-ports-gnome-30a00f2227a3e53b607331247c81c2911c1e98ef.zip
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like "CC foo.c"). CMake and ninja enable this by default, some autotools using ports do as well. This is unacceptable because we need complete build logs at any time, so we now switch to verbose build logs unconditionally. Note that this change deliberately affects ALL builds and not only package builds on cluster, because we need to be sure that user experiencing failure can always provide informative build log regardless of settings and without rerunning the build. Change summary: - Always do verbose builds for cmake, ninja and GNU configure (the latter includes check if --disable-silent-rules is actually supported by the configure script; there are isolated cases when it's not true) - Remove CMAKE_VERBOSE, NINJA_VERBOSE and CONFIGURE_ARGS=--disable-silent-rules from all ports which set them for this is no longer needed - Revert hacks for --disable-silent-rules support priorly committed to biology/ncbi-blast+ and net-p2p/mldonkey - no longer needed as well Submitted by: amdmi3 Reviewed by: mat Exp-run by: antoine Approved by: portmgr (mat, antoine) Differential Revision: D7534
Diffstat (limited to 'graphics')
-rw-r--r--graphics/entangle/Makefile6
-rw-r--r--graphics/gnash/Makefile3
-rw-r--r--graphics/graphviz/Makefile3
-rw-r--r--graphics/gthumb/Makefile3
-rw-r--r--graphics/ocrfeeder/Makefile1
-rw-r--r--graphics/sekrit-twc-zimg/Makefile1
-rw-r--r--graphics/ufraw/Makefile2
7 files changed, 4 insertions, 15 deletions
diff --git a/graphics/entangle/Makefile b/graphics/entangle/Makefile
index e8040d135afa..242309e9317a 100644
--- a/graphics/entangle/Makefile
+++ b/graphics/entangle/Makefile
@@ -30,12 +30,6 @@ INSTALLS_ICONS= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-# XXX: it would be nice if one day this option would be passed automatically
-# to configure scripts that support it :)
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-CONFIGURE_ARGS= --disable-silent-rules
-.endif
-
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index a321684ba2dd..28e8c61fd572 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -36,8 +36,7 @@ CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
--with-plugins-install=prefix \
--sysconfdir="${SYSCONFIGDIR}" \
--disable-kparts3 \
- --disable-jemalloc \
- --disable-silent-rules
+ --disable-jemalloc
GNASHVER= ${PORTVERSION}
CONFIG_FILES= gnashpluginrc gnashrc
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 69aabb6956f2..97aec783fbf5 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -162,8 +162,7 @@ CONFIGURE_ARGS+= --program-transform-name="s/x/x/" \
--with-fontconfigincludedir=${LOCALBASE}/include \
--with-fontconfiglibdir=${LOCALBASE}/lib \
--disable-io --disable-ocaml --disable-java \
- --disable-sharp \
- --disable-silent-rules
+ --disable-sharp
.if ${PORT_OPTIONS:MMING}
BROKEN= Ming incomplete, uses removed libgraph
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index c87e55d36021..9daed793d800 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -24,8 +24,7 @@ USE_GNOME= gtk30 intltool librsvg2
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_lib_jpeg_jpeg_destroy_decompress=yes \
ac_cv_lib_tiff_TIFFWriteScanline=yes
-CONFIGURE_ARGS= --disable-silent-rules \
- --disable-libchamplain \
+CONFIGURE_ARGS= --disable-libchamplain \
--enable-compile-warnings=minimum \
--enable-librsvg
INSTALL_TARGET= install-strip
diff --git a/graphics/ocrfeeder/Makefile b/graphics/ocrfeeder/Makefile
index c1e3cbf24508..2fd9a7f7d8a7 100644
--- a/graphics/ocrfeeder/Makefile
+++ b/graphics/ocrfeeder/Makefile
@@ -29,7 +29,6 @@ USES= desktop-file-utils gettext ghostscript gmake pkgconfig \
python tar:xz
USE_GNOME= gnomedocutils gtk30 intltool librsvg2 pygobject3
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/sekrit-twc-zimg/Makefile b/graphics/sekrit-twc-zimg/Makefile
index c7832b3b15e5..e71b404d4d24 100644
--- a/graphics/sekrit-twc-zimg/Makefile
+++ b/graphics/sekrit-twc-zimg/Makefile
@@ -23,7 +23,6 @@ USES= autoreconf compiler:c++11-lib gmake libtool pathfix
EXTRACT_AFTER_ARGS= --exclude test/extra
PATHFIX_MAKEFILEIN= Makefile.am
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules
CPPFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
-D_DECLARE_C99_LDBL_MATH # XXX ports/193528
CPPFLAGS+= ${CPPFLAGS_${CHOSEN_COMPILER_TYPE}_${COMPILER_VERSION}}
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 29224d35aa45..12aa87d0318d 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libtiff.so:graphics/tiff \
liblcms2.so:graphics/lcms2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules --enable-extras
+CONFIGURE_ARGS= --enable-extras
USES= desktop-file-utils gettext gmake jpeg pkgconfig
CPPFLAGS+= -I${LOCALBASE}/include