aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-06-01 16:06:38 +0800
committerOliver Braun <obraun@FreeBSD.org>2003-06-01 16:06:38 +0800
commit30f60ee03e4f7eaf8e1a543cde18cffe75508535 (patch)
tree9ce1944a52793dda76249fc9c0ed65aa22fd29e1 /graphics
parent27d05742bbd45eb615a2dab67a6b2b97df6e2fab (diff)
downloadfreebsd-ports-gnome-30f60ee03e4f7eaf8e1a543cde18cffe75508535.tar.gz
freebsd-ports-gnome-30f60ee03e4f7eaf8e1a543cde18cffe75508535.tar.zst
freebsd-ports-gnome-30f60ee03e4f7eaf8e1a543cde18cffe75508535.zip
Use libio on alpha (-STABLE & -CURRENT).
PR: ports/52633 Submitted by: maintainer
Diffstat (limited to 'graphics')
-rw-r--r--graphics/hpoj/Makefile8
-rw-r--r--graphics/hpoj/files/extra-patch-mlcd-Makefile.in11
-rw-r--r--graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp12
-rw-r--r--graphics/hpoj/files/extra-patch-mlcd-ParPort.h14
4 files changed, 44 insertions, 1 deletions
diff --git a/graphics/hpoj/Makefile b/graphics/hpoj/Makefile
index f26c1ed8aa88..9bda24e8ae40 100644
--- a/graphics/hpoj/Makefile
+++ b/graphics/hpoj/Makefile
@@ -28,10 +28,16 @@ USE_PERL5= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 500000
+.if ${ARCH} == "i386" && ${OSVERSION} > 500000
BROKEN= "ffs() clash, see i386/41930"
.endif
+.if ${ARCH} == "alpha"
+EXTRA_PATCHES= files/extra-patch-mlcd-Makefile.in \
+ files/extra-patch-mlcd-ParPort.cpp \
+ files/extra-patch-mlcd-ParPort.h
+.endif
+
.ifndef(WITHOUT_X11)
USE_QT_VER= 3
USE_XLIB= yes
diff --git a/graphics/hpoj/files/extra-patch-mlcd-Makefile.in b/graphics/hpoj/files/extra-patch-mlcd-Makefile.in
new file mode 100644
index 000000000000..76a6fdaa14f2
--- /dev/null
+++ b/graphics/hpoj/files/extra-patch-mlcd-Makefile.in
@@ -0,0 +1,11 @@
+--- mlcd/Makefile.in.orig Sat May 24 08:03:14 2003
++++ mlcd/Makefile.in Sat May 24 08:03:37 2003
+@@ -35,7 +35,7 @@
+ for link in $(LINKS) ; do ln -s . $$link ; done
+
+ $(GOAL): $(OBJS)
+- $(CXX) -o $(GOAL) $(OBJS)
++ $(CXX) -o $(GOAL) -lio $(OBJS)
+
+ clean:
+ rm -f $(OBJS) $(GOAL) $(LINKS)
diff --git a/graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp b/graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp
new file mode 100644
index 000000000000..4d62bc3f52a9
--- /dev/null
+++ b/graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp
@@ -0,0 +1,12 @@
+--- mlcd/ParPort.cpp.orig Sat May 24 08:03:20 2003
++++ mlcd/ParPort.cpp Sat May 24 08:03:48 2003
+@@ -926,9 +926,6 @@
+ #elif defined(PAR_PLATFORM_FREEBSD)
+ #include <unistd.h>
+ #include <fcntl.h>
+- extern "C" {
+- #include <machine/cpufunc.h>
+- }
+ #else
+ /* TODO: Handle these more gracefully! */
+ #error Undefined platform
diff --git a/graphics/hpoj/files/extra-patch-mlcd-ParPort.h b/graphics/hpoj/files/extra-patch-mlcd-ParPort.h
new file mode 100644
index 000000000000..ae352910e700
--- /dev/null
+++ b/graphics/hpoj/files/extra-patch-mlcd-ParPort.h
@@ -0,0 +1,14 @@
+--- mlcd/ParPort.h.orig Sat May 24 08:02:19 2003
++++ mlcd/ParPort.h Sat May 24 07:59:13 2003
+@@ -27,6 +27,11 @@
+
+ #define ERROR_NO_DATA ERROR /* TODO: Remove. */
+
++extern "C" {
++extern u_char inb (u_int port);
++extern void outb(u_int port, u_char data);
++}
++
+ class ParPort {
+ protected: // ATTRIB
+ int portType;