aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2019-01-11 22:51:57 +0800
committerMartin Wilke <miwi@FreeBSD.org>2019-01-11 22:51:57 +0800
commit326349c4acb52b1a54e30965e23136d98136eb45 (patch)
tree844b2aff04f41a720405afd1e4ddd05df11c5030 /graphics
parent1982cb35fec141a7e86d32c39c0d29d68ec3e5dc (diff)
downloadfreebsd-ports-gnome-326349c4acb52b1a54e30965e23136d98136eb45.tar.gz
freebsd-ports-gnome-326349c4acb52b1a54e30965e23136d98136eb45.tar.zst
freebsd-ports-gnome-326349c4acb52b1a54e30965e23136d98136eb45.zip
- Update to 2.5.11
PR: 230660 Submitted by: ndowens@yahoo.com Approved by: maintainer timeout Sponsored by: iXsystems Inc.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gif2png/Makefile17
-rw-r--r--graphics/gif2png/distinfo5
-rw-r--r--graphics/gif2png/files/patch-Makefile19
3 files changed, 33 insertions, 8 deletions
diff --git a/graphics/gif2png/Makefile b/graphics/gif2png/Makefile
index 5089d083c05e..f9b355a93078 100644
--- a/graphics/gif2png/Makefile
+++ b/graphics/gif2png/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gif2png
-PORTVERSION= 2.5.9
-PORTREVISION= 3
+PORTVERSION= 2.5.11
CATEGORIES= graphics
MASTER_SITES= http://www.catb.org/~esr/gif2png/
@@ -11,16 +10,22 @@ MAINTAINER= saper@saper.info
COMMENT= Converts GIF images to a PNG format
LICENSE= ZLIB
-LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png
+BUILD_DEPENDS= png>0:graphics/png \
+ gzip:archivers/gzip
-USES= localbase:ldflags python:2.7,run shebangfix
+USES= python:2.7,run shebangfix
SHEBANG_FILES= web2png
-GNU_CONFIGURE= yes
-PLIST_FILES= bin/${PORTNAME} bin/web2png \
+PLIST_FILES= bin/gif2png bin/web2png \
man/man1/gif2png.1.gz \
man/man1/web2png.1.gz
+MAKE_ARGS= CFLAGS="${CFLAGS}" prefix=${STAGEDIR}${PREFIX}
+CFLAGS+= -I${PREFIX}/include/libpng16 -L${PREFIX}/lib
+
+pre-build:
+ ${REINPLACE_CMD} -e 's|"gif2png " VERSION|" gif2png " ; VERSION|' ${WRKSRC}/version.c
+
.include <bsd.port.mk>
diff --git a/graphics/gif2png/distinfo b/graphics/gif2png/distinfo
index 93d5d09c5385..c0535571c65f 100644
--- a/graphics/gif2png/distinfo
+++ b/graphics/gif2png/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gif2png-2.5.9.tar.gz) = c8406b7c0c08f504952a1719e04f2366ee44c888c0edfac3a63fea2ab05b64c7
-SIZE (gif2png-2.5.9.tar.gz) = 137750
+TIMESTAMP = 1534339110
+SHA256 (gif2png-2.5.11.tar.gz) = 40483169d2de06f632ada1de780c36f63325844ec62892b1652193f77fc508f7
+SIZE (gif2png-2.5.11.tar.gz) = 31507
diff --git a/graphics/gif2png/files/patch-Makefile b/graphics/gif2png/files/patch-Makefile
new file mode 100644
index 000000000000..66fea44da22b
--- /dev/null
+++ b/graphics/gif2png/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig 2015-07-15 00:06:28 UTC
++++ Makefile
+@@ -38,13 +38,13 @@ prefix?=/usr
+
+ install: gif2png gif2png.1 web2png.1
+ mkdir -p $(prefix)/bin
+- mkdir -p $(prefix)/share/man/man1
++ mkdir -p $(prefix)/man/man1
+ cp gif2png web2png $(prefix)/bin/
+- cp gif2png.1 web2png.1 $(prefix)/share/man/man1/
++ cp gif2png.1 web2png.1 $(prefix)/man/man1/
+
+ uninstall:
+ rm $(prefix)/bin/gif2png $(prefix)/bin/web2png
+- rm $(prefix)/share/man/man1/gif2png.1 $(prefix)/share/man/man1/web2png.1
++ rm $(prefix)/man/man1/gif2png.1 $(prefix)/man/man1/web2png.1
+
+ PYLINTOPTS = --rcfile=/dev/null --reports=n \
+ --msg-template="{path}:{line}: [{msg_id}({symbol}), {obj}] {msg}" \