aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
committeradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
commit3285716aaeafc0b799b7d0f09455fb838f7423eb (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /graphics
parent0e44743df6c6b7c3f4bc9ebe5b47c9868ff2ca6d (diff)
downloadfreebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.gz
freebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.zst
freebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-CAD-Drawing/Makefile2
-rw-r--r--graphics/p5-Gimp/Makefile8
-rw-r--r--graphics/p5-Graphics-ColorNames-WWW/Makefile6
-rw-r--r--graphics/p5-Graphics-ColorNames/Makefile5
-rw-r--r--graphics/p5-Visio/Makefile3
5 files changed, 11 insertions, 13 deletions
diff --git a/graphics/p5-CAD-Drawing/Makefile b/graphics/p5-CAD-Drawing/Makefile
index 471a8616553c..902495ea5717 100644
--- a/graphics/p5-CAD-Drawing/Makefile
+++ b/graphics/p5-CAD-Drawing/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= p5-CAD-Calc>=0:${PORTSDIR}/math/p5-CAD-Calc \
p5-Math-MatrixReal>=0:${PORTSDIR}/math/p5-Math-MatrixReal \
p5-Math-Vec>=0:${PORTSDIR}/math/p5-Math-Vec \
p5-Stream>=0:${PORTSDIR}/devel/p5-Stream \
- ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
+ convert:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
diff --git a/graphics/p5-Gimp/Makefile b/graphics/p5-Gimp/Makefile
index 384317b56a88..15b9f7deabd5 100644
--- a/graphics/p5-Gimp/Makefile
+++ b/graphics/p5-Gimp/Makefile
@@ -15,13 +15,13 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
RUN_DEPENDS= p5-Gtk2>=1.0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
- PDL>=2.007:${PORTSDIR}/math/PDL \
- p5-IO-All>=0:${PORTSDIR}/devel/p5-IO-All \
p5-Gtk2-Ex-PodViewer>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2-Ex-PodViewer \
+ p5-IO-All>=0:${PORTSDIR}/devel/p5-IO-All \
p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-Web-Scraper>=0:${PORTSDIR}/www/p5-Web-Scraper \
- p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
-BUILD_DEPENDS= p5-ExtUtils-Depends>=0.200:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+ PDL>=2.007:${PORTSDIR}/math/PDL
+BUILD_DEPENDS:= p5-ExtUtils-Depends>=0.200:${PORTSDIR}/devel/p5-ExtUtils-Depends \
p5-ExtUtils-PkgConfig>=1:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
${RUN_DEPENDS}
LIB_DEPENDS= libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app
diff --git a/graphics/p5-Graphics-ColorNames-WWW/Makefile b/graphics/p5-Graphics-ColorNames-WWW/Makefile
index b12bc035e0b7..8a570e156516 100644
--- a/graphics/p5-Graphics-ColorNames-WWW/Makefile
+++ b/graphics/p5-Graphics-ColorNames-WWW/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Graphics-ColorNames-WWW
PORTVERSION= 1.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -12,8 +12,8 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= WWW color names and equivalent RGB values
RUN_DEPENDS= p5-Graphics-ColorNames>=0.32:${PORTSDIR}/graphics/p5-Graphics-ColorNames
-BUILD_DEPENDS:= ${RUN_DEPENDS} \
- p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+TEST_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
USES= perl5
USE_PERL5= modbuild
diff --git a/graphics/p5-Graphics-ColorNames/Makefile b/graphics/p5-Graphics-ColorNames/Makefile
index 488cd71c0bee..945531f99a63 100644
--- a/graphics/p5-Graphics-ColorNames/Makefile
+++ b/graphics/p5-Graphics-ColorNames/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Graphics-ColorNames
PORTVERSION= 2.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,9 +11,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl class that defines RGB values for common color names
-BUILD_DEPENDS= p5-Module-Load>=0.10:${PORTSDIR}/devel/p5-Module-Load \
- p5-Module-Loaded>=0:${PORTSDIR}/devel/p5-Module-Loaded
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
USES= perl5
diff --git a/graphics/p5-Visio/Makefile b/graphics/p5-Visio/Makefile
index 137a0eaac953..d43eafd38a09 100644
--- a/graphics/p5-Visio/Makefile
+++ b/graphics/p5-Visio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Visio
PORTVERSION= 1.010
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,6 +13,7 @@ COMMENT= Perl extension manipulating XML based Visio files
BUILD_DEPENDS= p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure