aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2014-03-06 23:46:24 +0800
committerthierry <thierry@FreeBSD.org>2014-03-06 23:46:24 +0800
commit34cf173e510381960e87d53060aade37cff2a303 (patch)
tree7ad9a48b02d88763cd95fc9713bc8d0c81767499 /graphics
parent5956de1b1a7a39ed403de065f8fedc1fbb4c06ed (diff)
downloadfreebsd-ports-gnome-34cf173e510381960e87d53060aade37cff2a303.tar.gz
freebsd-ports-gnome-34cf173e510381960e87d53060aade37cff2a303.tar.zst
freebsd-ports-gnome-34cf173e510381960e87d53060aade37cff2a303.zip
OPENMP implies compiler:openmp, hence Gcc46 (this could change in a
near future). This causes problems with the linker in some ports (e.g. graphics/cimg). Untill a better solution is found, don't enable OPENMP by default. Checked with CImg and Octave.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/GraphicsMagick13/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/GraphicsMagick13/Makefile b/graphics/GraphicsMagick13/Makefile
index fc976ceabfd1..20fad1487ae7 100644
--- a/graphics/GraphicsMagick13/Makefile
+++ b/graphics/GraphicsMagick13/Makefile
@@ -3,7 +3,7 @@
PORTNAME= GraphicsMagick
PORTVERSION= 1.3.19
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF \
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/1.3/
@@ -30,7 +30,7 @@ USES= iconv
USE_GNOME= libxml2
USE_GHOSTSCRIPT=yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PTHREAD_CFLAGS=" " PTHREAD_LIBS="-pthread"
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --without-perl --enable-shared --enable-static \
--with-quantum-depth="${QD}" \
--with-windows-font-dir="${WINDOWS_FONT_DIR}"