aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-12-17 12:15:52 +0800
committerijliao <ijliao@FreeBSD.org>2003-12-17 12:15:52 +0800
commit3ff00cc8e1acf1f2dfe342c7c1b82ee117299696 (patch)
tree44185aeda554ffa9c5749c686a4c9cf7568e9dec /graphics
parent394f1e93d899b7a5fa646926ab2480bce5344037 (diff)
downloadfreebsd-ports-gnome-3ff00cc8e1acf1f2dfe342c7c1b82ee117299696.tar.gz
freebsd-ports-gnome-3ff00cc8e1acf1f2dfe342c7c1b82ee117299696.tar.zst
freebsd-ports-gnome-3ff00cc8e1acf1f2dfe342c7c1b82ee117299696.zip
add ale 0.5.1
Anti-Lamenessing Engine
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/ale/Makefile31
-rw-r--r--graphics/ale/distinfo3
-rw-r--r--graphics/ale/files/patch-ppm.h11
-rw-r--r--graphics/ale/pkg-descr6
-rw-r--r--graphics/ale/pkg-plist1
6 files changed, 53 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index cc76d9a445ca..c12c12bfa9d1 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -12,6 +12,7 @@
SUBDIR += OpenEXR
SUBDIR += aalib
SUBDIR += acidwarp
+ SUBDIR += ale
SUBDIR += animabob
SUBDIR += aoi
SUBDIR += aqsis
diff --git a/graphics/ale/Makefile b/graphics/ale/Makefile
new file mode 100644
index 000000000000..1f7b826abd7f
--- /dev/null
+++ b/graphics/ale/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection Makefile for: ale
+# Date created: Dec 17, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ale
+PORTVERSION= 0.5.1
+CATEGORIES= graphics
+MASTER_SITES= http://auricle.dyndns.org/ALE/download/
+PATCH_SITES= http://auricle.dyndns.org/ALE/bugs/
+PATCHFILES= 0.5.1.patch1 0.5.1.patch2
+PATCH_DIST_ARGS= -p1 -d ${PATCH_WRKSRC}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Anti-Lamenessing Engine
+
+USE_GCC= 3.1
+USE_GMAKE= yes
+
+.if !defined(WITHOUT_IMAGEMAGICK)
+LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick
+MAKE_ARGS= IMAGEMAGICK=1
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ale ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/ale/distinfo b/graphics/ale/distinfo
new file mode 100644
index 000000000000..d14ea49b072d
--- /dev/null
+++ b/graphics/ale/distinfo
@@ -0,0 +1,3 @@
+MD5 (ale-0.5.1.tar.gz) = 5c08c6f8b1d7cec89771d64ef09e2bef
+MD5 (0.5.1.patch1) = 4de11856fdc611c0446c1ea81e6fee67
+MD5 (0.5.1.patch2) = b87e6023f4f6d4aa3f604582a691b3b8
diff --git a/graphics/ale/files/patch-ppm.h b/graphics/ale/files/patch-ppm.h
new file mode 100644
index 000000000000..060097ec7669
--- /dev/null
+++ b/graphics/ale/files/patch-ppm.h
@@ -0,0 +1,11 @@
+--- ppm.h.orig Wed Dec 17 11:56:17 2003
++++ ppm.h Wed Dec 17 11:57:01 2003
+@@ -189,7 +189,7 @@
+ }
+
+ if (mcv != CHANNEL_MAX)
+- ival = (int) round(((double) ival / (double) (mcv)) * (CHANNEL_MAX));
++ ival = (int) ceil(((double) ival / (double) (mcv)) * (CHANNEL_MAX) + 0.5);
+
+ im->set_pixel_component(i, j, k, ival);
+ }
diff --git a/graphics/ale/pkg-descr b/graphics/ale/pkg-descr
new file mode 100644
index 000000000000..c606f83dfa99
--- /dev/null
+++ b/graphics/ale/pkg-descr
@@ -0,0 +1,6 @@
+ALE is a free software program that renders high-fidelity images of real scenes
+by aligning and combining many similar images from a camera or scanner. The
+correct similarity between images is roughly that achieved by a somewhat
+unsteady hand holding a camera.
+
+WWW: http://auricle.dyndns.org/ALE/
diff --git a/graphics/ale/pkg-plist b/graphics/ale/pkg-plist
new file mode 100644
index 000000000000..c2c0fdcaa1e0
--- /dev/null
+++ b/graphics/ale/pkg-plist
@@ -0,0 +1 @@
+bin/ale