aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-08-03 20:47:05 +0800
committermat <mat@FreeBSD.org>2016-08-03 20:47:05 +0800
commit431402e6f41b0ead2340cd5b739afd97a7750d92 (patch)
tree0ef0e6e265bc625030daf067c3dd5dc211eab79b /graphics
parent46d1315f83f80cd05d0b92861b777385d3983a73 (diff)
downloadfreebsd-ports-gnome-431402e6f41b0ead2340cd5b739afd97a7750d92.tar.gz
freebsd-ports-gnome-431402e6f41b0ead2340cd5b739afd97a7750d92.tar.zst
freebsd-ports-gnome-431402e6f41b0ead2340cd5b739afd97a7750d92.zip
Don't use extension.ini any more, and have each extension install in its
file, so the order remains the same. Every PHP (or Zend) extension now installs its own .ini file in /usr/local/etc/php. A PHP extension will be automatically activated when installed. The order into which extensions are loaded is automatically guessed. In some very rare cases, the guess will be wrong, and PHP_MOD_PRIO will need to be set. Refer to the USES=php section of the Porter's Handbook for more information. Convert ports touching etc/php/extensions.ini manually, or telling the OP to do it. And finally, bump PORTREVISION for all php extensions. PR: 210697 Submitted by: mat Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D7022
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mapserver/Makefile28
-rw-r--r--graphics/mapserver/pkg-plist3
-rw-r--r--graphics/pecl-gmagick/Makefile1
-rw-r--r--graphics/pecl-imagick/Makefile1
-rw-r--r--graphics/pecl-imlib2/Makefile2
-rw-r--r--graphics/pecl-qrencode/Makefile1
-rw-r--r--graphics/php-facedetect/Makefile2
-rw-r--r--graphics/php-libpuzzle/Makefile2
-rw-r--r--graphics/php-magickwand/Makefile2
-rw-r--r--graphics/php5-ffmpeg/Makefile2
-rw-r--r--graphics/php55-exif/Makefile1
-rw-r--r--graphics/php55-gd/Makefile1
-rw-r--r--graphics/php56-exif/Makefile1
-rw-r--r--graphics/php56-gd/Makefile1
-rw-r--r--graphics/php70-exif/Makefile1
-rw-r--r--graphics/php70-gd/Makefile1
16 files changed, 28 insertions, 22 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index bf55fc1fee75..82929e1451ab 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -125,11 +125,9 @@ CMAKE_ARGS+= -DWITH_POSTGIS=0
.endif
.if ${PORT_OPTIONS:MPHP}
-BUILD_DEPENDS+= ${LOCALBASE}/bin/php-config:lang/php56
-RUN_BUILDS+= ${LOCALBASE}/bin/php-config:lang/php56
-PHP_EXTENSION_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e "s,/usr/local/,,"
+USES+= php:build
+IGNORE_WITH_PHP= 55 70
CMAKE_ARGS+= -DWITH_PHP=1
-PLIST_SUB+= PHP_EXTENSION_DIR=${PHP_EXTENSION_DIR}
PLIST_SUB+= PHP=""
.else
CMAKE_ARGS+= -DWITH_PHP=0
@@ -188,22 +186,20 @@ do-install:
.endfor
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/libmapserver.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib
-.if ${PORT_OPTIONS:MPHP}
- @${MKDIR} ${STAGEDIR}${PREFIX}/${PHP_EXTENSION_DIR}
+ @${LN} -s ${PREFIX}/lib/libmapserver.so.7.0.1 ${STAGEDIR}${PREFIX}/lib/libmapserver.so.2
+ @${LN} -s ${PREFIX}/lib/libmapserver.so.2 ${STAGEDIR}${PREFIX}/lib/libmapserver.so
+
+do-install-PHP-on:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/mapscript/php/php_mapscript.so \
- ${STAGEDIR}${PREFIX}/${PHP_EXTENSION_DIR}/
-.endif
+ ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}/
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/php
+ @${ECHO_CMD} "extension=php_mapscript.so" > ${STAGEDIR}${PREFIX}/etc/php/ext-20-php_mapscript.ini
-.if ${PORT_OPTIONS:MPYTHON}
+
+do-install-PYTHON-on:
@${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/
(cd ${BUILD_WRKSRC}/mapscript/python && ${CP} mapscript.py _mapscript.so ${STAGEDIR}${PYTHON_SITELIBDIR}/)
-.endif
-
- @${LN} -s ${PREFIX}/lib/libmapserver.so.7.0.1 ${STAGEDIR}${PREFIX}/lib/libmapserver.so.2
- @${LN} -s ${PREFIX}/lib/libmapserver.so.2 ${STAGEDIR}${PREFIX}/lib/libmapserver.so
-.if ${PORT_OPTIONS:MPHP}
- @${ECHO_MSG} "Please add the line extension=php_mapscript.so to ${PREFIX}/etc/php/extensions.ini"
-.endif
.include <bsd.port.mk>
diff --git a/graphics/mapserver/pkg-plist b/graphics/mapserver/pkg-plist
index 85d35e2ad67a..2a5cc2634d16 100644
--- a/graphics/mapserver/pkg-plist
+++ b/graphics/mapserver/pkg-plist
@@ -8,9 +8,10 @@ bin/shptreetst
bin/shptreevis
bin/sortshp
bin/tile4ms
+%%PHP%%etc/php/ext-20-php_mapscript.ini
lib/libmapserver.so
lib/libmapserver.so.2
lib/libmapserver.so.7.0.1
-%%PHP%%%%PHP_EXTENSION_DIR%%/php_mapscript.so
+%%PHP%%lib/php/%%PHP_EXT_DIR%%/php_mapscript.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/mapscript.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_mapscript.so
diff --git a/graphics/pecl-gmagick/Makefile b/graphics/pecl-gmagick/Makefile
index 8f3e82b87d30..b52e100fc6c3 100644
--- a/graphics/pecl-gmagick/Makefile
+++ b/graphics/pecl-gmagick/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gmagick
PORTVERSION= 1.1.7RC3
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
diff --git a/graphics/pecl-imagick/Makefile b/graphics/pecl-imagick/Makefile
index 5d4f8b5a909a..0058df3b1ad6 100644
--- a/graphics/pecl-imagick/Makefile
+++ b/graphics/pecl-imagick/Makefile
@@ -3,6 +3,7 @@
PORTNAME= imagick
DISTVERSION= 3.4.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
diff --git a/graphics/pecl-imlib2/Makefile b/graphics/pecl-imlib2/Makefile
index d9e09ba61d51..cab4f99374c3 100644
--- a/graphics/pecl-imlib2/Makefile
+++ b/graphics/pecl-imlib2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= imlib2
PORTVERSION= 0.1.00
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
diff --git a/graphics/pecl-qrencode/Makefile b/graphics/pecl-qrencode/Makefile
index 43ccb3f589a5..7c2585d0a6a2 100644
--- a/graphics/pecl-qrencode/Makefile
+++ b/graphics/pecl-qrencode/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qrencode
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= graphics pear
MASTER_SITES= LOCAL/vanilla
PKGNAMEPREFIX= pecl-
diff --git a/graphics/php-facedetect/Makefile b/graphics/php-facedetect/Makefile
index 94e41925f140..9555fb4371c0 100644
--- a/graphics/php-facedetect/Makefile
+++ b/graphics/php-facedetect/Makefile
@@ -3,7 +3,7 @@
PORTNAME= facedetect
PORTVERSION= 1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
PKGNAMEPREFIX= php-
diff --git a/graphics/php-libpuzzle/Makefile b/graphics/php-libpuzzle/Makefile
index 2f0539e4e143..13d919081cf6 100644
--- a/graphics/php-libpuzzle/Makefile
+++ b/graphics/php-libpuzzle/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libpuzzle
PORTVERSION= 0.11
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://download.pureftpd.org/pub/pure-ftpd/misc/libpuzzle/release/ \
ftp://ftp.pureftpd.org/pub/pure-ftpd/misc/libpuzzle/releases/
diff --git a/graphics/php-magickwand/Makefile b/graphics/php-magickwand/Makefile
index 9ce390db7d7c..fe68fddf085b 100644
--- a/graphics/php-magickwand/Makefile
+++ b/graphics/php-magickwand/Makefile
@@ -3,7 +3,7 @@
PORTNAME= magickwand
PORTVERSION= 1.0.9
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= http://www.magickwand.org/download/php/
PKGNAMEPREFIX= php-
diff --git a/graphics/php5-ffmpeg/Makefile b/graphics/php5-ffmpeg/Makefile
index 84572d0179fe..e5da53e5c03f 100644
--- a/graphics/php5-ffmpeg/Makefile
+++ b/graphics/php5-ffmpeg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ffmpeg
PORTVERSION= 0.6.0.20120114
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= php-
CATEGORIES= graphics
MASTER_SITES= LOCAL/sunpoet
diff --git a/graphics/php55-exif/Makefile b/graphics/php55-exif/Makefile
index 347a55693c95..6b479d4b9a6d 100644
--- a/graphics/php55-exif/Makefile
+++ b/graphics/php55-exif/Makefile
@@ -1,6 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= graphics
MASTERDIR= ${.CURDIR}/../../lang/php55
diff --git a/graphics/php55-gd/Makefile b/graphics/php55-gd/Makefile
index 6d549ce17dce..624b80b64de9 100644
--- a/graphics/php55-gd/Makefile
+++ b/graphics/php55-gd/Makefile
@@ -1,6 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= graphics
MASTERDIR= ${.CURDIR}/../../lang/php55
diff --git a/graphics/php56-exif/Makefile b/graphics/php56-exif/Makefile
index 13a6387c6997..bd9f998ffde9 100644
--- a/graphics/php56-exif/Makefile
+++ b/graphics/php56-exif/Makefile
@@ -1,6 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= graphics
MASTERDIR= ${.CURDIR}/../../lang/php56
diff --git a/graphics/php56-gd/Makefile b/graphics/php56-gd/Makefile
index 4746215748f7..4979a92bb137 100644
--- a/graphics/php56-gd/Makefile
+++ b/graphics/php56-gd/Makefile
@@ -1,6 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= graphics
MASTERDIR= ${.CURDIR}/../../lang/php56
diff --git a/graphics/php70-exif/Makefile b/graphics/php70-exif/Makefile
index b82d12848cce..7aa6b34ccf6f 100644
--- a/graphics/php70-exif/Makefile
+++ b/graphics/php70-exif/Makefile
@@ -1,6 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= graphics
MASTERDIR= ${.CURDIR}/../../lang/php70
diff --git a/graphics/php70-gd/Makefile b/graphics/php70-gd/Makefile
index 53aff8871d6e..f42efd1f9ce7 100644
--- a/graphics/php70-gd/Makefile
+++ b/graphics/php70-gd/Makefile
@@ -1,6 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= graphics
MASTERDIR= ${.CURDIR}/../../lang/php70