aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorru <ru@FreeBSD.org>2002-07-22 03:21:04 +0800
committerru <ru@FreeBSD.org>2002-07-22 03:21:04 +0800
commit45473cc058c6b06f62e478cff736391475705908 (patch)
treee9346dab96075160d9a8a35b954c34860028e46f /graphics
parent976b4d7a28f9c174a9f988ec320fec69c8bc96e4 (diff)
downloadfreebsd-ports-gnome-45473cc058c6b06f62e478cff736391475705908.tar.gz
freebsd-ports-gnome-45473cc058c6b06f62e478cff736391475705908.tar.zst
freebsd-ports-gnome-45473cc058c6b06f62e478cff736391475705908.zip
Fixed install on post-bsd.incs.mk systems by replacing the non-working
3.x hacks in files/Makefile (shell commands must be preceded by a tab) with pre-bsd.incs.mk hacks and using the new API (INCSGROUPS).
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ming/Makefile3
-rw-r--r--graphics/ming/files/Makefile39
2 files changed, 21 insertions, 21 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index b4287a563995..f7301c85eaba 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -69,6 +69,9 @@ post-build:
cd ${WRKSRC}/../util && \
${CC} ${CFLAGS} -L${PREFIX}/lib -o swftophp swftophp.o blocktypes.o decompile.o read.o -lm
+pre-install:
+ ${MKDIR} ${PREFIX}/include/ming/blocks
+
post-install:
.for f in ${UTILS}
${INSTALL_PROGRAM} ${WRKSRC}/../util/${f} ${PREFIX}/bin/
diff --git a/graphics/ming/files/Makefile b/graphics/ming/files/Makefile
index 0f1057fb25c3..6aa45b0f97e9 100644
--- a/graphics/ming/files/Makefile
+++ b/graphics/ming/files/Makefile
@@ -52,6 +52,7 @@ SRCS= blocklist.c \
blocks/sprite.c \
blocks/text.c \
blocks/textfield.c
+INCSGROUPS= INCS BLKS
INCS= blocklist.h \
blocktypes.h \
displaylist.h \
@@ -68,30 +69,25 @@ INCS= blocklist.h \
NOMAN= YES
LIBDIR= ${LOCALBASE}/lib
-INCDIR= ${LOCALBASE}/include/ming
+INCSDIR= ${LOCALBASE}/include/ming
-.include <bsd.lib.mk>
-
-# For FreeBSD 3.x or older
-.if !target(_includeinstall)
-_includeinstall:
-.if defined(INCS)
-.for header in ${INCS}
- cd ${.CURDIR} && \
- ${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
- ${header} ${DESTDIR}${INCDIR}
+BLKS= block.h cxform.h \
+ error.h exports.h \
+ input.h matrix.h \
+ outputblock.h placeobject.h \
+ sound.h sprite.h \
+ swf.h blocktypes.h \
+ character.h libswf.h \
+ method.h output.h \
+ rect.h
+BLKS:= ${BLKS:S;^;${.CURDIR}/blocks/;}
+BLKSDIR= ${INCSDIR}/blocks
-.endfor
-.endif
-
-beforeinstall: _includeinstall
-.endif
-
-_includeinstall: pre-_includeinstall
-
-pre-_includeinstall:
- mkdir -p ${DESTDIR}${INCDIR}/blocks
+.include <bsd.lib.mk>
+# For pre-bsd.incs.mk API
+.if defined(INCOWN)
+INCDIR= ${INCSDIR}
beforeinstall:
${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
${.CURDIR}/blocks/block.h ${.CURDIR}/blocks/cxform.h \
@@ -103,6 +99,7 @@ beforeinstall:
${.CURDIR}/blocks/character.h ${.CURDIR}/blocks/libswf.h \
${.CURDIR}/blocks/method.h ${.CURDIR}/blocks/output.h \
${.CURDIR}/blocks/rect.h ${INCDIR}/blocks/
+.endif
dynamic: lib${LIB}.so