aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-04-04 17:46:30 +0800
committerjbeich <jbeich@FreeBSD.org>2018-04-04 17:46:30 +0800
commit46de9ad6594380b3db1d39562a1ef281cd16c8b5 (patch)
tree39fa1c465e6b3f6b92c015f39dd827be83b81537 /graphics
parentca92a42bbc9041e4d94f10bedffa5407f9c1ec94 (diff)
downloadfreebsd-ports-gnome-46de9ad6594380b3db1d39562a1ef281cd16c8b5.tar.gz
freebsd-ports-gnome-46de9ad6594380b3db1d39562a1ef281cd16c8b5.tar.zst
freebsd-ports-gnome-46de9ad6594380b3db1d39562a1ef281cd16c8b5.zip
graphics/mapnik: unbreak with ICU 61
src/text/text_layout.cpp:234:5: error: unknown type name 'Locale'; did you mean 'icu::Locale'? Locale locale; // TODO: Is the default constructor correct? ^~~~~~ icu::Locale /usr/local/include/unicode/locid.h:188:20: note: 'icu::Locale' declared here class U_COMMON_API Locale : public UObject { ^ src/text/text_layout.cpp:236:21: error: unknown type name 'BreakIterator'; did you mean 'UBreakIterator'? std::unique_ptr<BreakIterator> breakitr(BreakIterator::createLineInstance(locale, status)); ^~~~~~~~~~~~~ UBreakIterator /usr/local/include/unicode/ustring.h:33:35: note: 'UBreakIterator' declared here typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:236:45: error: use of undeclared identifier 'BreakIterator'; did you mean 'UBreakIterator'? std::unique_ptr<BreakIterator> breakitr(BreakIterator::createLineInstance(locale, status)); ^~~~~~~~~~~~~ UBreakIterator /usr/local/include/unicode/ustring.h:33:35: note: 'UBreakIterator' declared here typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:236:45: error: incomplete type 'UBreakIterator' named in nested name specifier std::unique_ptr<BreakIterator> breakitr(BreakIterator::createLineInstance(locale, status)); ^~~~~~~~~~~~~~~ /usr/local/include/unicode/ustring.h:33:20: note: forward declaration of 'UBreakIterator' typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:247:13: error: member access into incomplete type 'UBreakIterator' breakitr->setText(text); ^ /usr/local/include/unicode/ustring.h:33:20: note: forward declaration of 'UBreakIterator' typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:260:53: error: member access into incomplete type 'UBreakIterator' int break_position = wrap_before_ ? breakitr->preceding(i + 1) : breakitr->following(i); ^ /usr/local/include/unicode/ustring.h:33:20: note: forward declaration of 'UBreakIterator' typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:260:55: error: expected ':' int break_position = wrap_before_ ? breakitr->preceding(i + 1) : breakitr->following(i); ^ : src/text/text_layout.cpp:260:43: note: to match this '?' int break_position = wrap_before_ ? breakitr->preceding(i + 1) : breakitr->following(i); ^ src/text/text_layout.cpp:260:55: error: use of undeclared identifier 'preceding' int break_position = wrap_before_ ? breakitr->preceding(i + 1) : breakitr->following(i); ^ src/text/text_layout.cpp:263:89: error: use of undeclared identifier 'BreakIterator'; did you mean 'UBreakIterator'? if (break_position <= last_break_position || break_position == static_cast<int>(BreakIterator::DONE)) ^~~~~~~~~~~~~ UBreakIterator /usr/local/include/unicode/ustring.h:33:35: note: 'UBreakIterator' declared here typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:263:89: error: incomplete type 'UBreakIterator' named in nested name specifier if (break_position <= last_break_position || break_position == static_cast<int>(BreakIterator::DONE)) ^~~~~~~~~~~~~~~ /usr/local/include/unicode/ustring.h:33:20: note: forward declaration of 'UBreakIterator' typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:267:38: error: member access into incomplete type 'UBreakIterator' break_position = breakitr->following(i); ^ /usr/local/include/unicode/ustring.h:33:20: note: forward declaration of 'UBreakIterator' typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:268:52: error: use of undeclared identifier 'BreakIterator'; did you mean 'UBreakIterator'? if (break_position == static_cast<int>(BreakIterator::DONE)) ^~~~~~~~~~~~~ UBreakIterator /usr/local/include/unicode/ustring.h:33:35: note: 'UBreakIterator' declared here typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:268:52: error: incomplete type 'UBreakIterator' named in nested name specifier if (break_position == static_cast<int>(BreakIterator::DONE)) ^~~~~~~~~~~~~~~ /usr/local/include/unicode/ustring.h:33:20: note: forward declaration of 'UBreakIterator' typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:373:89: error: use of undeclared identifier 'BreakIterator'; did you mean 'UBreakIterator'? if (break_position <= last_break_position || break_position == static_cast<int>(BreakIterator::DONE)) ^~~~~~~~~~~~~ UBreakIterator /usr/local/include/unicode/ustring.h:33:35: note: 'UBreakIterator' declared here typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:373:89: error: incomplete type 'UBreakIterator' named in nested name specifier if (break_position <= last_break_position || break_position == static_cast<int>(BreakIterator::DONE)) ^~~~~~~~~~~~~~~ /usr/local/include/unicode/ustring.h:33:20: note: forward declaration of 'UBreakIterator' typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:376:52: error: use of undeclared identifier 'BreakIterator'; did you mean 'UBreakIterator'? if (break_position == static_cast<int>(BreakIterator::DONE)) ^~~~~~~~~~~~~ UBreakIterator /usr/local/include/unicode/ustring.h:33:35: note: 'UBreakIterator' declared here typedef struct UBreakIterator UBreakIterator; ^ src/text/text_layout.cpp:376:52: error: incomplete type 'UBreakIterator' named in nested name specifier if (break_position == static_cast<int>(BreakIterator::DONE)) ^~~~~~~~~~~~~~~ /usr/local/include/unicode/ustring.h:33:20: note: forward declaration of 'UBreakIterator' typedef struct UBreakIterator UBreakIterator; ^ https://ssl.icu-project.org/trac/changeset/40705 PR: 227042 Reported by: antoine (via exp-run) Obtained from: upstream
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mapnik/Makefile3
-rw-r--r--graphics/mapnik/distinfo3
2 files changed, 6 insertions, 0 deletions
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index de3dcedf27ec..22e69791ebb2 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -8,6 +8,9 @@ PORTREVISION= 16
CATEGORIES= graphics geography
MASTER_SITES= http://mapnik.s3.amazonaws.com/dist/v${PORTVERSION}/
+PATCH_SITES= https://github.com/mapnik/mapnik/commit/
+PATCHFILES= 1ddfe6c31548.patch:-p1
+
MAINTAINER= littlesavage@rambler.ru
COMMENT= Free Toolkit For Developing Mapping Applications
diff --git a/graphics/mapnik/distinfo b/graphics/mapnik/distinfo
index bfc581dc3255..f503729d2fa0 100644
--- a/graphics/mapnik/distinfo
+++ b/graphics/mapnik/distinfo
@@ -1,2 +1,5 @@
+TIMESTAMP = 1448548335
SHA256 (mapnik-v3.0.9.tar.bz2) = 3a3f67532b05f8a527a5bab32effd7dd5aa59165c7e24505268f6d827955d3da
SIZE (mapnik-v3.0.9.tar.bz2) = 75213927
+SHA256 (1ddfe6c31548.patch) = fab754996485dc607108a4fd69d0df82414928eb5a210b329a84f47e90da0c8a
+SIZE (1ddfe6c31548.patch) = 2148