aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-03-01 00:22:30 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-03-01 00:22:30 +0800
commit4d9cddd57ba938e04a913d1bf47e3f54cdf6b2a3 (patch)
tree0dc7e70f42d0a796b2970f8924e85875e6883797 /graphics
parenta2215db484f2aa5162d5eb9c23a3615e938b9987 (diff)
downloadfreebsd-ports-gnome-4d9cddd57ba938e04a913d1bf47e3f54cdf6b2a3.tar.gz
freebsd-ports-gnome-4d9cddd57ba938e04a913d1bf47e3f54cdf6b2a3.tar.zst
freebsd-ports-gnome-4d9cddd57ba938e04a913d1bf47e3f54cdf6b2a3.zip
- Update to 2.0
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gimp-resynthesizer/Makefile50
-rw-r--r--graphics/gimp-resynthesizer/distinfo4
-rw-r--r--graphics/gimp-resynthesizer/pkg-message15
-rw-r--r--graphics/gimp-resynthesizer/pkg-plist18
4 files changed, 55 insertions, 32 deletions
diff --git a/graphics/gimp-resynthesizer/Makefile b/graphics/gimp-resynthesizer/Makefile
index 2a836c5db6cf..7f081b604e3e 100644
--- a/graphics/gimp-resynthesizer/Makefile
+++ b/graphics/gimp-resynthesizer/Makefile
@@ -1,42 +1,42 @@
-# New ports collection makefile for: resynthesizer
-# Date created: 05 May 2010
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= resynthesizer
-PORTVERSION= 0.16
-PORTREVISION= 2
+PORTVERSION= 2.0
CATEGORIES= graphics
-MASTER_SITES= http://www.logarithmic.net/pfh-files/resynthesizer/ \
- http://mirror.amdmi3.ru/distfiles/
PKGNAMEPREFIX= gimp-
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Gimp plug-in for texture synthesis
+RUN_DEPENDS= ${LOCALBASE}/libexec/gimp/2.2/python/gimpfu.py:${PORTSDIR}/graphics/py-gimp
+BUILD_DEPENDS= intltool-extract:${PORTSDIR}/textproc/intltool
LIB_DEPENDS= gimp-2.0:${PORTSDIR}/graphics/gimp-app
-GIMPTOOL?= gimptool-2.0
-PLUGINS_DIR?= libexec/gimp/2.2/plug-ins
-SCRIPTS_DIR?= share/gimp/scripts
+USE_GITHUB= yes
+GH_ACCOUNT= bootchk
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 28cade5
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lintl"
USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
-PLIST_FILES= ${PLUGINS_DIR}/resynth \
- ${SCRIPTS_DIR}/smart-enlarge.scm \
- ${SCRIPTS_DIR}/smart-remove.scm
-
-do-build:
- cd ${WRKSRC} && ${CXX} ${CXXFLAGS} \
- `${GIMPTOOL} --cflags --libs` -o resynth resynth.cc
-
-do-install:
- ${MKDIR} ${PREFIX}/${PLUGINS_DIR} ${PREFIX}/${SCRIPTS_DIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/resynth ${PREFIX}/${PLUGINS_DIR}
- ${INSTALL_DATA} ${WRKSRC}/smart-enlarge.scm \
- ${WRKSRC}/smart-remove.scm ${PREFIX}/${SCRIPTS_DIR}
+USE_AUTOTOOLS= aclocal automake
+USE_GMAKE= yes
+
+OPTIONS_DEFINE= THREADS
+THREADS_DESC= Threading support (produces nondeterministic results)
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(gimpplugindir=\).*|\1"$$GIMP_LIBDIR"|' \
+ ${WRKSRC}/configure
+.if ! ${PORT_OPTIONS:MTHREADS}
+ @${REINPLACE_CMD} -e '/^#define SYNTH_THREADED/ d' \
+ ${WRKSRC}/src/buildSwitches.h
+.endif
post-install:
@${ECHO_CMD}
diff --git a/graphics/gimp-resynthesizer/distinfo b/graphics/gimp-resynthesizer/distinfo
index b25dd5c23135..07ca426ad227 100644
--- a/graphics/gimp-resynthesizer/distinfo
+++ b/graphics/gimp-resynthesizer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (resynthesizer-0.16.tar.gz) = dd24ec89f3a36f867b733c6a5c1d193b6d603251bd6553ac54b573fd655020cd
-SIZE (resynthesizer-0.16.tar.gz) = 18241
+SHA256 (resynthesizer-2.0.tar.gz) = ce019c07422888b12596abd292f9f954b8495aca1d113cb6c7d5d207e594119b
+SIZE (resynthesizer-2.0.tar.gz) = 11168594
diff --git a/graphics/gimp-resynthesizer/pkg-message b/graphics/gimp-resynthesizer/pkg-message
index dfc9b08aa7f1..38fd204493a3 100644
--- a/graphics/gimp-resynthesizer/pkg-message
+++ b/graphics/gimp-resynthesizer/pkg-message
@@ -1,7 +1,12 @@
-After restarting the Gimp you should find the following items in
-the pop-up image menu:
+After restarting the Gimp you should find the following new items
+in the menu:
+ * Edit/Fill with pattern seamless
+ * Filters/Enhance/Enlarge & sharpen
+ * Filters/Enhance/Heal selection
+ * Filters/Enhance/Heal transparency
+ * Filters/Enhance/Sharpen by synthesis
+ * Filters/Enhance/Uncrop
* Filters/Map/Resynthesize
- * Filters/Enhance/Smart enlarge
- * Filters/Enhance/Smart sharpen
- * Filters/Enhance/Smart remove selection
+ * Filters/Map/Style
+ * Filters/Render/Texture
diff --git a/graphics/gimp-resynthesizer/pkg-plist b/graphics/gimp-resynthesizer/pkg-plist
new file mode 100644
index 000000000000..bcd83b6fcdae
--- /dev/null
+++ b/graphics/gimp-resynthesizer/pkg-plist
@@ -0,0 +1,18 @@
+libexec/gimp/2.2/plug-ins/plugin-heal-selection.py
+libexec/gimp/2.2/plug-ins/plugin-heal-transparency.py
+libexec/gimp/2.2/plug-ins/plugin-map-style.py
+libexec/gimp/2.2/plug-ins/plugin-render-texture.py
+libexec/gimp/2.2/plug-ins/plugin-resynth-enlarge.py
+libexec/gimp/2.2/plug-ins/plugin-resynth-fill-pattern.py
+libexec/gimp/2.2/plug-ins/plugin-resynth-sharpen.py
+libexec/gimp/2.2/plug-ins/plugin-uncrop.py
+libexec/gimp/2.2/plug-ins/resynthesizer
+libexec/gimp/2.2/plug-ins/resynthesizer_gui
+share/locale/es/LC_MESSAGES/resynthesizer.mo
+%%DATADIR%%/help/en/gimp-help.xml
+%%DATADIR%%/help/en/index.html
+%%DATADIR%%/help/images/wilber.png
+@dirrm %%DATADIR%%/help/images
+@dirrm %%DATADIR%%/help/en
+@dirrm %%DATADIR%%/help
+@dirrm %%DATADIR%%