aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-08-05 04:04:38 +0800
committermiwi <miwi@FreeBSD.org>2009-08-05 04:04:38 +0800
commit5153f40d24ec33479bb3f8c06e1c33f0c9e052d1 (patch)
tree2781cac7d68b8246efd7f5d5bf764de05aee8338 /graphics
parent32198db977429daaf8bbf3ef8312d29a0e17083d (diff)
downloadfreebsd-ports-gnome-5153f40d24ec33479bb3f8c06e1c33f0c9e052d1.tar.gz
freebsd-ports-gnome-5153f40d24ec33479bb3f8c06e1c33f0c9e052d1.tar.zst
freebsd-ports-gnome-5153f40d24ec33479bb3f8c06e1c33f0c9e052d1.zip
- Update Qt4 to 4.5.2
The KDE FreeBSD team would like to say thanks to all the helpers and submitters. Tested by: pointyhat-exp-run (pav/miwi)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/qt4-iconengines/Makefile25
-rw-r--r--graphics/qt4-iconengines/distinfo6
-rw-r--r--graphics/qt4-iconengines/pkg-plist16
-rw-r--r--graphics/qt4-imageformats/Makefile3
-rw-r--r--graphics/qt4-imageformats/distinfo6
-rw-r--r--graphics/qt4-pixeltool/Makefile1
-rw-r--r--graphics/qt4-pixeltool/distinfo6
-rw-r--r--graphics/qt4-svg/Makefile1
-rw-r--r--graphics/qt4-svg/distinfo6
-rw-r--r--graphics/qt4-svg/pkg-plist6
10 files changed, 48 insertions, 28 deletions
diff --git a/graphics/qt4-iconengines/Makefile b/graphics/qt4-iconengines/Makefile
index cc1bb506cbd2..6c160ac672f7 100644
--- a/graphics/qt4-iconengines/Makefile
+++ b/graphics/qt4-iconengines/Makefile
@@ -6,7 +6,7 @@
# $FreeBSD$
#
-PORTNAME= iconengines
+PORTNAME= imageformats
PORTVERSION= ${QT4_VERSION}
PORTREVISION=0
CATEGORIES?= graphics
@@ -16,12 +16,18 @@ DISTNAME= qt-x11-opensource-src-${PORTVERSION}
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt SVG icon engine plugin
+COMMENT= Qt imageformat plugins for GIF, JPEG, MNG and SVG
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ mng:${PORTSDIR}/graphics/libmng \
+ png:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff
USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build corelib gui svg xml
+QT_COMPONENTS= qmake_build moc_build rcc_build corelib gui svg xml
QT_NONSTANDARD= yes
QT_DIST= yes
+MAKE_JOBS_SAFE= true
HAS_CONFIGURE= yes
@@ -35,18 +41,19 @@ DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
src/qt3support src/script src/sql src/testlib \
src/tools src/xmlpatterns src/3rdparty/clucene \
src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+EXTRACT_AFTER_ARGS= |${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
-WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/iconengines/svgiconengine
-CONFIGURE_WRKSRC=${WRKSRC}/../../../..
+WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/${PORTNAME}
+CONFIGURE_WRKSRC=${WRKSRC}/../../..
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
- ${MKDIR} ${WRKSRC}/../../../../mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../../bin/moc
+ ${MKDIR} ${WRKSRC}/../../../mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../../bin/rcc
.include <bsd.port.mk>
diff --git a/graphics/qt4-iconengines/distinfo b/graphics/qt4-iconengines/distinfo
index 1756af8b04d9..27b0949354e8 100644
--- a/graphics/qt4-iconengines/distinfo
+++ b/graphics/qt4-iconengines/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 376c003317c4417326ba2116370227d0
-SHA256 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 79ea9fb46d75c3759e3e98ab0064a47eaa5bdbbc2a53d923d60bd8e9cd0bc5c6
-SIZE (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 112939803
+MD5 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = d8bcc070a58db25c228b7729ffad4550
+SHA256 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 4e4c8619335cac14ba0c52d1555fab549a562fb774c1c08dcbd2be9de38120a2
+SIZE (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 125803421
diff --git a/graphics/qt4-iconengines/pkg-plist b/graphics/qt4-iconengines/pkg-plist
index e3eafa6f386f..1b01f5eb0bca 100644
--- a/graphics/qt4-iconengines/pkg-plist
+++ b/graphics/qt4-iconengines/pkg-plist
@@ -1,3 +1,13 @@
-lib/qt4/plugins/iconengines/libqsvgicon.so
-%%DEBUG%%lib/qt4/plugins/iconengines/libqsvgicon.so.debug
-@dirrmtry lib/qt4/plugins/iconengines
+lib/qt4/plugins/imageformats/libqgif.so
+%%DEBUG%%lib/qt4/plugins/imageformats/libqgif.so.debug
+lib/qt4/plugins/imageformats/libqjpeg.so
+%%DEBUG%%lib/qt4/plugins/imageformats/libqjpeg.so.debug
+lib/qt4/plugins/imageformats/libqmng.so
+%%DEBUG%%lib/qt4/plugins/imageformats/libqmng.so.debug
+lib/qt4/plugins/imageformats/libqsvg.so
+%%DEBUG%%lib/qt4/plugins/imageformats/libqsvg.so.debug
+lib/qt4/plugins/imageformats/libqtiff.so
+%%DEBUG%%lib/qt4/plugins/imageformats/libqtiff.so.debug
+lib/qt4/plugins/imageformats/libqico.so
+%%DEBUG%%lib/qt4/plugins/imageformats/libqico.so.debug
+@dirrmtry lib/qt4/plugins/imageformats
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index 1c63e8571fe9..6c160ac672f7 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -8,7 +8,7 @@
PORTNAME= imageformats
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
+PORTREVISION=0
CATEGORIES?= graphics
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -27,6 +27,7 @@ USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build rcc_build corelib gui svg xml
QT_NONSTANDARD= yes
QT_DIST= yes
+MAKE_JOBS_SAFE= true
HAS_CONFIGURE= yes
diff --git a/graphics/qt4-imageformats/distinfo b/graphics/qt4-imageformats/distinfo
index 1756af8b04d9..27b0949354e8 100644
--- a/graphics/qt4-imageformats/distinfo
+++ b/graphics/qt4-imageformats/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 376c003317c4417326ba2116370227d0
-SHA256 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 79ea9fb46d75c3759e3e98ab0064a47eaa5bdbbc2a53d923d60bd8e9cd0bc5c6
-SIZE (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 112939803
+MD5 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = d8bcc070a58db25c228b7729ffad4550
+SHA256 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 4e4c8619335cac14ba0c52d1555fab549a562fb774c1c08dcbd2be9de38120a2
+SIZE (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 125803421
diff --git a/graphics/qt4-pixeltool/Makefile b/graphics/qt4-pixeltool/Makefile
index 1f1e2a1e15b2..ebdb35f2f840 100644
--- a/graphics/qt4-pixeltool/Makefile
+++ b/graphics/qt4-pixeltool/Makefile
@@ -22,6 +22,7 @@ USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build corelib gui network
QT_NONSTANDARD= yes
QT_DIST= yes
+MAKE_JOBS_SAFE= yes
HAS_CONFIGURE= yes
diff --git a/graphics/qt4-pixeltool/distinfo b/graphics/qt4-pixeltool/distinfo
index 1756af8b04d9..27b0949354e8 100644
--- a/graphics/qt4-pixeltool/distinfo
+++ b/graphics/qt4-pixeltool/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 376c003317c4417326ba2116370227d0
-SHA256 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 79ea9fb46d75c3759e3e98ab0064a47eaa5bdbbc2a53d923d60bd8e9cd0bc5c6
-SIZE (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 112939803
+MD5 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = d8bcc070a58db25c228b7729ffad4550
+SHA256 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 4e4c8619335cac14ba0c52d1555fab549a562fb774c1c08dcbd2be9de38120a2
+SIZE (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 125803421
diff --git a/graphics/qt4-svg/Makefile b/graphics/qt4-svg/Makefile
index c6a49a65a67f..2ac35bc34817 100644
--- a/graphics/qt4-svg/Makefile
+++ b/graphics/qt4-svg/Makefile
@@ -21,6 +21,7 @@ USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build corelib gui
QT_NONSTANDARD= yes
QT_DIST= yes
+MAKE_JOBS_SAFE= yes
HAS_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/lib/qt4
diff --git a/graphics/qt4-svg/distinfo b/graphics/qt4-svg/distinfo
index 1756af8b04d9..27b0949354e8 100644
--- a/graphics/qt4-svg/distinfo
+++ b/graphics/qt4-svg/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 376c003317c4417326ba2116370227d0
-SHA256 (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 79ea9fb46d75c3759e3e98ab0064a47eaa5bdbbc2a53d923d60bd8e9cd0bc5c6
-SIZE (KDE/qt-x11-opensource-src-4.4.3.tar.gz) = 112939803
+MD5 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = d8bcc070a58db25c228b7729ffad4550
+SHA256 (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 4e4c8619335cac14ba0c52d1555fab549a562fb774c1c08dcbd2be9de38120a2
+SIZE (KDE/qt-x11-opensource-src-4.5.2.tar.gz) = 125803421
diff --git a/graphics/qt4-svg/pkg-plist b/graphics/qt4-svg/pkg-plist
index 5ae813825bc6..f2bd42e1b9e3 100644
--- a/graphics/qt4-svg/pkg-plist
+++ b/graphics/qt4-svg/pkg-plist
@@ -16,9 +16,9 @@ lib/qt4/libQtSvg.la
lib/qt4/libQtSvg.prl
lib/qt4/libQtSvg.so
lib/qt4/libQtSvg.so.4
-lib/qt4/libQtSvg.so.4.4
-lib/qt4/libQtSvg.so.4.4.3
-%%DEBUG%%lib/qt4/libQtSvg.so.4.4.3.debug
+lib/qt4/libQtSvg.so.4.5
+lib/qt4/libQtSvg.so.4.5.2
+%%DEBUG%%lib/qt4/libQtSvg.so.4.5.2.debug
libdata/pkgconfig/QtSvg.pc
@dirrm include/qt4/QtSvg
@dirrmtry include/qt4/Qt