aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-04-11 02:54:22 +0800
committermiwi <miwi@FreeBSD.org>2007-04-11 02:54:22 +0800
commit51fb296beed0c7b0c89ca700321f91e9934a5cb9 (patch)
tree6cf8c5403854ec1064ccaece9ddbbf3779d45f68 /graphics
parent27c17fd1f901f474c0a2c45d6d4fbc4b52e8febc (diff)
downloadfreebsd-ports-gnome-51fb296beed0c7b0c89ca700321f91e9934a5cb9.tar.gz
freebsd-ports-gnome-51fb296beed0c7b0c89ca700321f91e9934a5cb9.tar.zst
freebsd-ports-gnome-51fb296beed0c7b0c89ca700321f91e9934a5cb9.zip
Animorph is a morphing engine responsible for calculating and then
executing all the real time changes to the MakeHuman basemesh, as required by the user's morph target selections and those target's value settings. Naturally, it also loads and saves character body setting (.bs) files. WWW: http://www.dedalo-3d.com/index.php PR: ports/111075 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/animorph/Makefile32
-rw-r--r--graphics/animorph/distinfo3
-rw-r--r--graphics/animorph/pkg-descr7
-rw-r--r--graphics/animorph/pkg-plist40
5 files changed, 83 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 2f112ca6565c..157e3c4d760d 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -21,6 +21,7 @@
SUBDIR += ale
SUBDIR += allegrogl
SUBDIR += amanith
+ SUBDIR += animorph
SUBDIR += aoi
SUBDIR += aolserver-nsgd
SUBDIR += aqsis
diff --git a/graphics/animorph/Makefile b/graphics/animorph/Makefile
new file mode 100644
index 000000000000..bfc32241a9a0
--- /dev/null
+++ b/graphics/animorph/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: animorph
+# Date created: 31 Mar 2007
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= animorph
+PORTVERSION= 0.2
+CATEGORIES= graphics
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= makehuman
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Morphing engine for MakeHuman
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^libanimorphdocdir =/ s|doc/|share/doc/|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^pkgconfigdir =/ s|\$$(libdir)|\$$(exec_prefix)/libdata|' ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-libanimorphdocDATA||' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/animorph/distinfo b/graphics/animorph/distinfo
new file mode 100644
index 000000000000..f42a52949b13
--- /dev/null
+++ b/graphics/animorph/distinfo
@@ -0,0 +1,3 @@
+MD5 (animorph-0.2.tar.gz) = 90cfb95f5eb0b49df0ab5c717e26b2e0
+SHA256 (animorph-0.2.tar.gz) = acb37c9b1b0331613f7bd379e7a201aade14eb1bab40201977771057f378abd4
+SIZE (animorph-0.2.tar.gz) = 313115
diff --git a/graphics/animorph/pkg-descr b/graphics/animorph/pkg-descr
new file mode 100644
index 000000000000..ca59064b524d
--- /dev/null
+++ b/graphics/animorph/pkg-descr
@@ -0,0 +1,7 @@
+Animorph is a morphing engine responsible for calculating and then
+executing all the real time changes to the MakeHuman basemesh, as
+required by the user's morph target selections and those target's value
+settings. Naturally, it also loads and saves character body setting
+(.bs) files.
+
+WWW: http://www.dedalo-3d.com/index.php
diff --git a/graphics/animorph/pkg-plist b/graphics/animorph/pkg-plist
new file mode 100644
index 000000000000..e5322bdffcde
--- /dev/null
+++ b/graphics/animorph/pkg-plist
@@ -0,0 +1,40 @@
+include/animorph/BodySettings.h
+include/animorph/Color.h
+include/animorph/DirectoryList.h
+include/animorph/Euler.h
+include/animorph/Face.h
+include/animorph/FaceVector.h
+include/animorph/FileReader.h
+include/animorph/FileWriter.h
+include/animorph/Hotspot.h
+include/animorph/Material.h
+include/animorph/MathUtil.h
+include/animorph/Matrix.h
+include/animorph/Mesh.h
+include/animorph/ObjExporter.h
+include/animorph/PoseSemiTarget.h
+include/animorph/PoseTarget.h
+include/animorph/Quaternion.h
+include/animorph/RIBExporter.h
+include/animorph/Target.h
+include/animorph/TextureVector.h
+include/animorph/Vector2.h
+include/animorph/Vector3.h
+include/animorph/Vertex.h
+include/animorph/VertexGroup.h
+include/animorph/VertexVector.h
+include/animorph/util.h
+lib/libanimorph.a
+lib/libanimorph.la
+lib/libanimorph.so
+lib/libanimorph.so.0
+libdata/pkgconfig/animorph.pc
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/animorph