aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2012-06-03 17:14:18 +0800
committermm <mm@FreeBSD.org>2012-06-03 17:14:18 +0800
commit531827fde95cb4006ff778aa1f9c30f454018038 (patch)
treeccf0ac5ca7e28c99e7408e70073724d4be622bcb /graphics
parent683579c2c3aa1ffce8d533c40f07f9ebc31e9296 (diff)
downloadfreebsd-ports-gnome-531827fde95cb4006ff778aa1f9c30f454018038.tar.gz
freebsd-ports-gnome-531827fde95cb4006ff778aa1f9c30f454018038.tar.zst
freebsd-ports-gnome-531827fde95cb4006ff778aa1f9c30f454018038.zip
Fix build with PHP 5.4
Fix LIB_DEPENDS
Diffstat (limited to 'graphics')
-rw-r--r--graphics/php-facedetect/Makefile12
-rw-r--r--graphics/php-facedetect/distinfo4
2 files changed, 9 insertions, 7 deletions
diff --git a/graphics/php-facedetect/Makefile b/graphics/php-facedetect/Makefile
index 2957b27799c2..21797e235d79 100644
--- a/graphics/php-facedetect/Makefile
+++ b/graphics/php-facedetect/Makefile
@@ -7,6 +7,7 @@
PORTNAME= facedetect
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= https://github.com/infusion/PHP-Facedetect/tarball/${GITVERSION}/
PKGNAMEPREFIX= php-
@@ -15,23 +16,24 @@ DISTNAME= infusion-PHP-Facedetect-${GITVERSION}
MAINTAINER= mm@FreeBSD.org
COMMENT= Face detection extension for PHP using OpenCV library
-LIB_DEPENDS= opencv_legacy.2:${PORTSDIR}/graphics/opencv
-
LICENSE= PHP30
-GITVERSION= 75a1d8f
+LIB_DEPENDS= opencv_core.2:${PORTSDIR}/graphics/opencv-core \
+ opencv_objdetect.2:${PORTSDIR}/graphics/opencv \
+
+GITVERSION= 4b1dfe1
FETCH_ARGS= -pRr
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -lopencv_core
USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
CONFIGURE_ARGS+= --with-facedetect
+CONFIGURE_ENV+= LIBS="${LIBS}"
.include <bsd.port.pre.mk>
diff --git a/graphics/php-facedetect/distinfo b/graphics/php-facedetect/distinfo
index 8521f7c3aae0..c66887db85fc 100644
--- a/graphics/php-facedetect/distinfo
+++ b/graphics/php-facedetect/distinfo
@@ -1,2 +1,2 @@
-SHA256 (infusion-PHP-Facedetect-75a1d8f.tar.gz) = e9deeeeee359adf7eb00a4fe45866908d7f2c8238a8cd7832e5ef3998ec04d01
-SIZE (infusion-PHP-Facedetect-75a1d8f.tar.gz) = 2981
+SHA256 (infusion-PHP-Facedetect-4b1dfe1.tar.gz) = 2e2361e0a26d7a959e9e5ba6aec78cf21a6ad631baf7e853fa9a0d1ed3a55ac1
+SIZE (infusion-PHP-Facedetect-4b1dfe1.tar.gz) = 2979