aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2014-06-21 16:52:18 +0800
committerwen <wen@FreeBSD.org>2014-06-21 16:52:18 +0800
commit53f75e54a49feca219bb5b472f72d5e184283571 (patch)
tree73b53884099b844db0063995d684af8efbc608ec /graphics
parent10973cbde60ce5a72f4f919efa68e9845f8d7262 (diff)
downloadfreebsd-ports-gnome-53f75e54a49feca219bb5b472f72d5e184283571.tar.gz
freebsd-ports-gnome-53f75e54a49feca219bb5b472f72d5e184283571.tar.zst
freebsd-ports-gnome-53f75e54a49feca219bb5b472f72d5e184283571.zip
- Add options CLIENT_WMS CLIENT_WFS
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mapserver/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 9994f37bb0bf..e211749001b9 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mapserver
PORTVERSION= 6.4.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics www geography
MASTER_SITES= http://download.osgeo.org/mapserver/
@@ -25,8 +25,9 @@ CMAKE_ARGS+= -DCMAKE_PREFIX_PATH=${LOCALBASE} \
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= FRIBIDI CURL GDAL GEOS KML POSTGIS PHP PERL PYTHON \
- WMS WFS WCS FASTCGI DEBUG CAIRO CAIRO_SVG
-OPTIONS_DEFAULT= FRIBIDI GDAL GEOS
+ WMS WFS WCS FASTCGI DEBUG CAIRO CAIRO_SVG \
+ CLIENT_WMS CLIENT_WFS
+OPTIONS_DEFAULT= FRIBIDI GDAL GEOS CLIENT_WMS CLIENT_WFS
CAIRO_SVG_DESC= Cairo SVG parser support
GDAL_DESC= GDAL library support
FRIBIDI_DESC= Fribidi library support
@@ -165,6 +166,18 @@ CMAKE_ARGS+= -DCMAKE_BUILD_TYPE=Release
PROG_FILES= legend scalebar shp2img shptree shptreetst shptreevis \
sortshp msencrypt tile4ms mapserv
+.if ${PORT_OPTIONS:MCLIENT_WMS}
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libgdal.so:${PORTSDIR}/graphics/gdal
+CMAKE_ARGS+= -DWITH_CURL=1 -DGDAL=1 -DCLIENT_WMS=1
+.endif
+
+.if ${PORT_OPTIONS:MCLIENT_WFS}
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libgdal.so:${PORTSDIR}/graphics/gdal
+CMAKE_ARGS+= -DWITH_CURL=1 -DGDAL=1 -DCLIENT_WFS=1
+.endif
+
do-install:
.for f in ${PROG_FILES}
${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin