aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-10-15 08:45:28 +0800
committerDoug Barton <dougb@FreeBSD.org>2011-10-15 08:45:28 +0800
commit5549be760e9d48d82312cab4d4dcb0a538591bd2 (patch)
tree5b5c0d7d39e25ff48ec80ee7e37c14c9a8b83a94 /graphics
parent7e4996eff458554ee62bdfdc7c053f99bef14dde (diff)
downloadfreebsd-ports-gnome-5549be760e9d48d82312cab4d4dcb0a538591bd2.tar.gz
freebsd-ports-gnome-5549be760e9d48d82312cab4d4dcb0a538591bd2.tar.zst
freebsd-ports-gnome-5549be760e9d48d82312cab4d4dcb0a538591bd2.zip
Grant graphics/linux-tiff a stay of execution
Due to the way that linux dependencies are recorded my greps for the portname, category/portname, etc. didn't discover that on RELENG_7 this version of the port is still heavily depended on. Neither did my building INDEX on more recent versions of FreeBSD. So bring it back for now, with the plan to mark those ports that depend on it BROKEN conditional on OSVERSION.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/linux-tiff/Makefile32
-rw-r--r--graphics/linux-tiff/distinfo.i3864
-rw-r--r--graphics/linux-tiff/pkg-descr7
-rw-r--r--graphics/linux-tiff/pkg-plist.i38655
5 files changed, 99 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b703b9232e05..5b67171337ab 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -522,6 +522,7 @@
SUBDIR += linux-png10
SUBDIR += linux-sdl_image
SUBDIR += linux-sdl_ttf
+ SUBDIR += linux-tiff
SUBDIR += linux-ungif
SUBDIR += linux_dri
SUBDIR += linux_glide
diff --git a/graphics/linux-tiff/Makefile b/graphics/linux-tiff/Makefile
new file mode 100644
index 000000000000..1971574d20ff
--- /dev/null
+++ b/graphics/linux-tiff/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: linux-tiff
+# Date created: 2001.02.08
+# Whom: taoka@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tiff
+PORTVERSION= 3.7.1
+PORTREVISION= 2
+CATEGORIES= graphics linux
+MASTER_SITES= CRITICAL/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
+DISTNAME= libtiff-${PORTVERSION}-6.fc4.2
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= TIFF library, Linux/i386 binary
+
+FORBIDDEN= Vulnerable since 2004-10-13, http://portaudit.freebsd.org/8816bf3a-7929-11df-bcce-0018f3e2eb82.html
+EXPIRATION_DATE= 2011-10-14
+
+CONFLICTS= linux-f8-tiff-[0-9]* linux-f10-tiff-[0-9]*
+
+ONLY_FOR_ARCHS= amd64 i386
+USE_LINUX_RPM= yes
+USE_LINUX_APPS= jpeg
+LINUX_DIST_VER= 4
+USE_LDCONFIG= yes
+BRANDELF_DIRS= usr/bin
+PLIST= pkg-plist.${LINUX_RPM_ARCH}
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-tiff/distinfo.i386 b/graphics/linux-tiff/distinfo.i386
new file mode 100644
index 000000000000..5d3de67e923a
--- /dev/null
+++ b/graphics/linux-tiff/distinfo.i386
@@ -0,0 +1,4 @@
+SHA256 (rpm/i386/fedora/4/libtiff-3.7.1-6.fc4.2.i386.rpm) = 9b6b41f210c38791bf388a81d5ed9f3d44591883313cc8c58797616d835b61ed
+SIZE (rpm/i386/fedora/4/libtiff-3.7.1-6.fc4.2.i386.rpm) = 306451
+SHA256 (rpm/i386/fedora/4/libtiff-3.7.1-6.fc4.2.src.rpm) = 93820f895507487e466fbee0d1696e2091178c7aa9d61bf4115bcc1cf08d57db
+SIZE (rpm/i386/fedora/4/libtiff-3.7.1-6.fc4.2.src.rpm) = 1269849
diff --git a/graphics/linux-tiff/pkg-descr b/graphics/linux-tiff/pkg-descr
new file mode 100644
index 000000000000..a0d231cc0527
--- /dev/null
+++ b/graphics/linux-tiff/pkg-descr
@@ -0,0 +1,7 @@
+This is a Linux/i386 binary of a library for reading and writing
+images in Tagged Image File Format.
+
+See http://www.awaresystems.be/imaging/tiff.html for information
+about the format.
+
+WWW: http://www.remotesensing.org/libtiff/
diff --git a/graphics/linux-tiff/pkg-plist.i386 b/graphics/linux-tiff/pkg-plist.i386
new file mode 100644
index 000000000000..302bf427b47b
--- /dev/null
+++ b/graphics/linux-tiff/pkg-plist.i386
@@ -0,0 +1,55 @@
+usr/bin/bmp2tiff
+usr/bin/fax2ps
+usr/bin/fax2tiff
+usr/bin/gif2tiff
+usr/bin/pal2rgb
+usr/bin/ppm2tiff
+usr/bin/ras2tiff
+usr/bin/raw2tiff
+usr/bin/rgb2ycbcr
+usr/bin/thumbnail
+usr/bin/tiff2bw
+usr/bin/tiff2pdf
+usr/bin/tiff2ps
+usr/bin/tiff2rgba
+usr/bin/tiffcmp
+usr/bin/tiffcp
+usr/bin/tiffdither
+usr/bin/tiffdump
+usr/bin/tiffinfo
+usr/bin/tiffgt
+usr/bin/tiffmedian
+usr/bin/tiffset
+usr/bin/tiffsplit
+usr/lib/libtiff.so.3
+usr/lib/libtiff.so.%%PORTVERSION%%
+usr/share/doc/libtiff-%%PORTVERSION%%/COPYRIGHT
+usr/share/doc/libtiff-%%PORTVERSION%%/README
+usr/share/doc/libtiff-%%PORTVERSION%%/RELEASE-DATE
+usr/share/doc/libtiff-%%PORTVERSION%%/VERSION
+usr/share/man/man1/bmp2tiff.1.gz
+usr/share/man/man1/fax2ps.1.gz
+usr/share/man/man1/fax2tiff.1.gz
+usr/share/man/man1/gif2tiff.1.gz
+usr/share/man/man1/pal2rgb.1.gz
+usr/share/man/man1/ppm2tiff.1.gz
+usr/share/man/man1/ras2tiff.1.gz
+usr/share/man/man1/raw2tiff.1.gz
+usr/share/man/man1/rgb2ycbcr.1.gz
+usr/share/man/man1/sgi2tiff.1.gz
+usr/share/man/man1/thumbnail.1.gz
+usr/share/man/man1/tiff2bw.1.gz
+usr/share/man/man1/tiff2pdf.1.gz
+usr/share/man/man1/tiff2ps.1.gz
+usr/share/man/man1/tiff2rgba.1.gz
+usr/share/man/man1/tiffcmp.1.gz
+usr/share/man/man1/tiffcp.1.gz
+usr/share/man/man1/tiffdither.1.gz
+usr/share/man/man1/tiffdump.1.gz
+usr/share/man/man1/tiffinfo.1.gz
+usr/share/man/man1/tiffgt.1.gz
+usr/share/man/man1/tiffmedian.1.gz
+usr/share/man/man1/tiffset.1.gz
+usr/share/man/man1/tiffsplit.1.gz
+usr/share/man/man1/tiffsv.1.gz
+@dirrm usr/share/doc/libtiff-%%PORTVERSION%%