aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2021-04-24 04:56:21 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2021-04-24 04:56:21 +0800
commit56d3caa4ad614ae876296a49bdc77f641da8ffe9 (patch)
tree588b8a39510dcad11a1659ddbcf83af85d29f6ad /graphics
parent30efb47f3c6d4a5a01143e36d0960048bbf010a9 (diff)
downloadfreebsd-ports-gnome-56d3caa4ad614ae876296a49bdc77f641da8ffe9.tar.gz
freebsd-ports-gnome-56d3caa4ad614ae876296a49bdc77f641da8ffe9.tar.zst
freebsd-ports-gnome-56d3caa4ad614ae876296a49bdc77f641da8ffe9.zip
Cleanup LIB_DEPENDS
Diffstat (limited to 'graphics')
-rw-r--r--graphics/art/Makefile2
-rw-r--r--graphics/jp2a/Makefile2
-rw-r--r--graphics/mscgen/Makefile2
-rw-r--r--graphics/mypaint/Makefile2
-rw-r--r--graphics/opencv/Makefile2
-rw-r--r--graphics/timg/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/graphics/art/Makefile b/graphics/art/Makefile
index 17cb8f6b467f..5760930862a2 100644
--- a/graphics/art/Makefile
+++ b/graphics/art/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libcanberra.so:audio/libcanberra \
libfftw3f.so:math/fftw3-float \
liblensfun.so:graphics/lensfun \
liblcms2.so:graphics/lcms2 \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtiff.so:graphics/tiff
USES= cmake compiler:c++11-lang desktop-file-utils gnome jpeg pkgconfig tar:xz xorg
diff --git a/graphics/jp2a/Makefile b/graphics/jp2a/Makefile
index e1055b217dca..0dce78ca3904 100644
--- a/graphics/jp2a/Makefile
+++ b/graphics/jp2a/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= jpeg localbase ncurses pkgconfig tar:bz2
USE_CSTD= c99
diff --git a/graphics/mscgen/Makefile b/graphics/mscgen/Makefile
index 7f6a9015be96..5f453b8c9e72 100644
--- a/graphics/mscgen/Makefile
+++ b/graphics/mscgen/Makefile
@@ -32,6 +32,6 @@ FREETYPE_LIB_DEPENDS= libfreetype.so:print/freetype2
PNG_CONFIGURE_WITH= png
PNG_LIB_DEPENDS= libgd.so:graphics/gd \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
.include <bsd.port.mk>
diff --git a/graphics/mypaint/Makefile b/graphics/mypaint/Makefile
index 0249934449b8..3b2ac05423e1 100644
--- a/graphics/mypaint/Makefile
+++ b/graphics/mypaint/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= swig:devel/swig \
${PYNUMPY}
LIB_DEPENDS= libjson-c.so:devel/json-c \
liblcms2.so:graphics/lcms2 \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libmypaint.so:graphics/libmypaint
RUN_DEPENDS= mypaint-brushes2>0:graphics/mypaint-brushes2 \
${PYNUMPY}
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index a2b19d061238..1e650a01f32b 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= \
libharfbuzz.so:print/harfbuzz \
libhdf5.so:science/hdf5 \
libopenblas.so:math/openblas \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libwebp.so:graphics/webp
# libtbb.so:devel/tbb
diff --git a/graphics/timg/Makefile b/graphics/timg/Makefile
index a65db2478ea7..bbfc335a3af7 100644
--- a/graphics/timg/Makefile
+++ b/graphics/timg/Makefile
@@ -13,7 +13,7 @@ BUILD_DEPENDS= pkgconf>0:devel/pkgconf \
LIB_DEPENDS= libavutil.so:multimedia/ffmpeg \
libexif.so:graphics/libexif \
libGraphicsMagick.so:graphics/GraphicsMagick \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libturbojpeg.so:graphics/libjpeg-turbo
USES= cmake compiler:c++11-lang