aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 17:23:54 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 17:23:54 +0800
commit598e3b95e377a3ff6d791057125fe27b1ffdb352 (patch)
treeae2da985769260bb23bc25c81c014e3f0f5add03 /graphics
parent336a28bb21cb0a1f37db2940b881f43d8f38ba36 (diff)
downloadfreebsd-ports-gnome-598e3b95e377a3ff6d791057125fe27b1ffdb352.tar.gz
freebsd-ports-gnome-598e3b95e377a3ff6d791057125fe27b1ffdb352.tar.zst
freebsd-ports-gnome-598e3b95e377a3ff6d791057125fe27b1ffdb352.zip
In preparation of the removal of USE_FREETYPE from bsd.port.mk: remove
USE_FREETYPE from all ports using it While here trim some headers, and do some conversion to new options framework.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gltt/Makefile9
-rw-r--r--graphics/ocaml-images/Makefile33
-rw-r--r--graphics/py-paint/Makefile15
-rw-r--r--graphics/py-paint/pkg-plist8
4 files changed, 27 insertions, 38 deletions
diff --git a/graphics/gltt/Makefile b/graphics/gltt/Makefile
index 689c1e1f2e79..963b8de72fa2 100644
--- a/graphics/gltt/Makefile
+++ b/graphics/gltt/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gltt
-# Date created: 12 Aug 2002
-# Whom: Igor Pokrovsky <tiamat@telegraph.spb.ru>
-#
+# Created by: Igor Pokrovsky <tiamat@telegraph.spb.ru>
# $FreeBSD$
-#
PORTNAME= gltt
PORTVERSION= 2.5.2
@@ -14,9 +10,10 @@ MASTER_SITES= http://gltt.sourceforge.net/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= TrueType fonts rendering using OpenGL
+LIB_DEPENDS= ttf:${PORTSDIR}/print/freetype
+
USE_AUTOTOOLS= libtool
USE_GL= gl glut
-USE_FREETYPE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index ded18cb5f2d0..e151447f718e 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -36,67 +36,62 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --without-lablgtk
MAKE_JOBS_UNSAFE= yes
-OPTIONS= PNG "Enable PNG support" on \
- JPEG "Enable JPEG support" on \
- TIFF "Enable TIFF support" on \
- XPM "Enable XPM support" on \
- GIF "Enable GIF support" on \
- FREETYPE "Enable text rendering via freetype" on \
- GS "Enable PostScript support via Ghostscript" on \
- GTK2 "Enable LablGTK2 support" off
+OPTIONS_DEFINE= PNG JPEG TIFF XPM GIF FREETYPE GS GTK2 DOCS
+OPTIONS_DEFAULT= PNG JPEG TIFF XPM GIT FREETYPE GS
+GS_DESC= PostScript support via Ghostscript
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_PNG)
+.if ${PORT_OPTIONS:MPNG}
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-png
.else
CONFIGURE_ARGS+= --without-png
.endif
-.if !defined(WITHOUT_JPEG)
+.if ${PORT_OPTIONS:MJPEG}
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
CONFIGURE_ARGS+= --with-jpeg
.else
CONFIGURE_ARGS+= --without-jpeg
.endif
-.if !defined(WITHOUT_TIFF)
+.if ${PORT_OPTIONS:MTIFF}
LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
CONFIGURE_ARGS+= --with-tiff
.else
CONFIGURE_ARGS+= --without-tiff
.endif
-.if !defined(WITHOUT_XPM)
+.if ${PORT_OPTIONS:MXPM}
USE_XORG= xpm
CONFIGURE_ARGS+= --with-xpm
.else
CONFIGURE_ARGS+= --without-xpm
.endif
-.if !defined(WITHOUT_GIF)
+.if ${PORT_OPTIONS:MGIF}
LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
CONFIGURE_ARGS+= --with-gif
.else
CONFIGURE_ARGS+= --without-gif
.endif
-.if !defined(WITHOUT_FREETYPE)
-USE_FREETYPE= yes
+.if ${PORT_OPTIONS:MFREETYPE}
+LIB_DEPENDS+= ttf:${PORTSDIR}/print/freetype
CONFIGURE_ARGS+= --with-freetype
.else
CONFIGURE_ARGS+= --without-freetype
.endif
-.if defined(WITH_GS)
+.if ${PORT_OPTIONS:MGS}
USE_GHOSTSCRIPT= yes
CONFIGURE_ARGS+= --with-gs
.else
CONFIGURE_ARGS+= --without-gs
.endif
-.if defined(WITH_GTK2)
+.if ${PORT_OPTIONS:MGTK2}
CONFIGURE_ARGS+= --with-lablgtk2
BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
@@ -112,12 +107,12 @@ GNU_CONFIGURE= yes
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
DOCSFILES= CHANGES README LICENSE
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= ${DOCSFILES} doc
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/doc
@(cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${DOCSDIR}/doc '-name "*.jpg" -o -name "*.html"')
@${INSTALL_DATA} ${DOCSFILES:S,^,${WRKSRC}/,g} ${DOCSDIR}/
diff --git a/graphics/py-paint/Makefile b/graphics/py-paint/Makefile
index 4d9110826828..d8e480e17aec 100644
--- a/graphics/py-paint/Makefile
+++ b/graphics/py-paint/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: py-paint
-# Date created: 8 July 2001
-# Whom: Hye-Shik Chang <perky@python.or.kr>
-#
+# Created by: Hye-Shik Chang <perky@python.or.kr>
# $FreeBSD$
-#
PORTNAME= paint
PORTVERSION= 0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics python
MASTER_SITES= SF/py${PORTNAME}/py${PORTNAME}/py${PORTNAME}%20${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,11 +12,11 @@ DISTNAME= pypaint-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple and flexible painting adaptor to libart for Python
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
+ ttf:${PORTSDIR}/print/freetype
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-USE_FREETYPE= yes
USE_GNOME= libartlgpl2
NO_WRKSUBDIR= yes
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libart-2.0 \
@@ -29,10 +25,11 @@ LDFLAGS+= -L${LOCALBASE}/lib
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e "s,art_lgpl,art_lgpl_2," ${WRKSRC}/setup.py
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MEXAMPLES}
post-install:
@${MKDIR} ${EXAMPLESDIR}
${CP} ${WRKSRC}/test* ${EXAMPLESDIR}
diff --git a/graphics/py-paint/pkg-plist b/graphics/py-paint/pkg-plist
index 7043947e266d..b5e9f0decbf2 100644
--- a/graphics/py-paint/pkg-plist
+++ b/graphics/py-paint/pkg-plist
@@ -1,5 +1,5 @@
%%PYTHON_SITELIBDIR%%/paint.so
-%%PORTDOCS%%%%EXAMPLESDIR%%/test_bar.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/test_paint.py
-%%PORTDOCS%%%%EXAMPLESDIR%%/testpie.py
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_bar.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_paint.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testpie.py
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%