aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2004-10-26 04:14:27 +0800
committermi <mi@FreeBSD.org>2004-10-26 04:14:27 +0800
commit5cba4bc4941bba837f00137880de462b380cc706 (patch)
tree36869004f3a792a97c6ce62dd8b43b7e3bc1ea39 /graphics
parent4317523a8c414dd2591bd4bd35773e465a8820ae (diff)
downloadfreebsd-ports-gnome-5cba4bc4941bba837f00137880de462b380cc706.tar.gz
freebsd-ports-gnome-5cba4bc4941bba837f00137880de462b380cc706.tar.zst
freebsd-ports-gnome-5cba4bc4941bba837f00137880de462b380cc706.zip
Remove the bogus dependency on -ltiff (--without-tiff was always in there).
Make the testcms link the new -lcms statically to avoid possible conflicts with the already installed library (probably of a different version). PR: ports/68610
Diffstat (limited to 'graphics')
-rw-r--r--graphics/lcms/Makefile4
-rw-r--r--graphics/lcms/files/patch-test-static9
2 files changed, 9 insertions, 4 deletions
diff --git a/graphics/lcms/Makefile b/graphics/lcms/Makefile
index 96dac7284794..bd52a0414f98 100644
--- a/graphics/lcms/Makefile
+++ b/graphics/lcms/Makefile
@@ -16,13 +16,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Light Color Management System -- a color management library
-LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
-
USE_GNOME= gnomehack gnometarget lthack
USE_REINPLACE= yes
USE_INC_LIBTOOL_VER= 13
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --without-jpeg --without-tiff
INSTALLS_SHLIB= yes
diff --git a/graphics/lcms/files/patch-test-static b/graphics/lcms/files/patch-test-static
new file mode 100644
index 000000000000..28e3f36fd690
--- /dev/null
+++ b/graphics/lcms/files/patch-test-static
@@ -0,0 +1,9 @@
+--- testbed/Makefile.in Mon Apr 19 12:02:23 2004
++++ testbed/Makefile.in Mon Oct 25 16:07:37 2004
+@@ -198,5 +198,5 @@
+
+ testcms_LDADD = $(top_builddir)/src/liblcms.la
+-testcms_LDFLAGS = @LDFLAGS@
++testcms_LDFLAGS = @LDFLAGS@ -static
+ testcms_SOURCES = testcms.c
+