aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-09-13 20:44:02 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2019-09-13 20:44:02 +0800
commit5fdbc9c99587bff23ff465922a138d8cf0d1f42d (patch)
treef0cfa97cc422e978d2b1ae458d49868be8daee6b /graphics
parent72e206b848ed89ea2e84b25a34668f4dcdfba060 (diff)
downloadfreebsd-ports-gnome-5fdbc9c99587bff23ff465922a138d8cf0d1f42d.tar.gz
freebsd-ports-gnome-5fdbc9c99587bff23ff465922a138d8cf0d1f42d.tar.zst
freebsd-ports-gnome-5fdbc9c99587bff23ff465922a138d8cf0d1f42d.zip
Canonicalize librsvg dependency
- Use USE_GNOME=librsvg2 where possible - Reduce scope of D18878
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick6/Makefile3
-rw-r--r--graphics/ImageMagick7/Makefile3
-rw-r--r--graphics/fpc-rsvg/Makefile3
-rw-r--r--graphics/gimageview/Makefile2
-rw-r--r--graphics/osg-devel/Makefile4
-rw-r--r--graphics/osg/Makefile4
6 files changed, 9 insertions, 10 deletions
diff --git a/graphics/ImageMagick6/Makefile b/graphics/ImageMagick6/Makefile
index 0c38c5998b12..0aeb5aa40c10 100644
--- a/graphics/ImageMagick6/Makefile
+++ b/graphics/ImageMagick6/Makefile
@@ -162,8 +162,7 @@ RAW_IMPLIES= LCMS2
SVG_DESC= SVG vector image format support (via librsvg, implies the x11 option)
SVG_CONFIGURE_WITH= rsvg
-SVG_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
-SVG_USE= gnome=cairo,gdkpixbuf2
+SVG_USE= gnome=cairo,gdkpixbuf2,librsvg2
SVG_IMPLIES= X11
TIFF_CONFIGURE_WITH= tiff
diff --git a/graphics/ImageMagick7/Makefile b/graphics/ImageMagick7/Makefile
index 5a401f3c5d1e..1afc8893e890 100644
--- a/graphics/ImageMagick7/Makefile
+++ b/graphics/ImageMagick7/Makefile
@@ -161,8 +161,7 @@ RAW_IMPLIES= LCMS2
SVG_DESC= SVG vector image format support (via librsvg, implies the x11 option)
SVG_CONFIGURE_WITH= rsvg
-SVG_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
-SVG_USE= gnome=cairo,gdkpixbuf2
+SVG_USE= gnome=cairo,gdkpixbuf2,librsvg2
SVG_IMPLIES= X11
TIFF_CONFIGURE_WITH= tiff
diff --git a/graphics/fpc-rsvg/Makefile b/graphics/fpc-rsvg/Makefile
index b8e18e41fb7b..806b38fa7e5e 100644
--- a/graphics/fpc-rsvg/Makefile
+++ b/graphics/fpc-rsvg/Makefile
@@ -17,6 +17,7 @@ OPTIONS_DEFINE= LIBRSVG2
LIBRSVG2_DESC= Install librsvg2 library
OPTIONS_DEFAULT= LIBRSVG2
-LIBRSVG2_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
+LIBRSVG2_USES= gnome
+LIBRSVG2_USE= GNOME=librsvg2
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gimageview/Makefile b/graphics/gimageview/Makefile
index 44898d3ab46f..2d58a2755166 100644
--- a/graphics/gimageview/Makefile
+++ b/graphics/gimageview/Makefile
@@ -40,7 +40,7 @@ LIBWMF_CONFIGURE_WITH= libwmf
LIBWMF_LIB_DEPENDS= libwmf.so:graphics/libwmf
LIBRSVG2_CONFIGURE_WITH=librsvg
-LIBRSVG2_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
+LIBRSVG2_USE= GNOME=librsvg2
LIBEXIF_CONFIGURE_ENABLE=exif # bundled exif is used
LIBEXIF_BROKEN_OFF= does not build without libexif support
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 1591a7defd3e..8d85af3b4204 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -103,8 +103,8 @@ QT5_VARS_OFF= FORCE_IGNORE+="Qt5Widgets Qt5WebKitWidgets"
SDL_USE= sdl=sdl
SDL_VARS= FORCE_REQUIRE+=SDL
SDL_VARS_OFF= FORCE_IGNORE+=SDL
-SVG_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
-SVG_USE= gnome=cairo
+SVG_USES= gnome
+SVG_USE= gnome=cairo,librsvg2
SVG_VARS= FORCE_REQUIRE+=RSVG
SVG_VARS_OFF= FORCE_IGNORE+=RSVG
VNC_LIB_DEPENDS= libvncserver.so:net/libvncserver
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index e20ac79deb8f..496098a0bc8c 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -106,8 +106,8 @@ QT5_VARS_OFF= FORCE_IGNORE+="Qt5Widgets Qt5WebKitWidgets"
SDL_USE= sdl=sdl
SDL_VARS= FORCE_REQUIRE+=SDL
SDL_VARS_OFF= FORCE_IGNORE+=SDL
-SVG_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
-SVG_USE= gnome=cairo
+SVG_USES= gnome
+SVG_USE= gnome=cairo,librsvg2
SVG_VARS= FORCE_REQUIRE+=RSVG
SVG_VARS_OFF= FORCE_IGNORE+=RSVG
VNC_LIB_DEPENDS= libvncserver.so:net/libvncserver