aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2013-08-30 22:00:24 +0800
committernivit <nivit@FreeBSD.org>2013-08-30 22:00:24 +0800
commit60d1327797cf1e6da62b3ec7eb01549283d5cb90 (patch)
tree835a8d60d31db9197b50028b5dbd9d3d5a00ab60 /graphics
parenta7125526684d025524fab92c9e98b625ebc45d48 (diff)
downloadfreebsd-ports-gnome-60d1327797cf1e6da62b3ec7eb01549283d5cb90.tar.gz
freebsd-ports-gnome-60d1327797cf1e6da62b3ec7eb01549283d5cb90.tar.zst
freebsd-ports-gnome-60d1327797cf1e6da62b3ec7eb01549283d5cb90.zip
- Trim Makefile header [1]
- Fix MASTER_SITES [1] - Convert to new options framework [1] - Use the new Uses/(perl5|shebang).mk facilities - Fix WWW entry in pkg-descr [1] PR: ports/177286 [1] Submitted by: nemysis
Diffstat (limited to 'graphics')
-rw-r--r--graphics/l2p/Makefile32
-rw-r--r--graphics/l2p/pkg-descr3
2 files changed, 17 insertions, 18 deletions
diff --git a/graphics/l2p/Makefile b/graphics/l2p/Makefile
index b46d029fa730..fedc2b07f6d0 100644
--- a/graphics/l2p/Makefile
+++ b/graphics/l2p/Makefile
@@ -1,40 +1,40 @@
-# New ports collection makefile for: l2p
-# Date created: 2006-03-22
-# Whom: Nicola Vitale <nivit@email.it>
-#
# $FreeBSD$
-#
PORTNAME= l2p
PORTVERSION= 1.1.1
PORTREVISION= 3
CATEGORIES= graphics print perl5
-MASTER_SITES= http://www.redsymbol.net/software/l2p/dist/ \
- http://nivi.interfree.it/distfiles/${PORTNAME}/
+MASTER_SITES= http://static.redsymbol.net/software/l2p/dist/ \
+ http://nivit.altervista.org/FreeBSD/ports/distfiles/
MAINTAINER= nivit@FreeBSD.org
COMMENT= Create PNG images from LaTeX math expressions
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
-USE_PERL5_RUN= yes
-USE_ZIP= yes
-USE_TEX= latex dvipsk
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+OPTIONS_DEFINE= DOCS
PLIST_FILES= bin/l2p
PORTDOCS= l2p.txt l2p.html
-post-patch:
- @${REINPLACE_CMD} -e '1s|.*|#!${PERL} -w|' ${WRKSRC}/${PORTNAME}
+SHEBANG_FILES= ${WRKSRC}/${PORTNAME}
+
+USE_PERL5= run
+USE_TEX= latex dvipsk
+USE_ZIP= yes
+USES= perl5 shebangfix
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.options.mk>
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/l2p/pkg-descr b/graphics/l2p/pkg-descr
index c27d395b72e6..fc5cc8e0ebe7 100644
--- a/graphics/l2p/pkg-descr
+++ b/graphics/l2p/pkg-descr
@@ -1,4 +1,3 @@
A command-line program to create PNG images from LaTeX math expressions.
-Author: Aaron Maxwell <amax@redsymbol.net>
-WWW: http://www.redsymbol.net/software/l2p/
+WWW: http://www.redsymbol.net/software/l2p/