aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2014-05-20 14:06:35 +0800
committerak <ak@FreeBSD.org>2014-05-20 14:06:35 +0800
commit6161bf6a5273690fdda58c0296d59bde10ee8583 (patch)
treea3f77a0d965b1e0633bce4bd914a678be49a43c0 /graphics
parentf19e9f65f3029b1743d93e7d5971571234845104 (diff)
downloadfreebsd-ports-gnome-6161bf6a5273690fdda58c0296d59bde10ee8583.tar.gz
freebsd-ports-gnome-6161bf6a5273690fdda58c0296d59bde10ee8583.tar.zst
freebsd-ports-gnome-6161bf6a5273690fdda58c0296d59bde10ee8583.zip
- Add/update license when possible
- Modernize ports Makefiles - Update MASTER_SITES/distfile for converters/chmview
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fli2gif/Makefile6
-rw-r--r--graphics/pngquant/Makefile5
-rw-r--r--graphics/xmountains/Makefile2
3 files changed, 6 insertions, 7 deletions
diff --git a/graphics/fli2gif/Makefile b/graphics/fli2gif/Makefile
index 4ac0ab1d0613..03034d3621ed 100644
--- a/graphics/fli2gif/Makefile
+++ b/graphics/fli2gif/Makefile
@@ -20,12 +20,12 @@ PLIST_FILES= bin/${PORTNAME}
PORTDOCS= fli2gif.txt
post-extract:
- @cd ${WRKSRC} && ${UNZIP_CMD} -q source.zip \
+ @(cd ${WRKSRC} && ${UNZIP_CMD} -q source.zip \
&& ${LN} -sf GIF.CPP gif.cpp \
- && ${LN} -sf FLIPLAY.CPP fliplay.cpp
+ && ${LN} -sf FLIPLAY.CPP fliplay.cpp)
do-build:
- @cd ${WRKSRC} && ${CXX} ${CXXFLAGS} -o ${PORTNAME} *.cpp
+ (cd ${WRKSRC} && ${CXX} ${CXXFLAGS} -o ${PORTNAME} *.cpp)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fli2gif ${STAGEDIR}${PREFIX}/bin
diff --git a/graphics/pngquant/Makefile b/graphics/pngquant/Makefile
index b3557c520acf..e5cef4977181 100644
--- a/graphics/pngquant/Makefile
+++ b/graphics/pngquant/Makefile
@@ -10,15 +10,14 @@ MASTER_SITES= http://pngquant.org/
MAINTAINER= ak@FreeBSD.org
COMMENT= Converts 32-bit RGBA PNGs into 8-bit RGBA-palette PNGs
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
MAKE_ARGS+= CC="${CC}"
CPPFLAGS+= $$(libpng-config --I_opts)
diff --git a/graphics/xmountains/Makefile b/graphics/xmountains/Makefile
index 423efa81d8d5..97c59515f99f 100644
--- a/graphics/xmountains/Makefile
+++ b/graphics/xmountains/Makefile
@@ -27,7 +27,7 @@ post-extract:
@${LN} -sf ${PORTNAME}.man ${WRKSRC}/${PORTNAME}.6
do-build:
- cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} *.c -lX11 -lm -o ${PORTNAME}
+ (cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} *.c -lX11 -lm -o ${PORTNAME})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin