aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-05-01 15:27:27 +0800
committerdanfe <danfe@FreeBSD.org>2013-05-01 15:27:27 +0800
commit66943667698196b03ea350313348c3e74f099fcd (patch)
tree5e301bf775eda874794348c5366051c6a2bf502c /graphics
parent79d92b73c38f65321ce886bca18ca9c72ac57cc3 (diff)
downloadfreebsd-ports-gnome-66943667698196b03ea350313348c3e74f099fcd.tar.gz
freebsd-ports-gnome-66943667698196b03ea350313348c3e74f099fcd.tar.zst
freebsd-ports-gnome-66943667698196b03ea350313348c3e74f099fcd.zip
Update to version 1.2, which brings some nice and useful features (profiled
denoise, usability enhancements, JPEG2000 support). PR: ports/178232 Submitted by: Matthieu Volat
Diffstat (limited to 'graphics')
-rw-r--r--graphics/darktable/Makefile16
-rw-r--r--graphics/darktable/distinfo4
-rw-r--r--graphics/darktable/pkg-plist9
3 files changed, 21 insertions, 8 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index c6fd1cc96c3c..98c6d09d347e 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= darktable
-PORTVERSION= 1.1.3
+PORTVERSION= 1.2
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Virtual lighttable and darkroom for photographers
@@ -24,6 +24,7 @@ ONLY_FOR_ARCHS_REASON= uses SSE extensions
MAKE_JOBS_SAFE= yes
USES= cmake:outsource
+USE_XZ= yes
USE_GNOME= librsvg2
USE_SQLITE= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
@@ -32,7 +33,7 @@ MAN1= ${PORTNAME}.1
LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= GPHOTO GEO FLICKR FACEBOOK KWALLET GNOMEKEYRING RAWSPEED \
- SLIDESHOW NLS GCC46
+ OPENJPEG SLIDESHOW NLS GCC46
GEO_DESC= Build geotagging parts
FACEBOOK_DESC= Support images export to Facebook
@@ -93,6 +94,13 @@ CMAKE_ARGS+= -DUSE_GNOME_KEYRING:BOOL=OFF
CMAKE_ARGS+= -DDONT_USE_RAWSPEED:BOOL=ON
.endif
+.if ${PORT_OPTIONS:MOPENJPEG}
+LIB_DEPENDS+= openjpeg:${PORTSDIR}/graphics/openjpeg
+PLIST_FILES+= lib/darktable/plugins/imageio/format/libj2k.so
+.else
+CMAKE_ARGS+= -DUSE_OPENJPEG:BOOL=OFF
+.endif
+
.if ${PORT_OPTIONS:MSLIDESHOW}
USE_GL= gl
USE_SDL= sdl
@@ -102,7 +110,7 @@ CMAKE_ARGS+= -DBUILD_SLIDESHOW:BOOL=OFF
.endif
.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
+USES+= gettext
.else
CMAKE_ARGS+= -DUSE_NLS:BOOL=OFF
.endif
diff --git a/graphics/darktable/distinfo b/graphics/darktable/distinfo
index 4e4865170aa0..c0481c4b9eec 100644
--- a/graphics/darktable/distinfo
+++ b/graphics/darktable/distinfo
@@ -1,2 +1,2 @@
-SHA256 (darktable-1.1.3.tar.gz) = 7607b4a891babe0d4d4e24288c6c463d67eb6c82ca8912f209104fbb2f924a3d
-SIZE (darktable-1.1.3.tar.gz) = 3432839
+SHA256 (darktable-1.2.tar.xz) = dc52582b5c5dfbd22e936f1d441e192a4aa53ac6533fe2c53aaa59433ccd5450
+SIZE (darktable-1.2.tar.xz) = 2399856
diff --git a/graphics/darktable/pkg-plist b/graphics/darktable/pkg-plist
index ce4758c41a73..9fe4936a20d2 100644
--- a/graphics/darktable/pkg-plist
+++ b/graphics/darktable/pkg-plist
@@ -14,7 +14,10 @@ bin/darktable-cltest
%%DATADIR%%/kernels/basic.cl
%%DATADIR%%/kernels/bilateral.cl
%%DATADIR%%/kernels/blendop.cl
+%%DATADIR%%/kernels/colorspace.cl
+%%DATADIR%%/kernels/common.h
%%DATADIR%%/kernels/demosaic_ppg.cl
+%%DATADIR%%/kernels/denoiseprofile.cl
%%DATADIR%%/kernels/extended.cl
%%DATADIR%%/kernels/gaussian.cl
%%DATADIR%%/kernels/highpass.cl
@@ -42,6 +45,7 @@ bin/darktable-cltest
%%DATADIR%%/pixmaps/plugins/darkroom/colortransfer.png
%%DATADIR%%/pixmaps/plugins/darkroom/colorzones.png
%%DATADIR%%/pixmaps/plugins/darkroom/demosaic.png
+%%DATADIR%%/pixmaps/plugins/darkroom/dither.png
%%DATADIR%%/pixmaps/plugins/darkroom/exposure.png
%%DATADIR%%/pixmaps/plugins/darkroom/flip.png
%%DATADIR%%/pixmaps/plugins/darkroom/graduatednd.png
@@ -104,7 +108,6 @@ lib/darktable/plugins/imageio/storage/libdisk.so
lib/darktable/plugins/imageio/storage/libemail.so
lib/darktable/plugins/imageio/storage/libgallery.so
lib/darktable/plugins/imageio/storage/liblatex.so
-lib/darktable/plugins/imageio/storage/libpicasa.so
lib/darktable/plugins/libatrous.so
lib/darktable/plugins/libbasecurve.so
lib/darktable/plugins/libbilat.so
@@ -123,6 +126,8 @@ lib/darktable/plugins/libcolorout.so
lib/darktable/plugins/libcolortransfer.so
lib/darktable/plugins/libcolorzones.so
lib/darktable/plugins/libdemosaic.so
+lib/darktable/plugins/libdenoiseprofile.so
+lib/darktable/plugins/libdither.so
lib/darktable/plugins/libequalizer.so
lib/darktable/plugins/libexposure.so
lib/darktable/plugins/libflip.so
@@ -184,7 +189,6 @@ lib/darktable/plugins/lighttable/libnavigation.so
lib/darktable/plugins/lighttable/libratings.so
lib/darktable/plugins/lighttable/librecentcollect.so
lib/darktable/plugins/lighttable/libselect.so
-lib/darktable/plugins/lighttable/libsimilarity.so
lib/darktable/plugins/lighttable/libsnapshots.so
lib/darktable/plugins/lighttable/libstyles.so
lib/darktable/plugins/lighttable/libtagging.so
@@ -219,6 +223,7 @@ share/locale/ru/LC_MESSAGES/darktable.mo
share/locale/sq/LC_MESSAGES/darktable.mo
share/locale/sv/LC_MESSAGES/darktable.mo
share/locale/th/LC_MESSAGES/darktable.mo
+share/locale/uk/LC_MESSAGES/darktable.mo
share/locale/zh_CN/LC_MESSAGES/darktable.mo
@dirrmtry share/applications
@dirrm lib/darktable/views