aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-05-02 22:16:49 +0800
committertijl <tijl@FreeBSD.org>2014-05-02 22:16:49 +0800
commit673c455dee3c36c9efed21d9de5688f2620710e7 (patch)
tree78e72938e9ae1fafd84cf8b4b69b5d7c261245bd /graphics
parent124cec08155b67060bd1b615d90c7d3e7a1c20dd (diff)
downloadfreebsd-ports-gnome-673c455dee3c36c9efed21d9de5688f2620710e7.tar.gz
freebsd-ports-gnome-673c455dee3c36c9efed21d9de5688f2620710e7.tar.zst
freebsd-ports-gnome-673c455dee3c36c9efed21d9de5688f2620710e7.zip
Convert graphics/sdl_gfx to USES=libtool. Also set USE_AUTOTOOLS because
upstream forgot to regenerate the build scripts. This makes the build use the correct version information and causes a library version bump. Use this opportunity to use USES=libtool instead of USES=libtool:oldver. Bump PORTREVISION on all dependent ports and convert them to USES=libtool where needed. Also use USES=(gmake, pathfix, tar) and new LIB_DEPENDS syntax here and there. games/freedink-engine: - Option helpers. - Staging. - Use dirrmtry for locale directories. games/oolite: - Staging. - Replace ECHO with ECHO_CMD. - Don't use GNUSTEP_PREFIX to install files because it expands to LOCALBASE rather than PREFIX. games/openssn: - Remove USES=desktop-file-utils. No MimeType field in desktop file. - Staging. - Install files in standard DATADIR. games/xblast: - Use proper options. - Staging. - Patch configure so normal make install can be used instead of do-install. - Replace TAR | TAR with COPYTREE_SHARE.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fpc-graph/Makefile2
-rw-r--r--graphics/sdl_gfx/Makefile10
-rw-r--r--graphics/sdl_gfx/pkg-plist4
3 files changed, 9 insertions, 7 deletions
diff --git a/graphics/fpc-graph/Makefile b/graphics/fpc-graph/Makefile
index 39ee681fc34d..73de0690cde8 100644
--- a/graphics/fpc-graph/Makefile
+++ b/graphics/fpc-graph/Makefile
@@ -1,7 +1,7 @@
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics lang
PKGNAMESUFFIX= -graph
diff --git a/graphics/sdl_gfx/Makefile b/graphics/sdl_gfx/Makefile
index 745480b9eac3..0962ee571f51 100644
--- a/graphics/sdl_gfx/Makefile
+++ b/graphics/sdl_gfx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sdl_gfx
PORTVERSION= 2.0.24
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.ferzkopp.net/Software/%SUBDIR%/
MASTER_SITE_SUBDIR= SDL_gfx-${PORTVERSION:R}
@@ -13,13 +14,14 @@ COMMENT= SDL graphics drawing primitives and other support functions
LICENSE= ZLIB
-USES= gmake pathfix
-USE_AUTOTOOLS= libtool
+USES= gmake libtool pathfix
+PATHFIX_MAKEFILEIN= Makefile.am
+USE_AUTOTOOLS= libtoolize aclocal autoconf automake
+AUTOMAKE_ARGS= -a -c -f
+LIBTOOLIZE_ARGS=-i -c -f
USE_SDL= sdl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir=${PREFIX}/include
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
- AUTOHEADER="${TRUE}"
USE_LDCONFIG= yes
OPTIONS_DEFINE_i386= MMX
diff --git a/graphics/sdl_gfx/pkg-plist b/graphics/sdl_gfx/pkg-plist
index 09d95d3c3d2f..b57b0dc78153 100644
--- a/graphics/sdl_gfx/pkg-plist
+++ b/graphics/sdl_gfx/pkg-plist
@@ -5,8 +5,8 @@ include/SDL/SDL_gfxPrimitives_font.h
include/SDL/SDL_imageFilter.h
include/SDL/SDL_rotozoom.h
lib/libSDL_gfx.a
-lib/libSDL_gfx.la
lib/libSDL_gfx.so
-lib/libSDL_gfx.so.22
+lib/libSDL_gfx.so.14
+lib/libSDL_gfx.so.14.9.1
libdata/pkgconfig/SDL_gfx.pc
@dirrmtry include/SDL