aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-30 22:34:03 +0800
committeradamw <adamw@FreeBSD.org>2014-08-30 22:34:03 +0800
commit6893b1df5bd613fe4551ea8b3b46f7b1f5a6b80b (patch)
treec19f91339735170ca02df78b0922fac19b39d3f5 /graphics
parent4ca519d9da3086cedabc95ae805d321adafc50d9 (diff)
downloadfreebsd-ports-gnome-6893b1df5bd613fe4551ea8b3b46f7b1f5a6b80b.tar.gz
freebsd-ports-gnome-6893b1df5bd613fe4551ea8b3b46f7b1f5a6b80b.tar.zst
freebsd-ports-gnome-6893b1df5bd613fe4551ea8b3b46f7b1f5a6b80b.zip
Fix a docs conflict from libjpeg-turbo not excluding the DOCS option.
PR: 193145 Submitted by: Jan Beich
Diffstat (limited to 'graphics')
-rw-r--r--graphics/jpeg-turbo/Makefile14
-rw-r--r--graphics/libjpeg-turbo/Makefile3
2 files changed, 10 insertions, 7 deletions
diff --git a/graphics/jpeg-turbo/Makefile b/graphics/jpeg-turbo/Makefile
index 6ee91b6122e0..10c8e6530b41 100644
--- a/graphics/jpeg-turbo/Makefile
+++ b/graphics/jpeg-turbo/Makefile
@@ -29,9 +29,15 @@ PORTEXAMPLES= *
# chase graphics/jpeg
SOVERSION= 11
-OPTIONS_DEFINE= PIC
+OPTIONS_DEFINE= DOCS EXAMPLES PIC
PIC_DESC= Static library with PIC (required for VirtualGL)
+DOCS_MAKE_ARGS= docdir="${DOCSDIR}"
+DOCS_MAKE_ARGS_OFF= dist_doc_DATA=""
+
+EXAMPLES_MAKE_ARGS= exampledir="${EXAMPLESDIR}"
+EXAMPLES_MAKE_ARGS_OFF= dist_example_DATA=""
+
PIC_CONFIGURE_ON= --with-pic
.if defined(SLAVE_PORT)
@@ -39,13 +45,7 @@ PLIST_SUB+= JPEG="@comment " LIBTURBOJPEG=""
.else
PLIST_SUB+= JPEG="" LIBTURBOJPEG="@comment "
CONFLICTS_INSTALL= jpeg-[0-9]*
-OPTIONS_DEFINE+=DOCS EXAMPLES
CONFIGURE_ARGS+=--without-libturbojpeg
.endif
-post-patch:
- ${REINPLACE_CMD} -e '/^docdir/s,=.*,= ${DOCSDIR},' \
- -e '/^exampledir/s,=.*,= ${EXAMPLESDIR},' \
- ${WRKSRC}/Makefile.in
-
.include <bsd.port.mk>
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
index 52bcaef07760..4e1c79b5434f 100644
--- a/graphics/libjpeg-turbo/Makefile
+++ b/graphics/libjpeg-turbo/Makefile
@@ -1,12 +1,15 @@
# Created by: Denis Podolskiy <bytestore@yandex.ru>
# $FreeBSD$
+PORTREVISION?= 3
+
PKGNAMEPREFIX= lib
COMMENT= SIMD-accelerated JPEG codec library, provides libTurboJPEG
MASTERDIR= ${.CURDIR:H}/jpeg-turbo
SLAVE_PORT= yes
+OPTIONS_EXCLUDE=DOCS EXAMPLES
OPTIONS_SLAVE= PIC
.include "${MASTERDIR}/Makefile"