aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-03-14 13:30:38 +0800
committermezz <mezz@FreeBSD.org>2012-03-14 13:30:38 +0800
commit69e93079dbc8e72c42c01e7e5a7434f5af0132de (patch)
treea0e287c4a6e877438c74cebd6b74f2599011b006 /graphics
parente239e9c59909bde802e6d78def29e093145aa10a (diff)
downloadfreebsd-ports-gnome-69e93079dbc8e72c42c01e7e5a7434f5af0132de.tar.gz
freebsd-ports-gnome-69e93079dbc8e72c42c01e7e5a7434f5af0132de.tar.zst
freebsd-ports-gnome-69e93079dbc8e72c42c01e7e5a7434f5af0132de.zip
Fix the crash on some PDF files. Bump the PORTREVISION.
PR: ports/162755 Obtained from: http://osdir.com/ml/general/2010-09/msg30460.html Submitted by: Hiroto Kagotani <hiroto.kagotani@gmail.com> Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/evince/Makefile2
-rw-r--r--graphics/evince/files/patch-backend_pdf_ev-poppler.cc28
2 files changed, 29 insertions, 1 deletions
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index 502fc7dadf17..f2478928789b 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -8,7 +8,7 @@
PORTNAME= evince
PORTVERSION= 2.32.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics print gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/graphics/evince/files/patch-backend_pdf_ev-poppler.cc b/graphics/evince/files/patch-backend_pdf_ev-poppler.cc
new file mode 100644
index 000000000000..14495098696e
--- /dev/null
+++ b/graphics/evince/files/patch-backend_pdf_ev-poppler.cc
@@ -0,0 +1,28 @@
+--- ./backend/pdf/ev-poppler.cc.orig 2010-09-28 01:54:34.000000000 +0900
++++ ./backend/pdf/ev-poppler.cc 2011-11-22 20:11:28.000000000 +0900
+@@ -640,6 +640,7 @@
+ PopplerPermissions permissions;
+ EvPage *page;
+ char *metadata;
++ gboolean linearized;
+
+ info = g_new0 (EvDocumentInfo, 1);
+
+@@ -676,7 +677,7 @@
+ "producer", &(info->producer),
+ "creation-date", &(info->creation_date),
+ "mod-date", &(info->modified_date),
+- "linearized", &(info->linearized),
++ "linearized", &linearized,
+ "metadata", &metadata,
+ NULL);
+
+@@ -782,6 +783,8 @@
+ info->security = g_strdup (_("No"));
+ }
+
++ info->linearized = linearized ? g_strdup (_("Yes")) : g_strdup (_("No"));
++
+ return info;
+ }
+