aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2015-11-18 17:09:15 +0800
committerdumbbell <dumbbell@FreeBSD.org>2015-11-18 17:09:15 +0800
commit70b7e58717578463c34aebded7aa762be15766b5 (patch)
tree7b9809346e82c4b5631a85c110659ae12cd665c3 /graphics
parent86d6eb04fd4bdd95317c8821b4eeecc97317c974 (diff)
downloadfreebsd-ports-gnome-70b7e58717578463c34aebded7aa762be15766b5.tar.gz
freebsd-ports-gnome-70b7e58717578463c34aebded7aa762be15766b5.tar.zst
freebsd-ports-gnome-70b7e58717578463c34aebded7aa762be15766b5.zip
graphics/darktable: LLVM 3.7 does not provide OpenMP on i386
This fixes the build on FreeBSD 10.x and 11-CURRENT on i386. While here, completely remove the OPENMP option. The implementation was incomplete anyway because disabling it would not turn off OpenMP in darktable if it was built with GCC. Reviewed by: kwm Approved by: kwm Differential Revision: https://reviews.freebsd.org/D4130
Diffstat (limited to 'graphics')
-rw-r--r--graphics/darktable/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index d4da638f66ec..dfb38333b86a 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -29,8 +29,8 @@ INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib -lintl
OPTIONS_DEFINE= COLORD DOCS FB_PICASA FLICKR GEO GNOMEKEYRING GPHOTO \
- GRAPHMAGICK LIBSECRET LUA NLS OPENEXR OPENJPEG OPENMP \
- RAWSPEED SLIDESHOW SQUISH WEBP
+ GRAPHMAGICK LIBSECRET LUA NLS OPENEXR OPENJPEG RAWSPEED \
+ SLIDESHOW SQUISH WEBP
GEO_DESC= Support geotagging
FB_PICASA_DESC= Support export to Facebook and Picasa
@@ -40,7 +40,7 @@ RAWSPEED_DESC= Compile with rawspeed backend
SLIDESHOW_DESC= Build OpenGL/SDL slideshow viewer
OPTIONS_DEFAULT=COLORD FB_PICASA FLICKR GEO GPHOTO LUA NLS OPENEXR \
- OPENJPEG OPENMP RAWSPEED SLIDESHOW SQUISH WEBP
+ OPENJPEG RAWSPEED SLIDESHOW SQUISH WEBP
OPTIONS_SUB= yes
CMAKE_ARGS+= -DBINARY_PACKAGE_BUILD=1
@@ -98,7 +98,7 @@ WEBP_CMAKE_OFF= -DUSE_WEBP:BOOL=OFF
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MOPENMP} && ${COMPILER_TYPE} == clang
+.if ${ARCH} == amd64 && ${COMPILER_TYPE} == clang
# Enable OpenMP support with Clang 3.7.
BUILD_DEPENDS+= clang37:${PORTSDIR}/devel/llvm37
RUN_DEPENDS+= clang37:${PORTSDIR}/devel/llvm37