aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-11-28 04:53:21 +0800
committerdinoex <dinoex@FreeBSD.org>2013-11-28 04:53:21 +0800
commit72016ca920017ef27cb1ed720c6d44bbb7972a22 (patch)
tree09e13df651ec8750dcfdc6a40d3d3b0ca9267b71 /graphics
parent6ae1069a9c81408c7f033fe69369dd7a93aa3572 (diff)
downloadfreebsd-ports-gnome-72016ca920017ef27cb1ed720c6d44bbb7972a22.tar.gz
freebsd-ports-gnome-72016ca920017ef27cb1ed720c6d44bbb7972a22.tar.zst
freebsd-ports-gnome-72016ca920017ef27cb1ed720c6d44bbb7972a22.zip
- use new LIB_DEPENDS style
Diffstat (limited to 'graphics')
-rw-r--r--graphics/swftools/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index 5b449849b7a2..e592f8e72b14 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -13,12 +13,12 @@ COMMENT= SWF manipulation and generation utilities
LICENSE= GPLv2
-LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- gif.5:${PORTSDIR}/graphics/giflib \
- fftw3:${PORTSDIR}/math/fftw3 \
- freetype.9:${PORTSDIR}/print/freetype2 \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libt1.so:${PORTSDIR}/devel/t1lib \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libgif.so:${PORTSDIR}/graphics/giflib \
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
NO_STAGE= yes
@@ -56,11 +56,11 @@ PLIST_SUB+= PDF="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's| -O | |g ; \
+ ${REINPLACE_CMD} -e 's| -O | |g ; \
s|/usr/include/fontconfig|${LOCALBASE}/include/fontconfig|g ; \
s|/usr/local/include|${LOCALBASE}/include|g ; \
s|/usr/local/lib|${LOCALBASE}/lib|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/python/d ; \
+ ${REINPLACE_CMD} -e '/python/d ; \
/avi2swf/d' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>