aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-02-05 20:57:58 +0800
committertobik <tobik@FreeBSD.org>2019-02-05 20:57:58 +0800
commit72bb6c20a5df0d98b02f7a454374b16c35c7ec39 (patch)
treed393ae7d0bb9f79675667dfe0e08ac107304fd69 /graphics
parent4a27e05075c2d65c456a50a4dd8c5e810bb0c5e2 (diff)
downloadfreebsd-ports-gnome-72bb6c20a5df0d98b02f7a454374b16c35c7ec39.tar.gz
freebsd-ports-gnome-72bb6c20a5df0d98b02f7a454374b16c35c7ec39.tar.zst
freebsd-ports-gnome-72bb6c20a5df0d98b02f7a454374b16c35c7ec39.zip
New port: graphics/py-glfw
pyGLFW provides Python bindings for GLFW. It is a ctypes wrapper which aims to be very close to the original GLFW API. WWW: https://github.com/FlorianRhiem/pyGLFW PR: 230424 Submitted by: neel@neelc.org Reviewed by: koobs
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-glfw/Makefile22
-rw-r--r--graphics/py-glfw/distinfo3
-rw-r--r--graphics/py-glfw/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 65543fed1006..df0e0fde36a5 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -836,6 +836,7 @@
SUBDIR += py-gimp
SUBDIR += py-gizeh
SUBDIR += py-glewpy
+ SUBDIR += py-glfw
SUBDIR += py-goocanvas
SUBDIR += py-gphoto2
SUBDIR += py-graph-core
diff --git a/graphics/py-glfw/Makefile b/graphics/py-glfw/Makefile
new file mode 100644
index 000000000000..dff376f01323
--- /dev/null
+++ b/graphics/py-glfw/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= glfw
+PORTVERSION= 1.7.1
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= neel@neelc.org
+COMMENT= Ctypes-based wrapper for GLFW3
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libglfw.so:graphics/glfw
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-glfw/distinfo b/graphics/py-glfw/distinfo
new file mode 100644
index 000000000000..b30be0e0d415
--- /dev/null
+++ b/graphics/py-glfw/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1549307581
+SHA256 (glfw-1.7.1.tar.gz) = 51e2539e0e39eac124f47e4e032f817cd87b0d4f4836b65b90925e66adeb514d
+SIZE (glfw-1.7.1.tar.gz) = 19502
diff --git a/graphics/py-glfw/pkg-descr b/graphics/py-glfw/pkg-descr
new file mode 100644
index 000000000000..37e0d3f92290
--- /dev/null
+++ b/graphics/py-glfw/pkg-descr
@@ -0,0 +1,4 @@
+pyGLFW provides Python bindings for GLFW. It is a ctypes wrapper
+which aims to be very close to the original GLFW API.
+
+WWW: https://github.com/FlorianRhiem/pyGLFW