aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-01-04 20:57:36 +0800
committerPietro Cerutti <gahr@FreeBSD.org>2012-01-04 20:57:36 +0800
commit7ab69fcc67f8067fee04530228312c7bb186734c (patch)
treec86e3a60d4e2c9d60ed13fbce5a51fc93b352b07 /graphics
parent2bcc25f9371cbc6d0a26e3941ae6d3a29b81823f (diff)
downloadfreebsd-ports-gnome-7ab69fcc67f8067fee04530228312c7bb186734c.tar.gz
freebsd-ports-gnome-7ab69fcc67f8067fee04530228312c7bb186734c.tar.zst
freebsd-ports-gnome-7ab69fcc67f8067fee04530228312c7bb186734c.zip
- Correctly link against pthread to avoid segfaulting at shlib load time
- Bump PORTREVISION
Diffstat (limited to 'graphics')
-rw-r--r--graphics/meshviewer/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/graphics/meshviewer/Makefile b/graphics/meshviewer/Makefile
index 6053459d5683..45e53ecad93b 100644
--- a/graphics/meshviewer/Makefile
+++ b/graphics/meshviewer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= meshviewer
PORTVERSION= 0.3.3
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/mview/mview/${PORTVERSION}
DISTNAME= mview-src-${PORTVERSION}
@@ -19,6 +20,7 @@ WRKSRC= ${WRKDIR}/mview-${PORTVERSION}
USE_QT_VER= 4
QT_COMPONENTS= corelib gui opengl moc_build
USE_GMAKE= yes
+LDFLAGS+= ${PTHREAD_LIBS}
MAKE_ARGS= QTDIR="${QT_PREFIX}" CC="${CXX}" MOC="${MOC}" \
CPPFLAGS="${CPPFLAGS}" FLAGS="${CXXFLAGS}" \
LIBPATH="" LIBS_QT4="${LDFLAGS}"