aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2015-02-02 05:40:57 +0800
committermadpilot <madpilot@FreeBSD.org>2015-02-02 05:40:57 +0800
commit7e5c894594e9493959771a177f6c70d7b5793f7b (patch)
tree1242418326113dc2271d900440efb5361f370a6a /graphics
parentea4556214c4c27d9583fe6c5472899fef9c96fda (diff)
downloadfreebsd-ports-gnome-7e5c894594e9493959771a177f6c70d7b5793f7b.tar.gz
freebsd-ports-gnome-7e5c894594e9493959771a177f6c70d7b5793f7b.tar.zst
freebsd-ports-gnome-7e5c894594e9493959771a177f6c70d7b5793f7b.zip
- Update graphics/zathura to 0.3.2 [1]
- Update graphics/zathura-djvu to 0.2.4 [2] - Fix OpenSSL library path in graphics/zathura-pdf-mupdf [3] - Use OPTION Helpers [1] - Add LICENSE [1] [2] [3] PR: 196438 Submitted by: mike.d.ft402@gmail.com Approved by: quentin.stievenart@gmail.com (maintainer of zathura) [1] Approved by: alexander.4mail@gmail.com (maintainer of zathura-djvu) [2] Approved by: Zsolt Udvari <udvzsolt@gmail.com> (maintainer of zathura-pdf-mupdf) [3]
Diffstat (limited to 'graphics')
-rw-r--r--graphics/zathura-djvu/Makefile15
-rw-r--r--graphics/zathura-djvu/distinfo4
-rw-r--r--graphics/zathura-pdf-mupdf/Makefile10
-rw-r--r--graphics/zathura-pdf-mupdf/pkg-plist2
-rw-r--r--graphics/zathura-pdf-poppler/Makefile13
-rw-r--r--graphics/zathura/Makefile35
-rw-r--r--graphics/zathura/distinfo4
-rw-r--r--graphics/zathura/files/patch-Makefile11
-rw-r--r--graphics/zathura/files/patch-zathura_page-widget.c76
-rw-r--r--graphics/zathura/files/patch-zathura_shortcuts.c20
-rw-r--r--graphics/zathura/pkg-plist1
11 files changed, 160 insertions, 31 deletions
diff --git a/graphics/zathura-djvu/Makefile b/graphics/zathura-djvu/Makefile
index f295457e2759..0129973439ec 100644
--- a/graphics/zathura-djvu/Makefile
+++ b/graphics/zathura-djvu/Makefile
@@ -2,22 +2,31 @@
# $FreeBSD$
PORTNAME= zathura-djvu
-PORTVERSION= 0.2.3
-PORTREVISION= 1
+PORTVERSION= 0.2.4
CATEGORIES= graphics
MASTER_SITES= http://pwmt.org/projects/zathura/plugins/download/
MAINTAINER= alexander.4mail@gmail.com
-COMMENT= The zathura-djvu plugin adds DjVu support to zathura
+COMMENT= DjVu support for zathura
+
+LICENSE= zlib
+LICENSE_NAME= zlib license
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
LIB_DEPENDS= libdjvulibre.so:${PORTSDIR}/graphics/djvulibre
BUILD_DEPENDS= zathura:${PORTSDIR}/graphics/zathura
RUN_DEPENDS= zathura:${PORTSDIR}/graphics/zathura
+PLIST_FILES= lib/zathura/djvu.so share/applications/zathura-djvu.desktop
+
USE_GNOME= glib20 gtk30
USES= desktop-file-utils gmake pkgconfig
PLIST_FILES= lib/zathura/djvu.so \
share/applications/zathura-djvu.desktop
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/lib/zathura/djvu.so
+
.include <bsd.port.mk>
diff --git a/graphics/zathura-djvu/distinfo b/graphics/zathura-djvu/distinfo
index 7ef3894ae6eb..0e4267506616 100644
--- a/graphics/zathura-djvu/distinfo
+++ b/graphics/zathura-djvu/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zathura-djvu-0.2.3.tar.gz) = c16e82d525012b788fd01c4189df93708fcffffb7dd34ca09db55005d644ed89
-SIZE (zathura-djvu-0.2.3.tar.gz) = 11181
+SHA256 (zathura-djvu-0.2.4.tar.gz) = ac10b8c07fd9f58281225e1a4cb026634cd03bf6b549eaceeea02f99ab5334bc
+SIZE (zathura-djvu-0.2.4.tar.gz) = 11197
diff --git a/graphics/zathura-pdf-mupdf/Makefile b/graphics/zathura-pdf-mupdf/Makefile
index e8c55712d92f..57d4be2b8e85 100644
--- a/graphics/zathura-pdf-mupdf/Makefile
+++ b/graphics/zathura-pdf-mupdf/Makefile
@@ -3,14 +3,15 @@
PORTNAME= zathura-pdf-mupdf
PORTVERSION= 0.2.7
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://pwmt.org/projects/zathura-pdf-mupdf/download/
MAINTAINER= udvzsolt@gmail.com
COMMENT= MuPDF render PDF plugin for Zathura PDF viewer
-LICENSE= pwmt
-LICENSE_NAME= pwmt license
+LICENSE= zlib
+LICENSE_NAME= zlib license
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
@@ -18,9 +19,10 @@ BUILD_DEPENDS= zathura:${PORTSDIR}/graphics/zathura \
mupdf>=1.5_1,1:${PORTSDIR}/graphics/mupdf
RUN_DEPENDS= zathura:${PORTSDIR}/graphics/zathura
-MAKE_ARGS= MUPDF_LIB=-lmupdf_pic OPENSSL_INC=-I${OPENSSLINC} \
- OPENSSL_LIB="-L${OPENSSL_LIB} -lcrypto"
+PLIST_FILES= lib/zathura/pdf.so share/applications/zathura-pdf-mupdf.desktop
+MAKE_ARGS= MUPDF_LIB=-lmupdf_pic OPENSSL_INC=-I${OPENSSLINC} \
+ OPENSSL_LIB="-L${OPENSSLLIB} -lcrypto"
USES= desktop-file-utils gmake pkgconfig
USE_GNOME= glib20 gtk30
USE_OPENSSL= yes
diff --git a/graphics/zathura-pdf-mupdf/pkg-plist b/graphics/zathura-pdf-mupdf/pkg-plist
deleted file mode 100644
index 2a8d627b2210..000000000000
--- a/graphics/zathura-pdf-mupdf/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-lib/zathura/pdf.so
-share/applications/zathura-pdf-mupdf.desktop
diff --git a/graphics/zathura-pdf-poppler/Makefile b/graphics/zathura-pdf-poppler/Makefile
index b555eb62e07a..ae0838250e6e 100644
--- a/graphics/zathura-pdf-poppler/Makefile
+++ b/graphics/zathura-pdf-poppler/Makefile
@@ -3,17 +3,25 @@
PORTNAME= zathura-pdf-poppler
PORTVERSION= 0.2.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://pwmt.org/projects/zathura/plugins/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Poppler render PDF plugin for Zathura PDF viewer
+LICENSE= zlib
+LICENSE_NAME= zlib license
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
LIB_DEPENDS= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
BUILD_DEPENDS= zathura:${PORTSDIR}/graphics/zathura
RUN_DEPENDS= zathura:${PORTSDIR}/graphics/zathura
+PLIST_FILES= lib/zathura/pdf.so \
+ share/applications/zathura-pdf-poppler.desktop
+
USE_GNOME= glib20 gtk30
USES= desktop-file-utils gmake pkgconfig
@@ -22,4 +30,7 @@ CONFLICTS= zathura-pdf-mupdf-[0-9]*
PLIST_FILES= lib/zathura/pdf.so \
share/applications/zathura-pdf-poppler.desktop
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/lib/zathura/pdf.so
+
.include <bsd.port.mk>
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index 41e5af8d05ac..110614268a29 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -2,13 +2,18 @@
# $FreeBSD$
PORTNAME= zathura
-PORTVERSION= 0.2.9
+PORTVERSION= 0.3.2
CATEGORIES= graphics print
MASTER_SITES= http://pwmt.org/projects/zathura/download/
MAINTAINER= quentin.stievenart@gmail.com
COMMENT= Customizable lightweight pdf viewer
+LICENSE= zlib
+LICENSE_NAME= zlib license
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
libgirara-gtk3.so:${PORTSDIR}/x11-toolkits/girara
BUILD_DEPENDS+= rst2html:${PORTSDIR}/textproc/py-docutils
@@ -16,25 +21,19 @@ BUILD_DEPENDS+= rst2html:${PORTSDIR}/textproc/py-docutils
USE_GNOME= glib20 gtk30
USES= gmake pkgconfig
MAKE_ENV= SFLAGS="${STRIP}" \
- RSTTOMAN=${LOCALBASE}/bin/rst2man
+ RSTTOMAN=${LOCALBASE}/bin/rst2man \
+ ZLIB_INC= \
+ ZLIB_LIB=-lz
OPTIONS_DEFINE= NLS SQLITE
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSQLITE}
-LIB_DEPENDS+= libsqlite3.so:${PORTSDIR}/databases/sqlite3
-MAKE_ENV+= WITH_SQLITE=1
-.else
-MAKE_ENV+= WITH_SQLITE=0
-.endif
+SQLITE_LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
+SQLITE_MAKE_ENV= WITH_SQLITE=1
+SQLITE_MAKE_ENV_OFF= WITH_SQLITE=0
+NLS_USES= gettext
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-.endif
+.include <bsd.port.options.mk>
post-patch: .SILENT
${REINPLACE_CMD} -e 's|man[15]|man/&|g' \
@@ -42,6 +41,8 @@ post-patch: .SILENT
${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's|PLUGINDIR ?= .*$$|PLUGINDIR ?= ${PREFIX}/lib/zathura|'\
${WRKSRC}/config.mk
+ ${REINPLACE_CMD} -e '/^CC /d'\
+ ${WRKSRC}/colors.mk
.if ! ${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} -e '/-C po/d'\
${WRKSRC}/Makefile
@@ -52,7 +53,7 @@ post-patch: .SILENT
-e 's/DL_LIB /#&/' \
${WRKSRC}/config.mk
${REINPLACE_CMD} -e 's|/etc|${PREFIX}&|g' \
- ${WRKSRC}/config.h \
+ ${WRKSRC}/zathura/config.h \
${WRKSRC}/doc/man/zathurarc.5.rst
(cd ${WRKSRC}; ${RM} -f zathura.1 zathurarc.5)
diff --git a/graphics/zathura/distinfo b/graphics/zathura/distinfo
index 53eed9721c41..d54c0647eff0 100644
--- a/graphics/zathura/distinfo
+++ b/graphics/zathura/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zathura-0.2.9.tar.gz) = 2c071d403ec9348b839567b2897850bf29d9c24c85982b5509a1a429a72ee09f
-SIZE (zathura-0.2.9.tar.gz) = 196690
+SHA256 (zathura-0.3.2.tar.gz) = fda6503dc5b21f7c667301798fbd2c978897e68b4555e8c731945cecd9d165e2
+SIZE (zathura-0.3.2.tar.gz) = 202943
diff --git a/graphics/zathura/files/patch-Makefile b/graphics/zathura/files/patch-Makefile
new file mode 100644
index 000000000000..6854c78fb623
--- /dev/null
+++ b/graphics/zathura/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2014-11-09 22:50:01 UTC
++++ Makefile
+@@ -12,7 +12,7 @@ LIBS += $(SQLITE_LIB)
+ SOURCE = $(OSOURCE)
+ CPPFLAGS += -DWITH_SQLITE
+ else
+-SOURCE = $(filter-out database-sqlite.c,$(OSOURCE))
++SOURCE = $(filter-out ${PROJECT}/database-sqlite.c,$(OSOURCE))
+ endif
+
+ ifneq ($(WITH_MAGIC),0)
diff --git a/graphics/zathura/files/patch-zathura_page-widget.c b/graphics/zathura/files/patch-zathura_page-widget.c
new file mode 100644
index 000000000000..4b092ed1e3ab
--- /dev/null
+++ b/graphics/zathura/files/patch-zathura_page-widget.c
@@ -0,0 +1,76 @@
+X-Git-Url: https://git.pwmt.org/?p=zathura.git;a=blobdiff_plain;f=zathura%2Fpage-widget.c;h=ad27c273f1ba04b66dd8a84337febec3729a68af;hp=309f63321cdbc27694fcba964faa3c4ecc48295f;hb=8d71a755d648c5856ef91d214bfdb46925f6c2f0;hpb=10f3da57c65a8ed7d4d3beff3e49da2bcddcf7a7
+
+diff --git zathura/page-widget.c zathura/page-widget.c.orig
+index 309f633..ad27c27 100644
+--- zathura/page-widget.c
++++ zathura/page-widget.c.orig
+@@ -28,8 +28,8 @@ typedef struct zathura_page_widget_private_s {
+
+ struct {
+ girara_list_t* list; /**< List of links on the page */
+- bool retrieved; /**< True if we already tried to retrieve the list of links */
+- bool draw; /**< True if links should be drawn */
++ gboolean retrieved; /**< True if we already tried to retrieve the list of links */
++ gboolean draw; /**< True if links should be drawn */
+ unsigned int offset; /**< Offset to the links */
+ unsigned int n; /**< Number */
+ } links;
+@@ -37,12 +37,12 @@ typedef struct zathura_page_widget_private_s {
+ struct {
+ girara_list_t* list; /**< A list if there are search results that should be drawn */
+ int current; /**< The index of the current search result */
+- bool draw; /**< Draw search results */
++ gboolean draw; /**< Draw search results */
+ } search;
+
+ struct {
+ girara_list_t* list; /**< List of images on the page */
+- bool retrieved; /**< True if we already tried to retrieve the list of images */
++ gboolean retrieved; /**< True if we already tried to retrieve the list of images */
+ zathura_image_t* current; /**< Image data of selected image */
+ } images;
+
+@@ -52,7 +52,7 @@ typedef struct zathura_page_widget_private_s {
+ int x; /**< X coordinate */
+ int y; /**< Y coordinate */
+ } selection_basepoint;
+- bool over_link;
++ gboolean over_link;
+ } mouse;
+ } zathura_page_widget_private_t;
+
+@@ -313,13 +313,13 @@ zathura_page_widget_set_property(GObject* object, guint prop_id, const GValue* v
+ case PROP_DRAW_LINKS:
+ priv->links.draw = g_value_get_boolean(value);
+ /* get links */
+- if (priv->links.draw == true && priv->links.retrieved == false) {
++ if (priv->links.draw == TRUE && priv->links.retrieved == FALSE) {
+ priv->links.list = zathura_page_links_get(priv->page, NULL);
+- priv->links.retrieved = true;
++ priv->links.retrieved = TRUE;
+ priv->links.n = (priv->links.list == NULL) ? 0 : girara_list_size(priv->links.list);
+ }
+
+- if (priv->links.retrieved == true && priv->links.list != NULL) {
++ if (priv->links.retrieved == TRUE && priv->links.list != NULL) {
+ GIRARA_LIST_FOREACH(priv->links.list, zathura_link_t*, iter, link)
+ if (link != NULL) {
+ zathura_rectangle_t rectangle = recalc_rectangle(priv->page, zathura_link_get_position(link));
+@@ -338,7 +338,7 @@ zathura_page_widget_set_property(GObject* object, guint prop_id, const GValue* v
+ }
+ priv->search.list = g_value_get_pointer(value);
+ if (priv->search.list != NULL && priv->search.draw) {
+- priv->links.draw = false;
++ priv->links.draw = FALSE;
+ redraw_all_rects(pageview, priv->search.list);
+ }
+ priv->search.current = -1;
+@@ -355,7 +355,7 @@ zathura_page_widget_set_property(GObject* object, guint prop_id, const GValue* v
+ priv->search.current = girara_list_size(priv->search.list);
+ } else {
+ priv->search.current = val;
+- if (priv->search.draw == true && val >= 0 && val < (signed) girara_list_size(priv->search.list)) {
++ if (priv->search.draw == TRUE && val >= 0 && val < (signed) girara_list_size(priv->search.list)) {
+ zathura_rectangle_t* rect = girara_list_nth(priv->search.list, priv->search.current);
+ zathura_rectangle_t rectangle = recalc_rectangle(priv->page, *rect);
+ redraw_rect(pageview, &rectangle);
diff --git a/graphics/zathura/files/patch-zathura_shortcuts.c b/graphics/zathura/files/patch-zathura_shortcuts.c
new file mode 100644
index 000000000000..067a64416fe2
--- /dev/null
+++ b/graphics/zathura/files/patch-zathura_shortcuts.c
@@ -0,0 +1,20 @@
+X-Git-Url: https://git.pwmt.org/?p=zathura.git;a=blobdiff_plain;f=zathura%2Fshortcuts.c;h=93182c0835f3c41157637f7d2b78dbb7ff3b1328;hp=0e6ca6349a529a9faff75f2a445f7cf0b7a3c98c;hb=8d71a755d648c5856ef91d214bfdb46925f6c2f0;hpb=10f3da57c65a8ed7d4d3beff3e49da2bcddcf7a7
+
+diff --git zathura/shortcuts.c zathura/shortcuts.c.orig
+index 0e6ca63..93182c0 100644
+--- zathura/shortcuts.c
++++ zathura/shortcuts.c.orig
+@@ -861,9 +861,11 @@ sc_search(girara_session_t* session, girara_argument_t* argument,
+ const unsigned int num_pages = zathura_document_get_number_of_pages(zathura->document);
+ const unsigned int cur_page = zathura_document_get_current_page_number(zathura->document);
+ GtkWidget *cur_page_widget = zathura_page_get_widget(zathura, zathura_document_get_page(zathura->document, cur_page));
+- bool nohlsearch, first_time_after_abort, draw;
++ bool nohlsearch, first_time_after_abort;
++ gboolean draw;
+
+- nohlsearch = first_time_after_abort = draw = false;
++ nohlsearch = first_time_after_abort = false;
++ draw = FALSE;
+ girara_setting_get(session, "nohlsearch", &nohlsearch);
+
+ if (nohlsearch == false) {
diff --git a/graphics/zathura/pkg-plist b/graphics/zathura/pkg-plist
index 1ed487e37555..78cca23b88ec 100644
--- a/graphics/zathura/pkg-plist
+++ b/graphics/zathura/pkg-plist
@@ -9,6 +9,7 @@ include/zathura/version.h
libdata/pkgconfig/zathura.pc
man/man1/zathura.1.gz
man/man5/zathurarc.5.gz
+share/appdata/zathura.appdata.xml
share/applications/zathura.desktop
share/dbus-1/interfaces/org.pwmt.zathura.xml
%%NLS%%share/locale/ca/LC_MESSAGES/zathura.mo